Lutron Caseta Can Not Add New Switch to SmartThings

I added a new Lutron PD-5WS-DV-WH switch successfully to the Lutron app. I can control it with the Lutron app.
However the new switch does not show up in the Smartthings app when I try to add the device. (My previous 4 Lutron switches are still there and still work. I rebooted the SmartThings hub as well as the Lutron hub and still no luck

If you open Automation: Lutron Caseta (Connect) are they discovered there?

The old switches are still there but the added one does not show up

I’m having the same issue. Did you figure out how to fix this?

I had this happen to me over the weekend. I force closed the ST app and retried. Worked for me.

Looks like there’s a delay between when you add the device and when it syncs to become available in SmartThings. Support said it could take up to 2 hours. It took about 45 minutes in my case and then was available in the ST app.

It has been 8 hours now and still seeing same issue. New Caseta switch not being seen but all others are seen just fine. Has anybody seen it take this long?

Just checking… you are opening the Lutron Caseta (Connect) smartapp? have you tried rebooting your ST hub?

Yes - using the Lutron SmartApp…
It is showing up now though - i guess just took time.

I added 2 new dinners and 2 switches. I can see them in the Lutron app but not in ST. Tried rebooting my hub but that didn’t work. It’s been almost 12 hours since I added them to the Lutron app. One thing I notice is ST doesn’t ask me for my username / password to Lutron. It just goes straight to 0 devices foundation through Lutron connect in ST. Anyone know how’s I might resolve this?

1 Like

I am having the same issues. I have not added devices to Lutron in quite a while. I added 4 new devices 3 days ago. When doing that, the wizard in the Lutron app prompts for what room, etc.
Works great using the separate Lutron app.

Within Smarthings, it never finds the lights.

Here is what I noticed now: in my Lutron app, my previously added lights were never entered into a “room”, they were in a category called “My Home”. I now changed those old lights and added them to rooms.

In Smarthings they are now showing as “unavailable”.

I cannot see under Automation/Smartapps how to check the Lutron id/password. I did try to go into that and remove. it tells me An Unexpected error occurred. My guess is this is because my devices are in use in several scripts.

Not sure how to get my device in.

Any thoughts?

Same here. I’ve not been able to get Lutron Caseta Connect smartapp to recognize my last three switch installs. So frustrating! I’ve rebooted both. Tried everything I know to do. Still nothing. Tried to remove the smartapp and start over but it will not let me. Errors out every time. Perhaps I need to remove all the caseta devices first?

Hopefully everyone is reporting these issues with ST support :slight_smile:

Their response was “hey keep trying, eventually they’ll show up and you can add them.”… I moved to Hubitat.

Support was able to help me. They had to remove the Lutron Connect smartapp. The I reinstalled and everything has been working fine ever since.

Pretty pathetic that 2 years later this still has not been fixed. Same problem here.


Hi Thomas,
Have you had any luck? I have multiple Caseta dimmers installed that work fine. I added another dimmer last night, and can’t get smartthings app to find it. So frustrating.


So this was happening to me. Installed a dozen new devices through the lutron app and then added new device, lutron, caseta in smartthings. It wouldn’t discover them.

After a couple week of it not working I just tried to add again and nothing.

Unplugged my lutron and smartthings hubs for 30 secs. Just went to add again in the smartthings app (without even closing the app, just hit add new again) and they were discovered instantaneously!

1 Like

I see above that @jimimoore had support delete the app and reinstall. I was thinking of doing this myself but wondered does anyone know whether it’s something you can do without support’s help?

This is the MOST PATHETIC AND USELESS “support” I have seen in a long time. THREE or FOUR YEARS with the same problem and nobody at Smartthings gives a shit fixing this???

I wish I had selected a different application for my home automation.