Lutron Caseta Issue


(Stephen) #1

Anyone out there using the Lutron Caseta integration? I am having trouble adding additional devices. I open the Lutron Connect app to discover the new devices and it says there are zero new devices discovered. I thought about deleting everything and re-adding but I get an error when trying to delete. Any info would be greatly appreciated.


Error with Lurton Casetta Connect
(Stephan H.) #2

I havent had to add any new lutron devices so I’m not aware of any issues. My first guess regarding the error would be that you have at least one of your lutron devices included in a smartApp or routine. Make sure you remove them from any automations and try to delete again.


(Stephen) #3

I’d rather stay away from deleting if I can. I was only going to do that as a last ditch effort. I’ll see what support says first. If nothing COBE’s of it, I’ll do what you said. Thanks!


(Zach R.) #4

Hi Stephen,

My name is Zach and I work on Lutron’s Residential Applications Engineering team. We stumbled across your post, and would like to help resolve your issue.

In your post, you mentioned the Lutron Connect app…when discovering devices in the SmartThings app, please make sure you are entering your credentials from the Lutron Caseta app (not the Lutron Connect app). Also, please confirm that the Lutron Caseta app was used to add the new device(s) to your Lutron Smart Bridge before attempting device discovery in the SmartThings app.

If you are still having issues after checking on the items above, send an email to zring@lutron.com with the following info:
-MAC address found on the bottom of your Smart Bridge
-Email address you are using when adding new devices in the SmartThings app

Sincerely,
Zach Ring


(Stephen) #5

Reply sent Zach. I will send the MAC address as soon as I get home. Thanks so much for reaching out. Lutron’ customer service is the best I have ever dealt with.


(Mark) #6

I have the same problem. I’m assuming when the OP wrote “Lutron connect” he is referring to the Lutron integration within the ST mobile app, because that’s what it’s called. However I see in the apple App Store there is an unrelated “Lutron connect” app that appears to be for their other wireless protocols.

I setup a few switches and dimmers in the caseta app. The first time I run Lutron connect in the ST app to add Lutron devices, I can see any Lutron devices that I previously added to the caseta app. However, if I add another switch to the caseta app, any subsequent attempt to add the switch in the ST app fails to discover any additional devices.

I asked ST phone support for help when I ran into this a few months ago. They couldn’t do anything, asked me to email or chat with support. I temporarily bypassed the issue by removing all the Lutron devices from ST and then re-added them all. I haven’t had time to try to deal with this since then. But I have at least one more Lutron switch that I’d like to add eventually, and obviously deleting everything from all smartapps every time isn’t an acceptable work around.


(Eddy) #7

Thanks for taking the time to read this forum
Companies need to take example on you guys


(Zach R.) #8

Hi Mark,

Our Caseta engineering team is currently looking into this. I will be sure to update everyone here with our findings.

Thank you for your patience!
Zach


(Zach R.) #9

You’re very welcome Eddy!


(Stephen) #10

Interestingly enough, I tried to run the discovery again tonight. The new item showed up. I selected them and hit done but continue to get an error. It’s trying!


(Zach R.) #11

Thanks for the update! Are you able to consistently control your Caseta devices remotely (Wi-Fi off) using the Caseta app and the SmartThings app? The symptoms you are seeing are pointing towards an intermittent connectivity issue. Please try the following:

  1. Try to run the SmartThings discovery again…maybe we’ll get lucky
  2. If that doesn’t work, try to immediately open/use the Caseta app with Wi-Fi turned off on your device
  3. Whether you can connect or not, please generate a support file as soon as you can connect to the same network as the bridge (Wi-Fi back on). Do this in the Caseta app by going to Settings>Help>Send feedback.

Please send the support file directly to me at zring@lutron.com…by default, the generated email will be sent to systemsupport@lutron.com.

@marktheknife, please feel free to take the same steps.


(Stephen) #12

Ok, I tried these steps. The discovery in SmartThings did not work. I am able to control the lights through the Lutron app on Wifi and on LTE. I sent the feedback. Hopefully you can find something! Thanks again for all of the help!


(Stephen) #13

Hitting done in the discovery mode still shows “an unexpected error occurred”. Weird.


#14

Stephen, If you PM me your smartthings user name (email) and let me know the time and date when you hit Done and saw “Unexpected error” I can take a look.


(Tyler) #15

I’m experiencing similar behavior did we ever get a resolution on this? I’ve added a slew of devices that don’t get discovered by SmarTthings via Lutron. And I’m unable to remove the Lutron (connect) smartapp.


(Jim) #16

@ZachFromLutron are you still looking into this issue? I am experiencing the same issue… I’ve had my Lurton Caseta system on a Pro bridge for a year, integrated with SmartThings. Today, I removed one switch and added two dimmers to the Caseta system. The new dimmers function correctly via the Caseta app, but SmartThings fails to discover them when I go through the discovery process.


(Stephen) #17

Call Lutron. Their support is awesome and they contacted SmartThings themselves when I had the issue and worked it out in one day.


(Jimi Moore) #18

I am having this exact issue also. SmartThings hasn’t recognized my last three Caseta switches.


(Jason) #19

I contacted SmartThings support and their reply was just to keep retrying and eventually they would show up. Well they haven’t. I also contacted Lutron support and the rep said he doesn’t know much about SmartThings and wasn’t any help. My solution was to migrate to Hubitat with my pro hub it was easy and all my devices are showing up in Hubitat just fine.