Issue with Lutron Caseta - stale status


(Richard Wong) #1

I have connected Lutron Caseta to Smartthings.

One thing I found is if I turned on the wall switches physically, Smartthings is not aware of the status right away. Sometimes the delay is 2-3 seconds, but more often it takes 10-20 mins or longer!!

It is a problem as I rely on the switch status for some of my automation routine.

The status in the Lutron app is always up to date. So it seems like it is only a Smartthings integration issue.

Has anyone run into similar problem? Any suggestion on how to fix it?


(jkp) #2

Have you tried rebooting everything - lutron bridge, SmartThings hub and router?


(Chris) #3

I have a large number of Caseta switches and dimmers and don’t experience this problem with Smartthings. I can use the physical switch and it shows up in Smartthings within a second.

I would try rebooting both hubs and see if that helps. And then try deleting the Lutron smart app and reinstalling in Smartthings.


(Richard Wong) #4

Thanks. Tried unplugged and reboot everything. And re-authorize Lutron to Smartthings. Didn’t work.

When I got the system a year ago. Things seems to work perfectly, but it got into this issue about 4-5 mos back. Seems like a few other folks on Reddit also see similar issues.

The only thing I haven’t tried is to reset SmartThings and restart from factory default. I am trying to avoid it as much as possible given number of devices that I need to reconfigure.


#5

I had something similar where it would show the correct status of he light for a second and then revert back to the status it was at just a minute before. Could never find out what was causing it. Finally moved over to the Pro hub and haven’t had any problem since.


(Chris) #6

I take back my previous comments. This week I’ve been having trouble with some Webcore pistons not firing and traced it back to the same issue but it isn’t just Lutron devices. If I manually turn off my Caseta switches using the physical switch, or any of my aleviton WiFi switches using the physical switch they don’t update in ST for a few minutes. From what I can tell it appears to be anything with a cloud connection to ST and it just started a few days ago for me.


(Richard Wong) #7

Thanks everyone - seems like I am not the only one running into this issue. A few other folks at Reddit also complained about this as well.

See thread: https://www.reddit.com/r/SmartThings/comments/9r6slf/delayed_lutron_status/?st=JNY207EP&sh=094c97c5

Anyone from Smartthings can help?


#8

Same issue here…there is a delay in the status when I physically turn on/off the switch. If I use Alexa, the status updates immediately in ST.


(Josh Weigner) #9

Same issue here, it’s driving me mad. Ive had this issue on and off for over a year. About to dump Smartthings all together.


(Richard Wong) #10

I got in touch with Smartthings support team. However the answer I got was this is a known issue and extremely rare, they don’t know how to fix it. :frowning: