Lutron switch not appearing in “add device”


#1

One of my long-standing in-wall Lutron dimmers stop responding via SmartThings. To my surprise, the switch was missing from the Lutron app. I re-added it to the Lutron app, named it something different, and tried to add it via “add device manually” but it’s not appearing there.
I also cannot delete the old device from SmartThings. When I tap “remove” it does nothing.


#2

I can’t even delete the non-responding Lutron dimmer in the API. It responds with “Lutron Caseta Wall Dimmer deleted”, but the device is still there. And Add Device is still not showing the newly added device via the Lutron app.


(Edward Niedziejko) #3

It might be locked by another integration. Do you have your lutron connected directly to alexa or google assistant? You might have to delete that integration and re-add to remove the old device.


#5

Hmm, I deleted the Lutron skill in Alexa and I still have the same issue. Very weird…my whole Lutron system has been running so well for 2+ years before this.


#6

Deleting and re-adding the device in the Lutron app is not a problem, it’s getting ST to update where I’m running into issues.


#8

:laughing: I wasn’t aware that’s what it was called. After reading your initial comment I downloaded the Lutron Connect iOS app which promptly told me that it was not appropriate for my equipment.
I tried hitting Save in the ST Lutron Caseta (Connect) smartapp and going back in but it didn’t work.


(Edward Niedziejko) #9

Lutron Connect is for radioRA2, I believe. The app just named Lutron is for RA2 select and Caseta.