Lutron Integration - Not working?

I am trying to connect Lutron account with SamrtThings to bring the Lutron Devices accessible in the SmartThings app. Although I am able to connect it (authorize lutron), ST App not displaying the lutron devices (dimmer switches, fan switches). Any ideas? TIA

Just to clarify… you are trying to connect Lutron Caseta?

Yes, my Lutron Caséta hub has about 28 dimmers+switches that I want to access from Smartthings.

Go to the Devices section and see if there is “No Room Assigned” in the list of rooms to see if they are there. If not there, go to Menu > Settings (the cog) and tap on Linked services. Simply click on Lutron in the list to see if they appear there. If not, remove the Linked service and try adding again.

You are using the main SmartThings account and not a shared account?

There are no “No room assigned” and the devices are not shown under the linked Lutron tab either. I had tried unlinking and linking multiple time but no luck. Tried in primary account as well as in shared, same results.

By the way, I know it used to work before all the changes happening at Smartthings, I had these devices working through hubconnect before but again, with the new changes, groovy app stopped working today. So I cleaned up everything and trying use the native cloud integration. Not sure if this integration is broken for new onboarding of Lutron?

remove the linked service in the ST app again, then go to the lutron app and ensure there is no integration for ST there. click the cog > tap on integrations > if ST is linked, remove the integration. Then return to the ST app and add it back.

but you never know if there is an issue due to the changes occurring. If you still can’t get it working, contact ST support.

1 Like

I tried that step, unfortunately it didn’t help either. Will wait till morning and reach out to ST support. Thanks

1 Like

All my Lutron Caseta devices have been working without problems with Smartthings all these months despite Zigbee issues -now resolved. Check within the Lutron App in Settings->Advanced->Integration->Connections if the ST integration is indeed active. I would remove it an re-connect. Also, in ST yo have to “select” all the devices in order for them to work.

Unfortunately, these steps did not work.
So far, I tried - deleting the integration within ST app, reconnecting (both primary account and shared account)
Once linked in ST app, I am able to see Smartthings in Lutron app under integrations. If I remove it in Lutron App, then it gets removed in ST app after few seconds. Re-enabling it in ST app brings it back in Lutron app - but the devices are not listed in ST either under the Lutron tab within ‘Linked services’ are under ‘All devices’ in Devices tab.

The issue is now resolved. Not sure which step resolved but I did following:

  1. removed the integration (ST app and in Lutron app manually)
  2. Restarted the ST hub and Lutron hub
  3. Waited for about 30 mins and enabled the integration in ST app.
  4. The devices are instantly discovered and displayed under “Lutron” and in the devices tab.

Thanks @jkp & @CarlMN for chiming in.

1 Like