LIFX bulb stopped working today

I have a Lifx bulb that has been working for many years. Occasionally it will stop working in SmartThings, and to fix it I simply cycle the power and the bulb will start working again. It stopped responding this afternoon and I have been unable to get it to work in SmartThings.

I still use the Classic app. The bulb works fine in the Lifx app so it is connected properly. So far I have cycled power on the bulb many times, rebooted my router and ST hub (v1).

I really can’t remember how I set this up - it’s probably been 4-5 years. Initially I had a community developed app IIRC, but I believe ST and Lifx had a (semi) official integration. I see info about that on both Lifx and ST web sites. But the mechanism doesn’t seem to exist anymore when I tried to reconnect the cloud accounts. I found no reference to Lifx in the Classic app. (

Any ideas what I can try before contacting support?


click on SmartThings Classic in the link you posted above to see the reference you seek :slight_smile:

LIFX devices are in the process of being migrated so that they no longer use the Groovy device handler.

As part of that, the ability to add LIFX bulbs via the Classic app has been removed.

For this issue, if you open the new SmartThings app (“snowflake” icon) are you able to control the device?

1 Like

I’m running this DTH on my LIFX bulbs. What’s going to happen to them in the new app?

Thanks for the reply. I have never really logged in to the new app. Can I do that without some automatic migration of my automations / devices? I.e. if I log into the new app, will all my current automations still work?

That said, it’s actually very seldom that I use the (classic) app to control the light - only when things go wrong. The light is used in a lot of automations and from Alexa / Google. None of which is currently working.

[Edit] I just noticed in the new app, there are a few (5) of my many devices. And they seem pretty arbitrary as to which ones they are :). The Lifx light is not there.

My understanding is that you can continue to use the custom Groovy DTH but will only be able to use supported capabilities. If the DTH is using unsupported capabilities, those will fail. As mentioned recently elsewhere, there are upcoming changes that will add support for custom capabilities.

1 Like

All 40 of my LIFX bulbs are down and we are unable to control them using Google Assistant like we usually do. This is bush league. When this was a fun Kickstarter I wouldn’t be this upset, but many years and many dollars later the device integeations ought to be up 99.999999% of the time. This isn’t the only service that has disappointed me lately, time for regulatory action to protect consumers who are already all-in and at the mercy of service providers who take that investment for granted.

I attempted a re-sync of your location. Can you force close the new app and check again?

If you are still not seeing your devices, please open a support ticket at

Also lost control of my LIFX bulbs without warning. I’m using the classic app because I still have many DTH’s, etc. and from reading the other thread, we won’t have to move over until everything is sorted out with the new app. Please help on this… Looks like WebCore lost control of it, too, which is not good.

Thank you for your help.

I have never NOT been able to see the device in the app, just not control it via either automations or the app. I also saw it in the new app but was unable to control the Lifx light. I got a network or server error, / try again later.

I’ll open a support ticket tomorrow if it hasn’t started working.

I have also lost control of my LIFX. The new app only has this. No control at all no on/off, color or anything.

Edit: I ended up having to delete the bulb and LIFX connect app and reinstall in the new app to get it back. I am not sure if it is the non groovy version, but at least it is useable. The IDE has placeholder in the type now.

Edit2: reinstalled bulb under the new app is no longer available to webCoRE. It is available to automatons and Alexa (Connect). It is now on the 3rd tier in the Actiontiles device selection and is fully functioning in the panel.

Edit 3: Was able to locate the bulb in webCoRE. It was in the Capability Group 1 under adjustable color lights.

I have this installed now, where do I set up the preferences section? Once this DTH is set up, will WebCore work again?

By preferences do you mean the three dots in the upper right hand corner in the new app.? (Or the gear icon in the upper right hand corner of the classic app). I have been using this DTH for about two years now with WebCoRE.

So something has definitely changed on the back end. My Lifx worked this morning when I tried it out remotely. However, the name of the light is back to something I have changed quite a while ago. Maybe ST restored some old backup?

I do get an error in the Classic app when I go to the settings of the light, but I don’t really care. As long as the automations work, I am 98.5% happy :slight_smile:

Thanks SmartThings for working with us during the transition!

I have experienced recently similar issues with random LIFX bulbs were unavailable. The only thing fixing it is turning the bulb on and off quickly 2 times. The bulb goes back to default colour and brightness. It gets connection again.

Are you still experiencing issues with controlling the LIFX bulbs from SmartThings? I took a look and nothing jumped out indicating an issue. Thanks!

YES! Still 100% down. All LIFX bulbs listed in the ST app but non-responsive. Unable to see where to add another LIFX bulb or even check on the LIFX auth/integration. Using the classic app.

Using the new app I try to add a LIFX bulb and I get a flash of a grey screen then returned to where I select “Lighting”.

All LIFX bulbs still work via LIFX app.

Most annoying part is that none of the LIFX bulbs can be controlled via Google Assistant anymore. For example, when carrying a sleeping infant into the nursery it is nice to say “hey Google, turn off the nursery” and it does.

Ranting because the ST/LIFX integeation went down at the same time as my OnStar and 8 years into the super fun world of IoT I have spent wayyyy too much time troubleshooting and it is all coming to a head. I shouldn’t have to post in a forum that my most commonly used integration has failed, somebody or some algorythm should have noticed already.

Plus more and more LIFX bulbs are starting to fail, and combined with the money and time investment over the years maintaining uptime for all these things I am starting to long for the days of manual switches.

Im on the brink guys, bring me back with effective troubleshooting. Don’t be like Nest with their “oh must be poor WiFi” excuses.

I’m still a classic App user… and my LIFX color light devices were also not working this morning as they have for last 11 months. I tried to migrate to the ericvitale : Better LIFX Bulb Plus custom DTH with my LIFX API and bulb name and that did not work.

:moneybag: Then magically, the bulbs started to function from the classic app and webcore. However the Tile interface, see below, is quite basic. The funny thing is that the stock ST LIFX device handler is missing from the drop down list of DTH’s, but this NEW device handler ‘placeholder’ is now assigned, and it does not appear in the DTH drop down list. I’m not touching it :radioactive:, as it is working, but that is magically weird…

Mine still is not working.

I’m using the classic app. I’m not sure where you input the individual parameters in the preferences section. It mention preferences in the instructions, but doesn’t specific where those preferences are.