LIFX bulbs not working, redux

lifx

(Graham Charles) #1

Like a bunch of people (yes, I searched the forums!) my LIFX bulbs stopped connecting to ST a couple of days ago. (They show in the device list as “unavailable.”) Unlike those people, though (see posts from 5/17, 4/17, and 1/16), I don’t seem to be able to get them back. I have tried:

  • updating firmware (it already was)
  • rebooting everything (bulbs, ST hub)
  • re-logging into the LIFX (Connect) SmartApp
  • revoking auth from LIFX and then re-logging into the LIFX (Connect) SmartApp
  • replacing the device handler with the one from ericvitale (and setting the API Key and Bulb Name, of course)

These steps have all had no effect – the LIFX bulbs still show as “Unavailable” in ST.

The next step, of course, is resetting entirely – removing the bulbs and the SmartApp and re-adding them. That would involve a fair bit of routine re-doing, though, so I thought I’d ask – is there anything I haven’t thought of?

Thanks,

g.


(Eric) #2

you regained control via the native LIFX phone-app? and remained broken via the ST-LIFX-smart-app?

That matches my experience. I had to redo LIFX integration from scratch (which was not a big deal with 3 bulbs). There was no way I found to restart or update the existing configuration to get it to resume operation with ST.

Come to think of it, I’d better see if they still work.


(Graham Charles) #3

Yes, that’s right – I can use them in LIFX app but not ST.

I only have two, but still – recreating might be a bit of a pain. I’m starting to use Trendsetter to make most of my routines work on “groups” and not individual lamps or switches, because you just can’t trust that ST will continue to recognize that particular device.

g.


(Graham Charles) #4

Okay, now I have reset the bulbs, re-added them to LIFX, revoked the SmartThings token at LIFX.

Now, when I re-add the LIFX (Connect) SmartApp and log in to LIFX, I get (0 found) for Select location. Ever more deviltry!

Any thoughts? What a mess.


(Eric) #5

I got nothin’.

I had to start from scratch (I think that I also uninstalled the LIFX-native-phone-app), and there were no extra issues installing after that. About 2 months ago - things change.


(Graham Charles) #6

Turns out it was a firewall. There’s a port you need to open, which as far as I can tell isn’t documented anywhere, or at least not in the generic setup info.

G.


(Benji) #7

Also, LIFX bulbs like to drop off LIFX’s OWN cloud. I discovered this when I was trying to narrow down a similar issue with one of the ST engineers.

I couldn’t control it through ST
I COULD control it through the LIFX app…

Then the engineer pointed out a simple test that I should have tried from the start, could I control it, from the LIFX app, NOT on my local WiFi connection, nope.

Then when I connected back to my WiFi and checked the status of the bulb in the LIFX app, low and behold it showed the LIFX cloud as ‘Disconnected’, hence why ST was unable to control it since it’s a cloud <–> cloud connection.

The only way to get my LIFX bulb to connect to the LIFX cloud again was to power cycle it.