LifX Bulbs Not Working


(Travis Reese) #1

So just a heads up for anyone thinking about buying Lifx bulbs, they currently don’t work with smartthings. Tried connecting them as instructed and get an error message. Talked to support and apparently this is a “known bug that has just popped up in the last few days.”

Apparently there is also a known bug with sharing smartthings access if you try sharing from a smarrthings account to a samsung account. That’s not working either.


(Specter1975) #2

Hope they work this out soon. 90% of my lighting are Lifx.


(might be my fake name?) #3

this must be for adding new bulbs? I have 10 right now that are working fine…


(Specter1975) #4

Correct. I went to add few new bulbs and it kicked them all out. All other supported Lifx integrations are working. Smartthings appears to be the only issue.


(might be my fake name?) #5

@whoismoses didn’t know if you saw this. I know you have a lot of LIFX bulbs. [quote=“Specter1975, post:4, topic:88036”]
Correct
[/quote]


(Eric) #6

@Specter1975 @eric182

LIFX recently made some updates to their API and were idiots about it. They basically made the API much more fragile. Which is bad. Your API should be very accepting of being called and be very strict on what it returns.

Bad LIFX.

They are supposed to be fixing it, but I went a head and updated my device handlers to deal with the more fragile api. I was a little proud of myself because once some of our forum members notified me that they were having issues I seemed to have it fixed before anyone in the LIFX forums and even before LIFX knew they had an issue.

One example of something they broke so you can understand how stupid it was… They removed support for ending the endpoint with a “/”.

For example…

https://api.lfix.com/lights/mylight/

used to work, now you have to do

https://api.lfix.com/lights/mylight

I am surprised the ST DH still hasn’t been updated… but you can use my DH if you want.

LIFX Group of Groups - Treat a group or set of groups as a single device, this one I use a ton.

Better LIFX Bulb - Is it really better, maybe, I like it. I only use this on a couple devices.


(Travis Reese) #7

It won’t let me connect the smartthings and lifx accounts. Says it’s “now authorized” then returns to a screen saying “not authorized.”


(Specter1975) #8

I finally got mine to work. I was not on my home network when I tried setting it up again. Don’t know if that has anything to do with it or not, but I’ll take it.


#9

I purchased 3 additional LIFX BR30s about a week and a half ago. I had no issues with bringing them into SmartThings. I went to Marketplace and Things and selected the LIFX 1000 Color A19 (because they don’t have one for the BR30), connected to LIFX and my bulbs were added to SmartThings baddabing.

So this issue must be real recent.


(might be my fake name?) #10

I’ve been using your DH for a while now. I haven’t updated it since November of last year. Everything is still working fine.


(Eric) #11

Yea, my DH worked 95% of the time. I had a few weird scenarios that I had to fix. However, I did spend a lot of time trying to figure out what was broken with the api and it was just “Command Optimization” was enabled in webCoRE’s latest release. lol


#12

Eric, in that other thread the other day you mentioned that your DH has the ability to adjust the infrared through core and WebCore. Does that capability exist on the device directly as well?


(Eric) #13

The functionality is not enabled on the Group of Groups DH. If you want it there I could probably add it. However, if you are trying to control a single bulb you can use this…

It has custom methods irOn() and irOff() that can be called from CoRE and webCoRE.

BTW, you can have the same bulb using both DHs…


(Travis Reese) #14

Just to update, as of this morning it’s now working again. I was going to go through it to screen shot each screen to show the issue and it worked.


(might be my fake name?) #15

The command optimization With Webcore didn’t really affect me with the LIFX bulbs because I’m activating scenes. I’m not really using the turn on and off commands.

My Pistons using WeMo bulbs had to be modified to account for command optimization.


(Eric) #16

He is making a change shortly related to command optimization.


#17

Good deal. Any chance that you can update the background color to 00a0dc for the ST blue instead of Green?


(Eric) #18

Done. Github.


#19

If you folks out there even think about getting LIFX … DON’T!!! It is a hit and miss. If the bulb works, it is nice but if it doesn’t it is a nightmarish hell to get any one from LIFX customer support to help you. They constantly hide behind " higher than normal volume" responses so they can get away with one light responses … example you post “my bulbs failed to connect to cloud”, wait days for a response, they come back with “what security do you use - WPA/WPA2?”, then another “due to higher than normal volumes”; takes days or weeks to come back for another one liner … I bought 15 different bulbs … minis, A19 gen3, br30 gen3 what have you … one 3 worked!!! Yes, that is 80% that you have to spend your time trying to figure out yourself what the problem is!!! And by the way, these bulbs are NOT cheap!!!


(Eric) #20

@penasco Welcome to the community. I’m glad your first post was a rant. Lots of us have these bulbs working fine. I have 48. I’ve also had to deal with LIFX support a few times. No long wait times.