Kwikset SmartCode 916 is not pairing with Smartthings


(James Wong) #1

Smartthings does not currently support Kwikset SmartCode 916 at the moment. This was confirmed by support. Has anyone managed to get it paired with Smarthings? My hub did not detect it at all. Your help is very much appreciated!


(DLee) #2

The 916 is described as being the same as the 914, just better looking. The specs and internals look the same. I would be surprised if it really won’t pair. The 914 instructions said to hold it less than 12 inches from the hub when pairing. I had problems pairing one of my 914s on arrival and ended it sending it back for a replacement. My suggestion is to make sure you got the Zwave model, not the Zigbee and try un-pairing and pairing again holding 8 inches or so from the hub.


(Josh Fink) #3

I know this is a little old but I was able to get this to pair.

Strangely it took a while. I tried it many times from about 10 feet away to directly on top of it almost. None worked. Then I decided to hit the button to pair and walk away to go to the bathroom, while I was away it paired fine.

Maybe it was me causing some kind of interference. Who knows?

Josh


(Kurt Sanders) #4

I was able to integrate my SmartCode™ 916 Touchscreen Electronic Deadbolt with HomeConnect™ technology to my Smartthings hub on the first try using the Kwikset sync button on the inside of the lock. My Smartthings hub is about 15 feet from the door lock. I am using the User Lock Manager v3.5 Copyright 2015 Erik Thayer to monitor & control the lock.

The door lock responds to my control commands within 1-2 seconds of touching the Unlock/Lock tile on my iPhone.


Front door lockset and garage opener
(Rhys Lynn) #5

Not to dredge up an old thread, but I found this page searching for issues with my 916. I installed and programmed the lock for user PINs but after that I could not get it to pair. I tried many times but it never paired. Long story short, a second 916 arrived and it paired immediately. I assume the radio on the first was defective. Just something to consider when troubleshooting.


(Matt Fink) #6

I’m having issues with this too. I have gone through 2 of them and neither want to connect to smartthings. Had no problems when I had a schlage or other model kwikset… I have tried it from far away and from on top of it the hub and everywhere in between but it just doesn’t find it! I’ve also tried adding it as a general device and a more specific lock…Anyone have any suggestion?


(Kurt Sanders) #7

I was lucky and my Kwikset Smartcode 916 paired right away. I would contact the Kwikset technical support line and see if they can determine if there is a hardware/firmware issue with the lock series you have.

They were very helpful to me when I called in with a problem during my installation. They also remained on the line while I fired up the lock and it connected with the SmartThings Hub.


(Ryan) #8

I was able to pair my SmartCode 916 lock with my SmartThings hub. It worked on the first try. The hub is about 4-6 ft from the front door. I can lock/unlock the lock. I was hoping the app would allow me to set code but it doesn’t look like it.

I wish the instructions that came with the lock were a bit clearer in how to pair. I didn’t see any information on where the pairing button was on the lock until I found this forum.


(Kurt Sanders) #9

Hum… I cannot remember, but did you install the Lock Manager by @ethayer in the SmartThings developer IDE? I have this app installed and configured and it allows quite a lot of added functionality to the Kwikset 916 from within the SmartThings.

@ethayer: Next update to your code, you can add Kwikset 916 to the “Confirmed Locks” list in the readme.markdown:


(Ryan) #10

Yes, I’m working on this. The instructions on the LockManager are a bit confusing. I’ve never used the SmartThings IDE and was hoping to be more of a consumer of this rather than a developer. I’ll have to see how to get it working.


(Kurt Sanders) #11

It’s really not that difficult. The SmartThings Develoiers IDE allows you to cut-and-paste in the plug n play code and then do a save, publish and voila you have more functionality.

You do not have to be a developer. Just create an account, cut and paste code as a SmartThings and My Device, save, publish and it shows up in the SmartThings GUI.


(Roman Aleksanyan) #12

I was able to pare my SmartCode 916 to my Smartthings hub 2 with no problem. My only problem with it is I don’t have full control of the lock, just lock and unlock. I have tried LockManager and all it does is lets me set the title and set mode (away, home and night). I can’t set codes, connect it with other devices or set security options.


(Kurt Sanders) #13

Did you change the default device type to Z-Wave Reporting (zwave-lock.groovy)?


(Patrick Musselman) #14

I had a similar issue with my 916 as well. It paired first time without an issues. Then I installed the User Lock Manager and used the Z-Wave Reporting device type. Tried to install the user codes and it would not take. I was able to lock the door from the ST app and use it in routines without issue. However it would take a very long time to report the lock status. I had to re-pair for it work correctly. I probably went a little overboard but it works as it should now. Her is what I did.

  1. Because I did not want to write done my the smart apps that were associated with the lock, I created a simulated device with the Z-Wave Lock. Then removed what smart apps I had on the real and added them to the simulated lock. Except for User Lock Manager which I removed completely.

  2. Exclude the lock from ST and rebooted the hub.

  3. Factory reset the 916 and pickup in the lock instructions at the door handling steps.

  4. I did not have to do this because my hub was close to the lock but I recommend moving the hub as close as possible to the hub.

  5. Paired the lock with ST.

  6. Updated the device to use the Z-Wave Reporting device type and rebooted the hub again.

  7. Verified that the lock was reporting the correct status right away. Also made sure that I could interact with the lock via ST.

  8. Installed the User Lock Manager and made sure that I was able to add codes and that the door worked with the codes.

  9. Transfer the Smart Apps from the simulated device to the newly paired 916.

  10. Removed the simulated lock.

Overkill but my lock is working as it should with the exception of the battery level status.

Hope it helps. This is a guess but I think the encryption in the lock requires the pair process to be close to the hub.

Pat


(Kurt Sanders) #15

The Battery level mysteriously shows up after either a few days or a week! Not sure why, but many people have reported this strange behavior… Just keep watching for it to arrive!


(Anthony Sevigny) #16

I had this some problem happen to me when I had a new 2GIG controller added, and I tried switching it to Secondary to ST. Then I tried removing the 2GIG and neither controller saw the device. I couldn’t remove it either.

I even did 3 factory resets and it would not include to either controller.

Finally, I went to the 2GIG after separating it and making it Primary, and went to REMOVE DEVICE in the Toolbox, even though it claimed nothing was connected. Then as it was searching I went to the 916 and pressed A to put it in Exclude mode. This worked! The 2GIG said “DEVICE REMOVED from another network”.

Since then, I was able to re-add the 916 to ST with the 2GIG as secondary.

Hope this helps anyone with 2 controllers.


(Ace) #17

I had this issue and almost returned the lock!

I had to take the lock out of my door, reassemble it much closer to my hub. Then run the exclusion process on the lock and most importantly put the smartthings V2 hub in exclusion mode and then press the A button on the lock so as to force it to exclude itself from the hub.

And ONLY THEN, was I able to pair this lock to my hub.


(Brad Whitehead) #18

I had to call kwikset to find this out. Maybe this will help others.
Open the SmartThings app that is connected to your hub.
Dashboard

  • 3 dots in the top right corner
  • My Locations
  • Gear icon in the top right corner of your hub
  • Scroll down and select Hub name ‘ACTIVE’ in green text
  • Z Wave Utilities
  • General Device Exclusion
  • Hit the ‘A’ button on the lock

Then reconnect your lock.
The exclusion tool is hidden away/hard to find.


(Will Rotch) #19

Brad,
Thanks so much for your clear directions here.
I have one of the first 916 z-wave to market that had never been able to pair with my ST v1 or v2
I assumed maybe it was a dud.
You gave me the courage to try again and the explicit exclusion step worked like a charm!!
Yeah, chalk up a victory for the ST community. Thanks
Will


(Yurioyoko) #20

Oh my god! I literally made an account just so I could post here and thank you eternally! This worked for me.