New Smartthings Hub can see Kwikset 910 door locks, but not control them


(Geoff) #1

Hello everyone,

I am new to the Smartthings community, and I am migrating from a Vivint smart home system. I successfully removed all of my Z-wave devices (including two Kiwkset 910 door locks and 5 GE / Jasco toggle light switches) from my Vivint controller and was able to add them all to my new Smartthings (v3) wireless hub (they were recognized by Smartthings as devices).

While my GE / Jasco switches work perfectly with my Smartthings app, I am not able either view the correct status of or issue any commands to the Kwikset 910 door locks. The battery level is always at 0%, the status of the locks does not change when I manually lock or unlock the door locks, and if I try to issue a command, the error “Couldn’t connect to Front Door. try again later.”

I have tried to:

  • Remove (exclude) the door locks from the Smartthings Hub

  • Reset the door locks (by holding down the Lock button while removing / inserting the battery packs

  • Rebooting the Smartthings Hub

  • Moving the Smartthings Hub within two feet of the door lock when pairing

None of these actions has done anything to fix this.

Any other ideas out there? I’d really like to see this work so I can move away from Vivint. Thank you!


(jkp) #2

You can try running a z-wave repair


(Geoff) #3

Thank you for the suggestion. I forgot to mention that I did run a z-wave repair (using the Classic app), and then removed, reset everything, but the problem remains.

Again, no problems with the GE / Jasco switches. They work great! And I’m able to see and pair / unpair the Kwikset locks with any apparent problems. At the same time, it seems like the Smartthings Hub is not really connected to them, since I cannot view battery level, device status, or send commands.

Maybe I try to add it as a custom device?


(www.rboyapps.com - Make your home your butler!) #4

Check if it’s using the correct device handler. Is it a Z-Wave or ZigBee lock?


(Geoff) #5

Thank you, RBoy. It’s a Z-wave lock. I believe it is using the correct device handler, since it is the one that it “discovers” using the SmartThings Classic app and the name of the handler matches the model of my door lock.

Since my last post, I tried the following:

  1. I excluded the lock from the SmartThings Hub.
  2. I also excluded all 5 of my GE / Jasco light switches from the SmartThings Hub. I wanted to make sure they were not somehow interfering with the pairing between my door lock and my SmartThings Hub.
  3. I performed a factory reset on the lock (which wiped out all of my lock codes).
  4. I then rebooted my SmartThings Hub.
  5. Finally, I used the SmartThings Classic app on my iPhone to “Add a Thing” – which after only 6 or 7 seconds found what it determined to be a Kwikset SmartCode 910 Contemporary Deadbolt Door Lock.

I then waited 60 seconds or so before trying to either unlock the door manually or to unlock it from the app. The behavior is the same as before. I can add and remove the lock (pair / unpair) in the SmartThings app without any apparent issues (unpairs immediately, takes about 7-8 seconds to pair), but I cannot actually control it from the SmartThings app once it has been added.

The Kwikset 910 troubleshooting manual suggests the following if you can see the lock in your controller, but cannot control it from the controller:

Problem: The system needs a repeater or router to reach the lock.

Solution: Adding repeaters to your system may help communication between your lock and the controller, especially if they are far away from each other.

(Note: I have the SmartThings Hub only 5 feet from my door lock, so I do not things this should be an issue.)

Problem: The network configuration changed.

Solution: If any repeaters or routers in the system were moved since adding the lock to the system, perform the “rediscover” process in your system’s user interface.

(Note: Would this be applicable to me? I did remove all my Z-wave devices from my SmartThings Hub as stated above.)

Problem: The lock is in sleep mode.

Solution: If the lock has been unable to communicate with the system after multiple attempts, it will go into sleep mode. Lock and unlock the door with a key so that the lock status transmits to the system. If it still does not communicate, remove (exclude/unpair) the lock from your system. Then, pair (add/include) the lock with your system again. If the problem persists, add a repeater or router between the controller and lock if none presently exist in the system.

(Note: I tried using a key to open and close the lock from the outside, and then excluded and repaired the device, but it did not change anything.)

Problem: The light module or switch is not beaming capable.

Solution: (Z-Wave locks) Ensure the light module or switch located between the controller and lock is beaming capable.

(Note: I removed all my locks from my SmartThings Hub, so this should not be an issue – right?)

For some reason, I don’t think this should be so difficult! My GE / Jasco Z-wave light switches work great with the SmartThings Hub. Why not these door locks?


(mike ricchino) #6

My 910 Lock was my 3rd device I ever had, and its been flawless for 5 years. I do use the “Z-Wave Lock reporting” device type, and Lock Manager smart app to control it.

Log in to your IDE and look at the live logging information.


(www.rboyapps.com - Make your home your butler!) #7

Okay so try a few things to narrow it down:

  1. What is the device handler that your lock is using (you can see it in My devices - it should be Z-Wave Lock)
  2. Open IDE Live Logging and then pair your lock, do you see any error messages printed while pairing the lock
  3. In the Live Logging do you see any messages when you try to lock/unlock the lock
  4. Check to see if you manually operate the lock do you see any messages printed in IDE Live Logging

The last two steps will determine the issue most likely. If you see a response from the lock but the lock doesn’t move then it’s likely a lock issue with the motor / z-wave module

If you aren’t seeing any response from the lock but you are seeing commands being sent over the network then it could be a bad z-wave module (it’s known to happen to Kwikset locks after about a year in some cases).


(Geoff) #8

RBoy,

Thank you for outlining these steps for me – they look promising!. As a newbie, I am having trouble with Step 1. :frowning: I have both the SmartThings app and the SmartThings Classic app on my iPhone. Which one do I use to get to My Devices?

Thank you for your patience!


(Geoff) #9

Mike,

Thank you for giving me some confidence that these 910s can work. Since I’m new to SmartThings, please help me understand how to log in to my IDE so I can see the live logging information.

Thank you!


(Geoff) #10

Ok, so I was able to log in to the SmartThings IDE online here (https://graph.api.smartthings.com/), using my Samsung Account, but when I click on My Hubs, I see the following text:

You don’t have any hubs yet. Please use the SmartThings mobile app to claim your hub.

Yet, when I go to the SmartThings app on my iPhone, I can see the SmartThings Hub. It looks like it’s connected. How do I “claim” it?

I can also see my only other Z-wave device in the SmartThings app (my Kwikset 910 door lock), but when I go to SmartThings IDE online and click on My Devices, I see the following text:

You don’t have any devices yet. Add one now.

Thank you for any and all help with this! I’m willing to completely start over with the hub if needed to get this working properly.


(mike ricchino) #11

what does it show if you go to this address? https://graph-na02-useast1.api.smartthings.com/

edit: I should add more detail… there are actually 2 IDE addresses in order to reduce server load on Smartthings side. If nothing shows up, like you are describing, it normally shows up on the other server.


(Geoff) #12

Ok, another update:

Be sure not name your location “Home”, since this title is also used by SmartThings. Once I updated the location name to something else (“Our House”), all of a sudden I could see my Hub and my door lock. The door lock is listed as Z-Wave Lock for device type.

Now just figuring out how to open IDE Live Logging…


(Geoff) #13

Ok, found Live Logging, and a bunch of logs were created when I paired my Kwikset 910 with the SmartThings app.

When I try to unlock the door lock from the SmartThings app, here is the only log file that is generated:
0b952f14-d108-467f-9c1e-577d52e01549 7:22:47 AM: trace [DTH] Executing unlock() for device Front

After several seconds, I see the “Couldn’t connect to Front. Try again later” error in the SmartThings app.

When I try to manually unlock the door, nothing is logged in Live Logging. Nothing happened again when I tried manually locking the door.

Every few minutes I see the following in Live Logging:
0b952f14-d108-467f-9c1e-577d52e01549 7:25:10 AM: trace [DTH] Executing ‘reloadAllCodes()’ by Front

0b952f14-d108-467f-9c1e-577d52e01549 7:25:10 AM: trace [DTH] Executing refresh() for device Front

0b952f14-d108-467f-9c1e-577d52e01549 7:25:10 AM: debug Returning commands for lock operation get and battery get

However, when I check out the device status in the SmartThings app, battery reads 0% and the door status is listed as Unlocked (even though it is really locked).

My Vivint panel has not yet been taken down or turned off. I wonder if I need to go back in and exclude these door locks several times (or turn off the panel completely) to make sure there is no interference between the Vivint panel (which used to be paired with the door locks) and my v3 SmartThings Hub?


(mike ricchino) #14

Battery life always reports 0. that’s just a ST bug.

I suggest adding a new device handler and smart app in the IDE. Directions here: https://github.com/ethayer/lock-manager

These custom devices give a lot more features than the stock ST device type.


(www.rboyapps.com - Make your home your butler!) #15

Sounds like the lock isn’t responding or the response isn’t reaching your hub.

Custom handlers address a specific need. It would be to bring out additional functionality or fix bugs in the locks firmware or other issues. There are many really good/updated handlers out there but getting the basic lock / unlock functionality working would be the first step.

Did you try to look for error messages while pairing the lock? How far is your lock from the hub?

Try these steps:

  1. Exclude your lock
  2. Reboot and power cycle your hub
  3. Reset your lock / remove batteries for 5 minutes
  4. Open IDE Live Logging
  5. Pair your lock and see what messages are printed and copy paste them back here.

Don’t forget steps 2 and 3 and I’ve seen at times these help with some troublesome locks.


(Geoff) #16

Thank you, Mike. I started working the instructions in the link you sent and will have to get back to it when I return from work.

I have a hard time believing that both of my Z-Wave modules for my two door locks have failed at the same time. Yet I feel like the basic functionality should be working with SmartThings. The only thing that makes sense to me is that, somehow, there is a link or tie to the Vivint Z-Wave network – even though I excluded them at the very beginning and there are no Z-Wave devices paired with the Vivint panel.

Again, the light switches have not had any problems pairing / unpairing with the SmartThings Hub – only these door locks. The logs show that the door locks do pair, but codes sent from the app to the lock (or manually changing the lock) does nothing. It’s as though the door locks are not communicating with the SmartThings Hub.

Here is my latest log entries pairing the door lock using the updated SmartThings app:

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:07 AM: debug detecting status for 5fdf1ab0-5002-4919-84c2-b0157b52cb37 : true

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:06 AM: debug updated called

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:06 AM: debug No devices to add, verified devices: [:]

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:06 AM: debug detecting status for 5fdf1ab0-5002-4919-84c2-b0157b52cb37 : true

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:06 AM: trace in ssdpDiscover

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:06 AM: debug scheduled run, numberOfRuns: 6

d4cbbde8-c5d8-48e0-b9ac-d5792f449e53 8:20:06 AM: trace in discovery

Now it seems to be stuck on “Checking Status…”, which is better than before – at least it seems like it’s trying to check the status of the lock (which should be “unlocked”).


(Geoff) #17

Hi RBoy,

The hub is only 5 feet from the door lock. I just removed the door lock and re-added it to the hub using the updated SmartThings app on iOS, but now it’s stuck on “Checking status…” in the iOS device (and according to the Live Logging). Clicking on the tile in the app reads:

“Can’t connect to device. Check device and try again.”


(www.rboyapps.com - Make your home your butler!) #18

Don’t worry about the status in the ST mobile app. The new app uses something called Health Check capabilities. Long story short ignore the app status since it’s in BETA and has many bugs so the status will keep varying.

Your determining test will be, are you seeing a response from the lock in your logs. Once you start seeing that you’re golden.

It’s possible that the pairing process is leaving the lock in an uninitiated state. It’s been known to happen with Schlage locks esp the FE599 and even other devices, rare, but it could be happening with your Kwikset module. A key thing to look for would be if you notice any security failure or key exchange failure or any error in the logs while pairing.

See my previous post for the 5 steps you should try to isolate setup issues with the hub.


(mike ricchino) #19

Yeah it sounds like you will need to reset the lock again.

I believe the procedure for that is to remove the batteries, then reinstall them while holding the lock button. Kwikset 910 lock problems


(www.rboyapps.com - Make your home your butler!) #20

I would recommend one more step.

Instead of using the new SmartThings app, use the Classic app to pair your lock. The reason being that the Classic app notifies you if the hub has an error during the pairing process, like a key exchange or secure inclusion error.

Since both your lock modules are having trouble I’m beginning to wonder if there is an issue with the v3 hub and your specific module during the pairing process.

If so you may need to contact ST support to dive deeper into your hub logs to see what’s going on and where the pairing may be failing.