Kwikset 910 ZWave

Anyone involved in testing the ability to set temporary PIN codes remotely along with push notifications. I have a second home I rent out as a vacation rental and need the ability to perform these tasks. I know that the Vera controller works and was told that Smartthings was testing the ability. Its a great feature of the lock and hope that the ST hub can fully utilize.

I already implemented that capability with my 910 locks. Works like a champ. Thanks to the generous folks in this thread:


1 Like

Being new to smartthings can anyone speak to the ease and reliability of this? Hopefully it becomes integrated soon but in the mean time just want to make sure it will do what I need.

I have the app installed. Setting it up isn’t hard but you definitely get your feet wet in the IDE (development console) But it’s essentially copy and paste.

It is easy to use…however it is rather confusing. To set a code you type in a number for a user (1-100) then you pick a code for that user. You cannot tell which users are already set up, so you may overwrite an existing code if you just put in a random number. Essentially you have to keep a log of what codes you have setup for which user number.

It is a janky patch on glaring hole in usability ST has left open, but it works.


Thanks for the input. I will be installing the lock in April so I will be giving it a go then. Hopefully it will be integrated in the app by then. Have you noticed any issues with reliability? Don’t want to leave the house unsecured accidentally. Does the status in the app itself seem reliable?


Okay - I’ve got a stupid question - how the heck can I get my 910 paired up with my ST hub?

I’ve got my multi-sensor working fine on the front door, got the presence sensor on my keychain fine, got the 910 itself on the front door working great with a PIN code, and I’ve checked to make sure that I’ve got the z-wave daughterboard and that I’ve got brand-new fresh batteries.

The procedure that I can find via googling is “remove the battery pack, hit program 3 times to reset everything, put the battery pack back in, wait for the red LED to go out, hit the white button (B) on the left”. The Kwikset documentation says even less than that, pretty much just “press the left button”. All I get from the ST app (Android 4.4.2, Nexus 5) is “Searching…” after telling it to add another device.

@justinwc80 at launch reliability was pretty lousy, but now it’s pretty good. The app has gotten much better at updating you at the status of the lock, even if it was manually locked or unlocked. The logs even tell you which user code was used to unlock it.

Its not perfect, but most the issues I’ve had is the lock sometimes not responding to a command when it is a part of a mode change with a couple dozen other commands going out to other devices. In this situation the flood of traffic is sometimes too much for it.

I would just make sure which ever lock you get supports the number of usercodes you need. The Schlage touch screen one I got has been great. Its been nearly a year and the batteries are still at 83%

Bill, with my schlage I had to bring the hub within a few inches of the lock for it to pair. That’s all I can suggest as the pairing procedure is different on your kwikset.

Bill, did you ever figure out your issue? I am having the same problem. When I push the button on the upper left a red light comes on for about 5 seconds but the SmartThings app just keeps “searching”

Wanted to send a thanks to @coryds for his help, he was able to illustrate the functionality of the app enough that I feel good about my purchase. I’m hoping that I don’t have the pairing issues you guys seem to be having with the 910. Hope to hear you find a fix soon. Good luck

Is it strange that individuals are able to get this functionality of multiple pins to work but ST themselves don’t?

1 Like

I think for pairing just make sure the lock is very close to your hub when you first try. I actually put mine on a 50 foot Ethernet cable and ran it to the door. For whatever reason a lot of zwave devices dont have nearly the pair range as they do functional range.

They get the range after pairing through the zwave mesh (if one exists).

There is that, but I think thee is more to it. My lock for example has no devices between it and the HUB and wont pair unless the HUB is brought closer. I also remember my first zwave devices I installed required the same, but worked fine when the HUB was moved away…even though no mesh existed at the time.

Any updates from ST on this capability. It looks like someone was able to write a smart app themselves that works so how difficult to include in the ST app? I know many people waiting to transition from Vera because of this. It looks like the revolv boards are full of this request too. Would be great to integrate!

So just saw that revolv added this capability to their hub in a very user friendly way. I appreciate all that went above and beyond to write code but disappointed that months ago I was told it was on the roadmap but nothing has happened.

Worried I hitched my horse to the wrong cart. Hoping it’s coming soon.

Btw, the new location to that above referenced post is Door Locks Fully Supported by ST's

Kwikset locks have to actually be in the locked position before they will sync with the ST hub. My lock was a good 30 feet from the hub when it paired. I had tried everything to get it to work for over 2 hours. I searched the forums and someone suggested to lock it, then pair it. Worked within 10 seconds.

I’m also having trouble pairing my 910 with SmartThings. This is my first z-wave device on the network. It’s not easy to bring the hub within range of the lock (or vise versa).

Any tips would be great!

I"m also having trouble with the 910. I bought a module on eBay that claims to be the latest version 3.2 but who knows? And maybe it has a history – how can I find out. I remove the batteries and press buttons and get beeps and red lights and green lights but never a yellow light. It is about a foot from a range extender just to be safe.

After a day it finally deigned to connected but the commands don’t seem to do anything to the lock. I’m finding all-too-often commands don’t get through to devices or get delayed. I can’t rely on opening my other lock though sometimes it has worked. Need far better diagnostic tools.