Kwikset 910 lock problems


(Greyson Morrow) #1

I’m hoping someone can help me out. I have a Kwikset 910 z-wave lock. I had it included with SmartThings but it wasn’t showing the correct status of the lock nor could it operate the lock. So I did an exclude in SmartThings app and removed the Kwikset lock. Now I can’t get it added again. When I press the button below the Programming Instructions it lights up both red and yellow for about 4 seconds then red for 1 second and then turns off. The app just spins and spins looking for new device.

I took the lock off the door and put it right next to the SmartThings hub and it does the same thing.

I have tried going into the app and doing a general exclude again and same results. I have pulled the batteries, pressed program 3 times and waited 10 seconds. Then put batteries back in and pressed the button and same results.

I’m almost at my breaking point, any advice would be appreciated.


(Matt) #2

Try new batteries? Reseat the Z-Wave Module?


#3

Check out the steps here if you haven’t already:

Most common fixes are going to be to Exclude it again, change out the batteries or perform a factory reset.

How to perform a factory reset:

  1. Remove the batteries
  2. Press and hold the lock button on the keypad
  3. Place the batteries back in (while still holding the button)
  4. The lock will beep three times over the course of 15 seconds or so. After the 3rd beep release the button.

Kwikset 912 Paired but Not Functioning At All
New Smartthings Hub can see Kwikset 910 door locks, but not control them
(Greyson Morrow) #4

Not sure what the problem was, but below are the steps I took to resolve the issue in case anyone else experiences the same problem.

I tried excluding on the SmartThings hub and that wasn’t working at all. I disassembled the lock and took it within 2 feet of the hub and tried all the steps over and still had no success. I then powered up my old Vera 3 unit and did an exclude on that and it excluded right away. I tried to include it in SmartThings and still nothing. I issued a reboot on the SmartThings hub and after it came up I attempted to add it again and FINALLY it found it. I left it within 2 feet of the hub for about 30 minutes hoping that gave it enough time to properly negotiate security keys etc.

The lock finally works. I wouldn’t call it great, but it’s working. It was a pain to get it setup.


(Ellison Chan) #5

This is great advice.
I did the reset and everything connected!

Thanks!