Kwikset 912 Paired but Not Functioning At All


(Rob) #1

I’ve read lots of connectivity issues with the 912 but have not seen the problem I am having…

I am paired, status shows locked (no matter whether I unlock it) and I cannot have the iOS app control the lock whatsoever.

Anyone have this problem and solve it? Lock looks great, touchpad programming works great, paired easy but can’t control lock at all.

Any advice or thoughts for solving would be appreciated!


#2

Bummer. :disappointed: First question, are you using the zigbee or the Z wave model? The zigbee has a ZB in the model number and the Z wave has a ZW in the model number.

I think @brianlees has the Z wave model and he needed to get help from support@smartthings.com to get it working.


(John S) #3

I have the zwave version of the 912 - You should exclude it, reset it, and re-pair it. I forgot the specifics of doing the reset on the lock itself.

Exclude

Then Reset Lock

Then pair again.

Edit: I have two of these and a deadbolt. Once actually paired, they all work quite well.


(Dennis Pelham) #4

I just bought a house that had a Vivint system installed. Part of the system included a Kwikset 912 lock with a z-wave daughter card. The Vivint Skypanel had a button to lock/unlock the door, which worked perfectly, so I know there’s nothing wrong with the lock itself. The previous owners cancelled their Vivint service and we didn’t continue it, so I was only able to interact with a few things and couldn’t add/remove/change any of the hardware or configurations. So I bought a SmartThings Hub to take a more DIY approach.

I performed a General Exclusion on the Kwikset, followed the reset instructions (twice, first pulling the battery and holding down Lock as I replaced it, then again pulling the battery and holding down the Program button, as the manufacturer’s site instructed).

Every single time I try something new, I’m careful to exclude the lock. I’m able to re-pair the lock with no problems at all. But it never does anything except say “Locked”. No status refreshes, no locking or unlocking commands work. I’ve got my hub sitting right next to it, so I don’t think range is an issue.

Do I need to add a piece of hardware that supports beaming or should this thing be able to communicate with the hub regardless from 3 feet away?


(Carl_L) #5

I had this exact same scenario. Previous owner had the lock tied to a Vivint system, but the panel was gone before I moved in. I also did all of the exclusions and resets but like you, the lock would pair but never function and would send no status updates to the hub. I worked with both Smartthings support and Kwikset support for several months. They were both very helpful, but neither could resolve the issue. Smartthings support said that the lock wasn’t properly exchanging security information with the hub during the inclusion process, so even though it heard the hubs commands (the LED on the lock would light every time I sent a command from the hub), the lock would refuse to respond. I finally asked Kwikset support if they would send me a replacement. They asked me to send them a photo of the lock to verify ownership and then sent me a new lock. I installed it in the door, paired it up to my hub and have had no problems since.

I have read several things on the web that suggest that Vivint somehow binds the lock to their equipment so that it will only work with their panel, no matter how may ZWave exclusions or resets you try. Even Kwikset was surprised when a lock replacement solved the issue.

I would suggest asking Kwikset if they will send you a replacement lock.


(Dennis Pelham) #6

I called Kwikset to see if they would send me a new lock, but they said that I’d need proof of original purchase and that warranties don’t transfer between homeowners. They did confirm what you found about Vivint binding the equipment to their system only. Essentially, I’ve got a dud lock now.

Oh well, gives me an excuse to try out a Kevo.