Jasco 14285 40-Amp Outdoor Switch and power metering

Hello, I have a Jasco 14285 or otherwise known as a GE Z-Wave Plus 40-Amp Indoor/Outdoor Metal Box Smart Switch. I have this hooked up to my well pump which is 220v. I did this so that I can monitor when the well pump is running by creating a routine that notifies me if the wattage use is above 100W. The well pump draws about 1400-1500 watts when running. I had issues in the past with running toilets, leaky valves on sprinklers, etc. This way I can know ahead of time if there is a leak somewhere. My well pump should only be running 2-3 times a day on a normal day and when the sprinklers are not running.

Anyway, I find that the power reporting is really not that consistent. I used to get consistent notifications when the pump was running, and slowly the notifications stopped. Sometimes it would work, other times when I know the well pump was running I wouldn’t get anything. I looked in the app, and there was no power event. Almost like it was just not reported or not received by my hub.

As for device handlers, I am using the built in zwave metering switch device handler. I tried using the secured version and it was even worse. One notification might make it through in a week. I have tried doing a zwave network repair, excluding the switch and including it again. Nothing seems to make it better. I mean it was working pretty well when I first installed it, so something changed or got messed up.

One thing I do notice on the device page in the IDE, under Current States. One entry is there called checkinterval and it is set to 1920s which is 32min. Could this be the culprit. Does this device only send out events every 32min? Something about that doesn’t sound right.

Raw description is zw:Ls2a type:1001 mfr:0063 prod:4F44 model:3032 ver:5.55 zwv:6.02 lib:03 cc:5E,6C,55,9F sec:25,85,59,5B,70,2C,2B,32,86,72,5A,73,7A if that helps diagnosing anything.

Any help or suggestions would be much appreciated.

Have you run the pump with the device page on ST open to see if it is showing the correct wattage when the pump is running?

Not on the ST IDE, but on the android app I have watched it when I knew the pump is currently running, and it still showed 0. I don’t know if it’s an issue with the device not actually reporting the change, or my hub not receiving it.

Per the below, the device has some energy configuration options that default to reporting once per month. If you’ve done an exclude/include then the device will likely be back to default.


It’s also possible that you had the device set up previously in some way where the ST hub was polling for the data on a schedule. Maybe a different DTH that you were using handled that.

I think that “energy” report is actually the total KwH over time. The parameter I am looking for is called “power” which is the one that show current wattage being used. I attached some screenshots of the event list as well as the main page for the device on the IDE.

I have only switched device handlers a couple of times, bouncing from zwave metering switch to zwave metering switch secure, and back. The secure one was even worse as far as reporting anything.

Maybe. I had the same thought - it’s not completely clear whether “energy” is meant in the more general marketing sense of the “energy monitoring” feature or if it’s the way your physics professor used the word. I don’t find Jasco to be as informative about their configuration options as I’d like. I would guess it applies to all of the energy monitoring features though based on how this section of the product sheet is worded:

Note that in your event log, you’re getting W, kWh and KVAh reported with the same time stamp. I bet if you were to watch live logging when one of those reports came in you’d see z-wave reports coming in for the other listed data points (the DTH isn’t written to generate events for them though).

I don’t see anything about the device to make me think that it will generate power reports based on a change in consumption. The only options that I see are to set that parameter to a lower schedule and potentially get reports every 5 minutes, or to have the ST hub poll the device on a schedule. The zwave metering switch DTH is set up to poll the device every 15 minutes, which is why it’s giving you better results. I’m not sure why that’s not actually happening every 15 minutes - maybe polling isn’t working as well now that we’re approaching the Groovy DTH sunset.

If you want to try changing the config parameters, you can either try using the Tweaker DTH to change it, or if you want to go through the effort to move this to an Edge driver then I can add a profile for it to my GE/Jasco driver that includes those parameters in settings.

I haven’t mentioned but it seems like you’ve considered the possibility of mesh issues. I’m not too inclined to think that’s the problem here though.

If device was reading 0 watts in the mobile app when the pump was running I would assume the switch is defective or the DTH is not reporting wattage for some reason.

Wattage is an instantaneous reading and I wouldn’t think the reporting interval should affect it.

In the mobile app open the device, go to power meter, click on the bar graph, and select day. It should show the last 30 days. What do you see?

Can you turn the power to the pump on and off using the mobile app?

Are you on ios? I’m on android, I think the app is a little different than on ios. In the ST app, if I go to the device I see Power Meter but there is no bar graph to click and open up. I do have a History tab. All I see there is the same as the Events List in the screenshot above.

As for being able to control the power to the pump via the mobile app, yes, that works fine.

It may not sound like a good way to design a product, but I’m pretty sure that’s exactly how this one works. Here’s someone on hubitat that describes it working that way:

Z-wave devices tend to not report power as frequently as ZigBee since they can flood and crash the network. Better devices like Inovelli will have a threshold for a change to report.

I am on Android. The bar graph in on the upper right corner of the power meter section.

I have a Zooz Z-Wave Plus Power Switch ZEN15 that has a small condensate pump attached to it, and also another ZEN15 with a dehumidifier on it, both in my crawlspace. I have those setup with the same type of routine to notify me when the wattage increases to let me know each is running. Now the condensate pump only runs for about 10-20 seconds, and the ZEN15 reports immediately as is should. The dehumidifier can run for many hours, but those have worked great for close to a year as far as reporting. When the well pump runs it probably runs for 3 minutes or so each time to fill the pressure tank. And it did “seem” to work correctly at the beginning, sometime last year. I had noticed every now and then that I didn’t see a notification recently. I tried cycling the power by shutting off the main breaker to it. That seemed to work most times. Now, nothing seems to get the reports to be consistent.

Anyway, I am in the process of reading through the custom DTH for the ZEN15 to see if there is anything there I can see as to why it works so great and reports as the event occurs. I want to compare that custom DTH to the built in one for a zwave smart metering switch. Maybe there is something to be tweaked? or maybe my device is just defective?

Would you look at that, I never knew clicking there did anything. Thanks! Here is the screenshot.

So it show many days without out power usage, and if someone was home that makes no sense.
But it shows power reading for the last 3 days.

I use the Zooz Power Switch DTH for my 2 old Monoprice plugs. They work well. They are 2 of my last 3 devices using DTHs. Everything else uses Edge drivers.

How long does the well pump run when it comes on?

Open live logging and keep it open/running for 30 minutes (hopefully you get at least two cycles of polling during that period).

Only about 3min or so. I am assuming it has to be running at that exact moment when it polls to the hub every 32min. That really just sounds odd. Maybe that timeout was less at some point but I’m not sure if I should change it. I thought that timeout related to total energy consumption, not power meter reading. I will have to leave the live logging up tonight when the sprinklers are going to see if I catch anything.

I have to read into the edge driver thing. I am way behind on all that. Everything I am using still relies on DTHs. Is it possible to use the Zooz Power Switch DTH on this Jasco 14285? Do I have to exclude and join again to see if it works better?

The 32min is something else. I think the polling is actually happening every 15 minutes based on the way the DTH is written, but with a 3 minute pump run time the polling is only catching the pump when it’s running 3/15 or 20% of the time. You can easily have strings of several days missing it completely with only 2-3 runs per day.

If you open Live Logging in the IDE, you can confirm how often the polling is happening. I’d be interested in seeing Live Logging even running now when your pump isn’t running, just to confirm the polling interval is working. Since you’ve been looking in Event History, you’re only getting part of the story. Events only post if there’s a change from the last event, so you don’t see all the power reports that are consecutive readings of 0W.

The Zooz ZEN15 has better capabilities when it comes to power monitoring. You get instant reports from that because the device can be configured (and is configured by default) to send a report based on a wattage change above a certain threshold. The Jasco device simply doesn’t have that capability. The Zooz DTH will probably act the same as the z-wave secure metering since it doesn’t have polling. That DTH will have the Zooz configuration parameters in the settings menu, which at best will have no effect on your device and at worst will change your device’s configuration parameters (the link in my first post) to something undesirable. I don’t think it’s worth testing, but it’s up to you.

I think your two options to get faster reporting are:

  • Change that configuration parameter to the fastest time - 5 minutes - and the device will send reports without polling. You’ll still miss the pump events about half the time, but you would catch any that last more than 5 minutes, which might still work for you. Or…
  • Configure the handler to poll much more frequently - you might need every minute for your case to work well. If you go this route, you’ll definitely want to look at Edge since the work you put into a DTH would be scrapped in the near future when the Groovy cloud shuts down.
1 Like

Here you go:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

You are correct, every 15 min. So my well pump would have to be running at that exact moment to get a notification. I am surprised I get any at all.

How do I go about your option number one and change that parameter to 5 minutes, at least for now? With ZWave Tweaker I don’t have to exclude and include, right? Just change the DHT. make the change, and change it back? I think I used it once for an Aeotec door sensor but they had detailed instructions.

If I go with option two and increase the polling to one minute, do you think I will make a mess of my mesh. I would only do something like that for something as important as my well pump,