Issues with motion sensors (various makes)

Has anyone else had issues with motion sensors stopping reporting motion over the last few days?
I have some Aqara sensors (temperature, motion and contact) and although the temperature ones appear to work ok the motion sensors have stopped picking up motion completely.

At the weekend I had to swap a battery in a Samsung brand motion/temperature sensor and since I have the sensor reports temperature updates regularly but has totally stopped picking up motion.

With the Samsung sensor I have deleted it from the app (and also the web interface during a second attempt) and then re-added to my setup and both times it adds correctly but still only shows temperature updates.

I know the recent change to Edge drivers has caused issues with some devices so as a starting point I have tried to resolve the issue with the Samsung sensor first as I hope this would be an easier one to resolve but so far no luck.

Anyone else had the same happen or have any ideas what to look at next?


The 1st question is what driver is it using? In mobile app open device tile click on 3 dots in upper right, select driver.

As far as I can see it’s the Smartthings zigbee motion driver. I checked to make sure nothing had changed it unexpectedly when I noticed it wasn’t picking up the motion.


You could try the following Zigbee Sensors Driver.

I’ve added that driver to the hub. When I’ve tried changing to that driver in the web interface it’s giving an error:
Error changing device driver to “Zigbee Sensors Edge Driver [YG] 1.8.16”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.

I’ll try restarting the hub and then updating the driver again later to see if that helps.


That driver may not contain you fingerprints (manufacturing code and model). You may need to search for another driver. You may need to find a different driver.

The most recent issues have largely been with devices that were still using custom device handlers needing to be migrated and there not being any usefully functioning driver to migrate them too, which is why users would have installed custom solutions in the first place. Unfortunately many users weren’t aware they might need to do the same thing again.

Aqara devices would be very likely to need user action as only a few of the later models are in the default drivers. I seem to remember that the temperature sensor was pretty standard, it was the extra bits like atmospheric pressure that needed the custom handling. Otherwise the devices ploughed a lone furrow.

As you suggest, issues with the Samsung branded devices are perhaps less expected.

I’ve tried a power cycle on the hub and it’s still not able to let me select the suggested driver. I’ve found several others that look like they might work that I’ll try and cycle through.

I expected issues with the Aqara devices but not Samsung’s own!


Talking about aqara or samsung sensor is not very explicit, in order to help you it is necessary to know the fingerprints of the devices.

You can try to install the Zigbee Thing Mc driver from my channel to make them pair and see the fingerprints

Also for already connected devices, You can use the smartthings web, advanced users to view and publish the fingerprints of their devices

That is one of the drivers I had installed and was working my way through.

The Samsung motion detector is the version like this one

It had been detecting motion fine until a few days ago when I had to change battery and then it just reported temperature updates.

With the Zigbee Thing Mc driver it shows:

Manufacturer: CentraLite
Model: 3325-S
FingerPrinted_EndPoint.Id: 0x01
App Version: Unknown
ZCL Version: Unknown
Network ID: 0x6FF1
Zigbee EUI: 000D6F000BBADE2D
Device ID: 951e7d85-3fbc-4880-ad83-06bb966e3a18

Server Cluster:
Ep: 0x01={ 0000,0001,0003,0020,0402,0500,0B05 }

Client Clusters:
Ep: 0x01={ 0019 }

Signal Metrics:

It should work fine with the stock driver.

now that it is paired with zigbee thing Mc you can install my zigbee Motion Sensor Mc driver, from same channel, and make a driver change from the app, by clicking on the three dots, top right, menu driver, select another driver.

Once it works, you can install the stock Zigbee Motion Sensor driver and perform a driver change to it.

I’ve set it to the Motion Sensor Mc driver but so far, after a few hours, it still only reports temperature. I wonder if the sensor has somehow got stuck and whether it’s worth trying to remove it again, reset it and re-add it.

I would try deleting the sensor and re-pair it.