Issue with zwave switch and child mc

Replying here, because I think we’re close!

I’m using the “Z-Wave Switch and Child Mc” from @Mariano_Colmenarejo

The enerwave rsm2-plus is specifically device:

This is thankfully listed and covered in the aforementioned driver. But I’m replying to ask for help in controlling the second switch. This device only shows a “switch 1” and never a “switch 2”. Ive confirmed that switch 1 on the actual device comes through as “main”. Switch 2 on the device doesn’t cause any change to show in history at all.

Have others reported this? The ‘native’ edge switch driver (for lack of a better term) for this device had a similar problem. It would enumerate two switches and the app-control for switch 2 would work, but physically input for switch 2 at the wall would never reflect back in the hub/app.

Thank you SO MUCH for the work in supporting so many people. I feel this device must be almost there. Attached is what the app shows, no switch 2.

Hi @jpstewart

In multi-component edge smarttings they decided to call physical switch S1 main and physical switch S2 switch1.
In zwave I decided to keep the same philosophy.

You can create a separate child device for switch1(S2)

When this device was added it worked fine.

Does it pair directly with the controller or is it automatically migrated from a DTH? If so, I would recommend you pair it from scratch with the driver

The child devices used with DTH do not work with any edge driver and must be removed.

Thank you for your reply.

Yes, I have excluded the device (many times now in trying to make this work), confirmed that removes the devices, and re-added the device.

Given what you said, then what I’m seeing (hearing) is that I can toggle the physical switches/ switch inputs at the wall, hear the relay trip/click, however only the first of the input switches is monitored in the driver/app, showing as main turning on/off as I toggle the physical switch.

When I toggle the second physical switch at the wall, there is no event history at all shown for the device, like the app/driver doesn’t see or monitor any changes at all.

I believe the right driver is selected (image below).

Note that this exact behavior happened also with the native edge driver as well. (Two switches seen, app could ‘send’ on/off for both, but second switch changes at the wall never sent a signal to the app.)

A friend has the ‘non-plus’ enerwave rsm2 relay and it’s working great with your driver. So I was hoping this might be quick/easy.

Thank you.

Hi @jpstewart

You would need to send me the logs with the CLI when you hit physical switch 2.

Until the month of August I will not be able to make any changes to the driver

1 Like

Many thanks, no worry on timeline… you are helping everyone :slight_smile:

I have downloaded the cli, and followed some directions for logging. See logs below.

The summary is that there are no events shown at all when toggling the second switch.
I can hear the relay triggering withing the wall, but there are no events in the log whenever the second physical switch is toggled.

I annotated the logs below, but the timeline is, start logging, toggle switch 2, toggle switch 1, toggle switch 2.



F:\Downloads>smartthings edge:drivers:logcat --hub-address 192.168.[_specific IP_]
 »   Warning: The authenticity of 192.168.[_specific IP_]:9495 can't be established. Certificate fingerprint is  [_redacted_]
? Are you sure you want to continue connecting? Yes
 »   Warning: Permanently added 192.168.[_specific IP_]:9495 to the list of known hubs.
 #   Driver Id                             Name
  [_ Many Drivers Removed _]
 11  d58d8432-ea22-4d38-8300-2bd75fdf1358  Z-Wave Sensor
 12  2cbf55e3-dbc2-48a2-8be5-4c3ce756b692  Z-Wave Switch
 13  17c05c19-f008-42e2-aa12-f12f1aae5612  Z-Wave Switch and Child Mc
 14  3fb97b6c-f481-441b-a14e-f270d738764e  Zigbee Button
 15  ccea734e-e56e-4d2c-a259-3b2e1fdebd82  Zigbee Humidity Sensor
 [_ Many Drivers Removed _]
? Select a driver. 13
connecting... connected

[_ Manually toggle switch 2 /// NO LOGS happen ///_]

[_ Manually toggle switch 1... Logs: _]

2023-07-27T16:46:29.175248511+00:00 TRACE Z-Wave Switch and Child Mc  Received event with handler unnamed
2023-07-27T16:46:29.175812136+00:00 INFO Z-Wave Switch and Child Mc  <ZwaveDevice: 40c51c9d-6866-4fa7-a145-d97f9101e852 [2E] (Enerwave Double Relay)> received Z-Wave command: {args={value="ON_ENABLE"}, cmd_class="SWITCH_BINARY", cmd_id="REPORT", dst_channels={}, encap="NONE", payload="\xFF", src_channel=0, version=1}
2023-07-27T16:46:29.195872052+00:00 TRACE Z-Wave Switch and Child Mc  Found ZwaveDispatcher handler in zwave_switch
2023-07-27T16:46:29.196652886+00:00 PRINT Z-Wave Switch and Child Mc  <<<<< zwave_handlers_report in main driver >>>>>>>
2023-07-27T16:46:29.197296469+00:00 INFO Z-Wave Switch and Child Mc  <ZwaveDevice: 40c51c9d-6866-4fa7-a145-d97f9101e852 [2E] (Enerwave Double Relay)> emitting event: {"state":{"value":"on"},"capability_id":"switch","attribute_id":"switch","component_id":"main"}
2023-07-27T16:46:29.201442302+00:00 DEBUG Z-Wave Switch and Child Mc  Enerwave Double Relay device thread event handled
2023-07-27T16:46:33.865732930+00:00 TRACE Z-Wave Switch and Child Mc  Received event with handler unnamed
2023-07-27T16:46:33.866564430+00:00 INFO Z-Wave Switch and Child Mc  <ZwaveDevice: 40c51c9d-6866-4fa7-a145-d97f9101e852 [2E] (Enerwave Double Relay)> received Z-Wave command: {args={value="OFF_DISABLE"}, cmd_class="SWITCH_BINARY", cmd_id="REPORT", dst_channels={}, encap="NONE", payload="\x00", src_channel=0, version=1}
2023-07-27T16:46:33.884212971+00:00 TRACE Z-Wave Switch and Child Mc  Found ZwaveDispatcher handler in zwave_switch
2023-07-27T16:46:33.884970888+00:00 PRINT Z-Wave Switch and Child Mc  <<<<< zwave_handlers_report in main driver >>>>>>>
2023-07-27T16:46:33.885612305+00:00 INFO Z-Wave Switch and Child Mc  <ZwaveDevice: 40c51c9d-6866-4fa7-a145-d97f9101e852 [2E] (Enerwave Double Relay)> emitting event: {"state":{"value":"off"},"capability_id":"switch","attribute_id":"switch","component_id":"main"}
2023-07-27T16:46:33.889143763+00:00 DEBUG Z-Wave Switch and Child Mc  Enerwave Double Relay device thread event handled

[_ Manually toggle switch 2 -- attempt 2 /// NO LOGS happen ///_]

This is strange, if the messages do not reach the hub or are not emitted, the driver cannot do anything.
Have you tried doing a factory reset of the device?

Do you have the manual?

Hi there. Yes. I have held the action button down for ten seconds, after excluding the device, twice already during the troubleshooting process. Then have re-added the device using discovery.

I found the manual online which is what said to do that.

Each attempt has resulted in the same outcome as described. The “main” switch communicates. The second switch does not.

Thank you.

In the manual there is no parameter or command to cancel the operation of the physical switch?

Not that I have seen specifically.

There is an “ALL ON / ALL OFF” configuration and an unsolicited report configuration.

This is the manual I am referencing:

Try to set parameter 3, to value =1 and size=1

Create a configuration device in preferences.

This is the thread for device config

There might be some relevant information in [OBSOLETE] Enerwave ZWN-RSM2 (v1 & v2) & RSM2-Plus —Smart Dual Relay Switch Module - Devices & Integrations / Community Created Device Types - SmartThings Community. It looks like Eric established that the parameter 3 simply didn’t exist on the device despite what the manual suggested and that the way to get switch 2 was to use association group 3 (or something like that - I am not fluent in the terminology).

1 Like

I’ll look at it more slowly later now I’m busy, but what I’ve seen quickly in the dth is that it sets parameter 3 to value 1

def configure() {
	log.debug "configure() called"
    sendEvent(name: "checkInterval", value: 2 * 60 * 60 + 2 * 60, displayed: false, data: [protocol: "zwave", hubHardwareId: device.hub.hardwareID])
    def cmds = []
    cmds << zwave.configurationV1.configurationSet(parameterNumber: 3, configurationValue: [1]).format()
    cmds << zwave.configurationV1.configurationGet(parameterNumber: 3).format()
1 Like

Yeah, I saw that as well. Later on though Eric added:

As well as:

However, its not clear to me where or what in that (obviously) legacy controller maps specifically to: “associate the SmartThings Hub with association group 2

The smartthings hub normally associates itself to every available association group when a new device is added to the network, but that doesn’t always happen, especially with the newer generations.

Normally It’s an easy fix. Because associations are stored in the firmware of the device, you can usually add them with one driver, and then switch to a different driver, and the associations should be maintained. (I say should, because there have been a couple of reports of stock edge drivers, which mistakenly reset parameters. But you can always try it and see.)

So…switch the device to Mariano’s zwave configuration tool.

(EDGE Driver-Mc): Z-Wave Device Config Mc

Then, in the app you can add the hub’s network ID to whichever association groups you want to. In this case, based on what Eric wrote, it is Association group 2, not 3.

Then switch back to the edge Driver that you want to use for everyday use.

I recommend deleting the configuration tool from your hub once you are done with it as otherwise, it might accidentally get paired to other new devices.

But as I said, that’s just what normally happens.

I’ve seen lots of comments on lots of different home automation platform boards, that this specific device, the RSM 2+, doesn’t report the second switch action when manually activated. A couple of people said they were able to fix it by adding an endpoint 0 in the lifeline Association group, but that doesn’t make sense to me, so I don’t know.

1 Like

You can also check and set the association group to the hub with the configurator device


I misquoted it as 3, however I did that because I’d seen in a manual that group 2 was for switch 1 and group 3 was for switch 2 and that had stuck more firmly in my mind.

I am not entirely sure whether or not he was addressing a different issue at that point.

The problem with only switch 1 reporting has been encountered on other platforms and ‘parameter 3’ is usually brought up, even though it sounds like it should affect both switches, not just one. Unfortunately there weren’t any solutions to the problem where I looked.


Well, if there is a parameter three for this model, it will show up on the configurator tool, so you would be able to set it there.

I did see on two other forums that people said they were able to fix the issue in smartthings using the tweaker, but not anywhere else. :thinking: tweaker is no longer available, of course, but the configurator does the same thing, so it seems worth a try. But with leveled expectations.


Welp. Thanks all for the help every. I’ve spent a few days trying to learn a few things.

…I’ve learned this device is a real pain.

Conclusion up front: I’m likely to remove this device from the wall and replace it completely, likely with a zooz model. No blame to anyone here. I appreciate all of the help.

Some notes. A parameter scan never returns. I’ve tried many times and it always sticks on waiting for device. I’ve tried “waking” it. No luck. Regardless, that wasn’t really the goal.

It took me a long time to understand the instructions for the device config tool relative to the association groups. I did eventually find how to associate the hub node on group 2. I made a lot of mistakes here, initially missing the note about the hub ID and using the switch ID instead. Doing so breaks the switch and I had to factory reset again. (Btw resetting, excluding, or adding the device requires removing screws from a live switch and carefully inserting a very long and thin switch in the dark attempting to rapidly hit the program button. The instructions say the switch lines should work for exclusion. It did maybe once. But not reliably. So working with a switch disassembled for a while also limits the ability and motivation to work on this as well. — again, no one’s fault here, but it’s just not great.)

Despite this, the device still did not seem to send any change for switch 1. I also tried setting a parameter 3 as well, but that never seemed to work.

After completing the association to group 2, I also removed the config device, removed the config driver, excluded the switch and re-added it, even resetting it again, testing functionality at each of those steps all along the way after the manual node group inclusion, but still no change in behavior.

I already ordered the zooz switch. I’m not particularly looking forward to switching off the breaker and doing this work. But ah well.

I’m not in a hurry though. Primarily this switch only acted as a scene controller. (The relays have never been connected to anything. They are capped off.) I’ve never found a scene controller that would provide dual real decora rockers for instance, not push buttons. But the “light” devices this scene controller was paired with are outdoor lights running on an fx-luminaire system. (Surprise, no edge driver for these either unfortunately.) Which just means if and when I fix these switches…. I have no lights to control until either A. I learn how to write a lan-connected lua myself… which I could do, but time?? Or B. Someone else writes or ports the Luxor fx luminaire handler. (I’ve posted in the major topics for this already. It’s a niche market unfortunately.)

It’s been kinda a rough few weeks as various switches and lights around our house have all stopped working at once. :confused: :confused:

But again, everyone here has been great for trying to help out. Maybe one day, there will be a better way.



Hi @jpstewart

In case you want to try again
In this version of the driver I added for this model 011A-0111-0606, the association of group 2 with the Hub and the configuration of parameter 3 to value 1.

This configuration is done in the doConfigure lifecycle, so you must exclude it and add it again for doConfigure to run.

 Name         Z-Wave Switch and Child Mc
 Version      2023-08-02T21:40:21.731911078        

Many thanks for your help as always.

Sure. I can give it a shot.