[OBSOLETE] Enerwave ZWN-RSM2 (v1 & v2) & RSM2-Plus —Smart Dual Relay Switch Module

I’m starting to think my issue lies with the virtual switches and/or virtual device sync. Last night I completely lost control from the app, but state changes were still being updated when I flip the switches. I turned on switch 1 in app, then manually turned on the relay in the app, and switch 1 turned on then. My plan is to remove the virtual switched and switch sync and add them again; I haven’t yet because I have a lot of automations tied to those switches so it’s going to be a pain in the butt to do and I don’t have time right now. This is the life of a father with 11-month-old twins. Haha

Well, I think I’m giving up. I removed the virtual switches, removed the switch sync app, excluded the relay. Paired the relay, added switch sync app, created new virtual switches… and still only partial control. I think I’m going to return the relay and buy one from a different manufacturer because I definitely have a sour taste in my mouth from this one.

1 Like

Is this release supposed to support instant physical switch updates with the Enerwave ZWN-RSM2-PLUS (versus the ZWN-RSM2)? When I manually toggle a physical switch connected to the ZWN-RSM2-PLUS nothing shows up in the live logging area of the Smartthings Developer Tools. When a refresh is performed in the app, the status of the physical switch is correctly updated instantly.

The Enerwave documentation states that writing a 1 to parameter number 3 should enable unsolicited reports and it appears that this is being attempted by the device handler, but there are still no instant updates in the Smartthings app.

Using the following code in the device handler for the Enerwave ZWN-RSM2-PLUS I was able to get instant status updates working:

def configure() {
log.debug "configure() called"
def cmds = []
cmds << zwave.configurationV2.configurationSet(parameterNumber:3, size:1, configurationValue:[1]).format()
cmds << zwave.associationV2.associationSet(groupingIdentifier:2, nodeId:[zwaveHubNodeId]).format()
cmds << zwave.associationV2.associationSet(groupingIdentifier:3, nodeId:[zwaveHubNodeId]).format()
delayBetween(cmds, 2000)

1 Like

I installed a ZWN-RSM2-PLUS today in my Son’s Room for Fan and light control and used this device handler with your configure() method. Everything is working perfectly.

Thank you again.

For some reason, parameter 3 is not available on the plus despite what is mentioned in the manual. The work around is to associate the SmartThings Hub with association group 2 as you mentioned.

Does anyone know a code to do a siliar thing with the Enerwave Z-Wave Plus ZWN-RSM1 . I have one hooked up to my hallway light. It’s currently set up as a zwave generic switch. It works, however I don’t get status updates in the app if I use the wall switch, only if I use the app to turn it off and on.

You can try this handler. There is a special way that instant status updates are enabled with this switch. Use the following handler and hit the configure button a couple times.

1 Like

Do you still recommend using Physical/Virtual Device Sync or use the other one you created for the H801?

Use the one that works with the H801 “Virtual Device Sync”. It is an upgraded version of the one mentioned in this post. I say that in the Physical/Virtual thread, but I know it is easy to miss. :slight_smile:

duh… I sure did miss it. :rolling_eyes:

So I would like to use the ZWN-RSM1-Plus to respond to an ST motion detector to momentarily close a relay for about 1 second.

Can this device handler do a momentary on/off?

In another thread I see that there is a device handler to do that with Fibaro but I would like to avoid spending $60 on one and use the RMS1 since I already have one laying around.

There is a device handler that is a default to SmartThings called “Z-Wave Virtual Momentary Contact Switch”. It is very similar to what you are describing but momentarily opens a relay. You should check it out as it would be a great starting place for you.

1 Like

erocm1231 thank you for that tip.

I’m using this device and dth but the switch still isn’t updating. Not sure if I’m doing something wrong. Sucks because I’m trying to use core with this switch in my kitchen to turn on my lightify Leds that are under the cabinets when I turn on the kitchen lights.

Have you tried hitting the “Configure” button in the SmartThings app to push the correct settings to the device?

I have. Doesn’t seem to do anything

Hitting configure should send the configuration parameter that is needed for the device to send status updates to the SmartThings hub . . . unless enerwave has changed something. You could try excluding and including it.

Would hitting configure show anything in the logs on shard? Because it doesn’t log anything when i push configure button in app.

It should log:

“configure() called”

And then in the IDE event list for the device, there will be some configuration Report events. If not, make sure the correct device handler is assigned to the device.