Issue with Green and Blue in Philips Hue Bloom and Iris

hue

#1

Does anyone have any problems with trying to display green and blue colors on the Hue Bloom and Hue Iris? Each time I move the color picker to green, the light will flash the correct green color then change immediately to yellow. For blue, it flashes blue, then change to a gray white.

The color picker was working a couple weeks ago when I tested it. Now, whatever I do, I cannot get green or blue to display using the color picker in the Smartthings app. I can change to the correct colors using the Philips Hue app. If I set the colors using the Hue app, then open the Smartthings app and select one of the lights and hit refresh, the app does not refresh to show the color that is being displayed. I used to do this to migrate my scenes from the Hue app into saved “states” in Smartthings. Now I cannot migrate any scenes with blues or greens since Smartthings cannot refresh itself to display the corresponding color.

Also if I change the device type to use AP Hue Bulb by infofiend, the color picker works correctly but the response time is very slow (>30 seconds delay).

Can anyone help please?


(Jason "The Enabler" as deemed so by @Smart) #2

This is the device type I’m using for my blooms and it works great. The colors are true and response is instant. Follow this link.


CoRE - Get peer assistance here with setting up Pistons
#3

I’ve tried this device type. Still cant get green and blue to display.
Can you try using your set up to pick a shade of green or blue and see it it displays properly?


(Larry) #4

if your green and blue are not correct it could be a defective bulb… they were known from the blues to go out… call phillips i had a few replaced…


#5

Definitely not the bulbs. I have 8 Iris hue bulbs, and 2 blooms, all not working correct with the current Smartthings device types. It is not the bulbs because if I use the Hue app, they all can be adjusted to show greens/blues.


(Larry) #6

could be an older firmware in the bulbs then, that the smartthingnsg does not support. .have you tried updating that… i know mine works fine with green.


#7

yes. I checked in the Hue app (both old and new) for any updates to firmware. All are up to date. These bulbs were working fine with Smartthings before. Something changed and now the hue lights respond very slowly and the colors don’t display correctly. I went as far as doing a factory reset on my Smartthings Hub, but that didn’t make a difference.

Again, if I use the device type AP HUE Bulb by infofiend, I can get green and blue but it lags significantly. The modified device type by Lgkahn improves on the lag, but still cant get green and blue. It does show green and blue for a moment, then changes immediately to yellow (from green) or gray (from blue). It’s as if its resetting to one of the white presets.

Any ideas?


(Jason "The Enabler" as deemed so by @Smart) #8

Do this.
Change the dth to the stock one. Delete the custom. Turn the bulbs on and refresh them. Turn then off.
Reinstall the custom dth and see if that works.

If it’s not the bulbs it has to be the software… But the dth works great on my blooms and iris.


#9

which dth works for you? the default? I also noticed that the default dth for both iris and bloom is just “Hue Bloom”. Are you using LGK Hue Bulb?


#10

ok, I tried switching it to the default device type. Then refreshing it and turning it off. Then switched ti LGK Hue Bulb. Still can’t get it to show green. If I use the Hue app, green shows up fine.

Another thing: When I changed the color to green using the Philip Hue app, then switch to Smartthings and press on the refresh button, Smartthings does not update with the proper color that is showing.


(Jason "The Enabler" as deemed so by @Smart) #11

That is really weird…


#12

I did some more testing. Here’s what I observed:
When I use the Hue app to set the color to green (RGB: 0,120,0), the bulb changes to the correct color. Then when I open the Smartthings app and refresh the bulb, it appears to be stuck on the default yellow preset. I tap refresh a few times, Then I move the picker to the red (a color that displays properly) and the bulb changes to red. I move the picker back to green, the bulb transitions to green for 1 second, then changes to yellow. I tap on the green a couple times, the bulb flashes green and reverts back to yellow. This same thing happens if I try a light cyan-like blue, but instead of turning yellow, the bulb turns white (like a gray white color).

The interesting thing is when I use CoRE and set a piston: If a virtual switch (‘Test Green’) changes to ON, set color to Dark Green.
This works! The bulb turns on and is green. In CoRE, I cannot set the color using RGB or HSL settings. If I try to pick a color with these, the bulb does not turn on. I have to use one of the predefined colors from CoRE’s set color menu.
So in summary, I noticed that the color picker has a glitch that doesn’t allow selection of green or cyan. I tried the default device type and LGK Hue Bulb, both had this problem. The device type from infofiend AP Hue Bulb did not have the green/blue color problem, but was extremely slow to react. Using the Philips Hue app allows for proper color selection so the problem is not because of the bulbs. And finally using CoRE to set the color also works.

I have Hue Bloom and Iris bulbs on software version 5.23.1.13452
The Hue hub is 1st gen on version 01033978

This problem was not present before and I only noticed it this week. I’ve already tried factory resetting the Smartthings hub to no avail.