SmartThings Zwave devices routinely unresponsive

SmartThings has been regularly unresponsive for months now for me. My network is entirely z-wave. 25% of the time the app will simply not control devices. Clicking on or off on the device just spins several seconds, then stops, leaving the device status unchanged.

I’ve called support multiple times, they are always polite but never helpful

Anyone have any help?

How many z-wave devices do you have?
Are all z-wave devices affected or some?
Which hub do you have? Firmware version?
Type of z-wave devices… brand/model and what Edge driver is assigned to them?
Have you run z-wave repair?
You may want to power cycle all your main powered devices… circuit breaker is probably the quickest method. And remove battery from battery powered devices.
Any patterns you have noticed?

I am sure others in the community will give you great advice.

Also, a new hub firmware is in the process of being pushed out to the v2/v3/Aeotec hubs


I have right at 100 Z-Wave devices.
There doesn’t seem to be any particular device that is more or less affected. When SmartThings does this, I can’t control any device.
I have a v2 hub firmware version 000.052.00021 Controller version 2.3.35-5
Most of the Z-wave devices are GE/Enbrighten switches, I have a handful of others. The problem doesn’t seem tied to any particular device(s). the most recent device I had problems with is a GE Heavy Duty wall switch, but while that was going on I couldn’t control ANY devices. I’ve checked history and there’s nothing odd.

I have run z-wave repair; it never seems to finish. I’ve also power cycled the hub and my router, and I’ve uninstalled & reinstalled the app on my phone (Pixel 8).

I haven’t noticed any patterns; it seems just random. Often the devices I’m trying to control will go ahead and work several minutes later. (i.e. if I try to shut off a light and it doesn’t respond, it MAY turn off several minutes later; I’m not sure if it always does later or not.).

I can try power cycling all the devices. That seems unlikely since it seems the problem is random and isn’t tied to any particular device(s). When it happens, all devices are unresponsive.

Are you using the stock Edge drivers for your GE devices or custom Edge drivers?

I think stock; I haven’t installed any custom drivers unless maybe on a couple devices that instructed me too (Aeon Smartstrip and 1 or 2 others). How do I know if I’m running Edge drivers and if they’re stock or not?

If you haven’t custom edge drivers… you would be on stock.

First recommendation for you is to convert as many of those GE devices over to a particular custom Edge drivers.

It may help.

Thank you for help. I’m looking at some of the devices and they all look recent:

Do I still need to upgrade?

Some users who have switched to the custom ones were facing some of the same issues as you and found improvement. I say give it a try. You probably will not get much improvement until you get most switched over but they should be easy after you install the custom Edge driver.

Ok, thank you so much!

OK, the following is unusual, but it has happened to some community members in the past.

Although Z wave is less likely to suffer from local interference than Zigbee, it is possible, and it would produce exactly the kind of symptoms you’re seeing, in particular, the fact that all your Z wave devices become unresponsive for a few minutes and then return.

The most common items in North America that interfere with zwave are some of the older baby monitors, The older cordless phones or a fair number of drones.

We had one community member who found that every time they brought their drone into the garage and left it charging. They would get interference with their Zwave network.

It could also happen if one of your neighbors or your city has a drone that they occasionally fly through your neighborhood.

So the first thing is just to consider whether there’s any new equipment in the area that you’re aware of that might be causing interference. :thinking:


Definitely no equipment like that in the house. I’ve seen no drones and this has occurred at all hours including late at night and early in morning (I know someone COULD operate a drone at these times, but seems really unlikely).

1 Like

Hi, @Jtberr
Please, let us know if changing the device to a custom driver helps, I also find this odd.
The engineering team has mentioned before that when issues like this happen, it can be because the communication “path” between the Hub and the device isn’t clear for some reason.
If the issue persists, we would need more information for the team to look at, it would be great if you could stay with the current drivers and provide such information but I understand that you would like to recover control of your devices sooner rather than later and I don’t know how long the investigation would take.

I’ve switched most all the drivers, to the z-wave switch cs drivers. it doesn’t seem to help. Smartthings is taking 5-60+ seconds to control devices. Further it doesn’t recognize when devices change status for long periods of time. But, this behavior is not consistent. Sometimes it works reasonably well. I’m glad to go back to the other drivers. Can anyone help?

Generally, this kind of thing happens when there’s interference in the environment. It’s important to verify the hub isn’t too close to other devices that emit frequencies like Wi-Fi routers, baby monitors, microwaves, and others.
Also, if devices are too far away from the Hub and need to connect through repeaters, sometimes they don’t handle the load correctly.

If you already checked your network/environment and everything looks normal, we would need you to send more information to open an investigation.

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM
  2. Enable support access to your account:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.
  1. Let us know which device has issues so we can look for it in your account and describe its behavior.
  2. Replicate the issue described and:
    a. Send the Hub logs.
  1. In the Advanced Users app, enter the “Hubs” section
  2. Enter the corresponding Hub and click on “Dump Hub logs”
  3. Confirm the process by clicking on “Dump Hub logs” again in the pop-up.
  4. You’ll get a green box at the top confirming the Hub logs were requested.

b. Take note of the time when you replicated the issue and share it with us including the timezone. For example: 2024/07/16 at 18:00 GMT-6