Inovelli Zwave devices all OFFLINE today

Having issues will all my Inovelli Zwave devices today, Red switches, Black switches, 4-1 motion, RGBW bulbs, etc, all showing offline. The only common thing is they’re all Inovelli branded devices. Anyone else having issues like this? I’ve reset my hub (v3), ran ZWave repair a couple of times, using the air gap on the device has brought some of them back online. Never had issues with a specific brand across so many different type of devices. All of my other ZWave devices are working and online.

Strange. I have Inovelli devices at two locations they’re all working perfectly, both Z-Wave and Zigbee.

IKR, I’ve never just had a “brand” go offline like this. I have some Zooz switches in the same boxes as the Inovelli switches and they’re online, while the Inovelli is offline. It’s also weird that it’s across so many different type of devices, bulbs, switches, motion, smart plug. I’ve got a few back online by using the air gap switch. I guess I’ll wait it out and see if they come back online. I had the RGBW bulbs back online for a while, now they’re offline again. My Ecolink sensors (ZWave) in the same area, working fine. Very confusing.

Just an update, since these devices are still offline:

I had been running the ZWave repair from the Advanced tab on the website, I decided to try running it from my phone and got the following errors. I have 37 entries that say “unknown device”.

Still haven’t figured out the common factor, nothing has been added to my network, nothing moved. Most of the devices are the same vendor (Inovelli), yet the remainder of the ZWave devices are working. I may try a “therapeutic reboot” and see if that works.

There used to be a way in the IDE to see all the logs in real time, does that exist anywhere anymore?
Also, there is a button for “Dump Hub Logs” on the screen with the hub info. Where does that go? I’ve clicked it a couple of times and it asks me to provide a reason, and I’ve done that but I have no idea where these are supposed to be going.

Did you check the Edge driver to ensure it’s still using the proper Inovelli one?

That goes to SmartThings. When you dump logs it asks you for some descriptive info to relay to support, or to put in your ticket number if you have one.

To a certain extent, yes. It’s called the CLI. It’s all command line based, and it takes some getting used to.

Ok, thank you for the info.

I have the CLI program loaded, I looked through the command options but I didn’t see any way to look at things other than devices. I’ll see if I can get more out of it. I was using the API+ web view from TAustin and then the Advanced tab showed up and I’ve been using it for almost everything now.

Yeah, that’s what stinks with the CLI. If you use logcat (smartthings edge:drivers:logcat) without a driver ID the info goes by so fast it’s hard to catch anything.

I don’t use Inovelli’s zwave switches, but I do use all Blues and the new fan switches, but those are Zigbee. Did Inovelli update or do something with the zwave driver?

You could try that logcat command for just the Inovelli driver and see what’s returned. Depending on how many switches are using that driver, info will go by quickly.

IDK, I thought that maybe they updated their Edge drivers, but I have been able to get some of the switches back online using the gap switch. I have found a few non-Inovelli devices that are offline as I’ve gone room by room trying to reset everything. It started out with about 37 devices offline and today it’s down to 22, so it’s “healing” itself. I’ll keep an eye on it, luckily with switches I can just use them manually. ( I know, oh the horror ). It’s not isolated to just one area of my house, I have those switches in every room and detached garage and they’ve all gone offline, but other ZWave devices in the same room or area are working fine. Last time I had an issue like this it was pre-Lua so I could run the logs and see that I had a device just spewing traffic. Seems harder to diagnose issues now.

Here’s the latest update on my ZWave devices issue. I shut my hub off for about 8 hours yesterday. I pulled the airgap on the affected switches and unplugged the other devices. I then plugged the hub back in. About half of the devices are working again, the other half stayed online for 15-30 minutes and when offline again. If I unplug them or pull the airgap, they will come back online but only for a short time. Today I took drastic measures and began excluding and re-including the devices. This, so far, has worked. The devices came back online and have been able to be controlled and are staying online. This is giving me flashbacks to the move over from Groovy to Edge. At least the routines don’t disappear anymore, but it’s still a pain to locate the routines and add the devices back in. Also, since I use Google Home as my voice control, that means reconfiguring them in GH and adding them back into those routines. This is a huge pain, and since there really isn’t any reason for it, it’s a little concerning. Some of the exact same devices in other rooms were unaffected, it seems quite random and is leaving me somewhat uneasy as to if this will happen again. Since nothing changed recently on my end, and just one day about 37 devices (all ZWave) just stopped working, I’m a little concerned. At least, it does seem fixable, if not a little frustrating.

Well, the saga continues. I got all the offline ZWave devices excluded/included yesterday, only to wake up today to 15 more offline. These are not the same devices, these are the ones that seemed immune to the original issue. So, I guess I’ll spend today excluding and re-including 15 more devices. Hopefully this will be the end of it. I haven’t had any of my ZWave leak sensors go offline… yet. I’ve got at least 7 or more of those around the house. This is so weird. None of my ZigBee devices have been affected and none of the ZWave devices I’ve added in the last 6 or so months have disappeared.

Hi @ericreed5280 , you definitely have something odd going on with your zwave mesh. Quite honestly, this is the reason why i have all but abandoned zwave on ST’s platform. For me and many others, once we got beyond ~30ish devices, the mesh became unreliable and difficult to diagnose issues. I also think ST’s zwave implementation still has issues, but now that i only have two zwave devices left and my zwave issues have gone away, i can’t provide any info to support my theory.

Anyway, it almost sounds like you have a zwave device behaving badly in your mesh, or is failing, or it’s routing table has been corrupted. That type of scenario is difficult to figure out. In the past when I had zwave issues like this and I was trying to diagnose things, I power cycled all my zwave devices to see if that did anything. I basically “rebooted the house” by tripping every breaker. It’s not fun, but not as thermonuclear as excluding and rejoining devices.

Well, most of the devices I deleted and re-included have gone offline again. I’ve ordered a new ST’s hub and I’m going to move all my devices off the current hub manually. I’d like to try the new migration tool, but I don’t want to replicate any device that may be causing the issue. Once it arrives, I’ll manually move the devices off the old (V3) hub to the new one and then factory reset the old hub. I think I’ll move it to my detached garage and put all the devices out there on their own hub. I checked my ZWave device ID’s for the devices I just re-included and I’m already up to HEX id A9, not sure what happens when you get to FF, but I don’t want to find out. I think it’s time to give up on this hub and start fresh. I did this a year ago when I moved from my V2 hub to this V3 hub. Something has just gone sideways and I think a fresh start is what my system needs at this point.

Ok the frustration continues. I bought a brand new V3 hub. Added it to ST’s. I’ve tried onboarding 5 different ZWave devices and none of them will connect. The devices are all within 5’ of the hub. I know all of the devices are excluded, the hub just won’t find them. I checked in the advanced tab and everything on the new hub looks good, all the radios show active. I’ve even tried turning off my other 2 hubs to reduce conflicting radio traffic. I’ve finally factory reset the devices and the hub, trying again.