Leviton Z-Wave Switches (and other devices) not responding

2 days ago I installed some new hallway ceiling lights and in the process flipped a few wrong breakers cutting power to my router and Smartthings hub in the process. No big deal, I’ve lost power plenty of times before without issues. But this time after getting everything powered back up I now have several Leviton Z-Wave+ switches that are unresponsive via Smartthings and Google Home. Total of 4 switches (which is total of what I have) and 1 (out of 3) multipurpose sensors are not functioning. The switches work fine manually, but do not change state in the Smartthings app. They are constantly in an “on” state no matter if the switch is physically on or off. In the IDE they are all showing as online, but last activity corresponds with when I cut the power in the house. I have uninstalled one of the switches and reinstalled with no luck. That particular switch now just says “connected” in the app, but is non functioning through the app or Google Home. Other things I have done:

-Run Z-Wave repair (several times) This doesn’t show complete on the app, but in the IDE under Hub events it shows as finished
-Unplugged hub and router to reset
-Uninstalled and reinstalled Smartthings app

I haven’t really messed with much in regards to Smartthings in the past few years. I’ve been up in running since 2017, and fairly quickly got everything installed and integrated the way I want. Things have been running pretty smoothly, especially the past 2 years or so. So, I haven’t had the need to really even open the app much in that time. Is there something else I’m missing? I’d even be alright completely resetting my hub and re-installing all of my switches, sensors, locks and bulbs, if needed. Obviously something simpler would be preferred. I’m just not sure where to go next. Thanks!!!

If you’re on Android have you tried clearing the a
ST app chache and force stopping the app?

Are these using edge drivers or DTH?

1 Like

I’m on Android and yes, I’ve tried both with the ST app.

I’m not sure which these switches are using. But in the IDE the only thing listed under DTH is my Nest Thermostat. So, I’m assuming edge drivers. But again, I’m not certain.

What is the model number of the leviton switches?

1 Like

The single switches are DZ15S-1BZ.
The “dual” switches are DD0SR-DLZ (matching switch) and DD0SR-1Z (coordinating switch)

I have 2 single and 2 “dual” switches (a switch at each end of the hallway, for example.)

Both of those are non-smart “companion” switches that work with Leviton smart switches such as the DZ15S you have. They don’t have a radio of their own and are only used for multi-way applications. Only the smart switch that they’re connected to will show up as a device in SmartThings. What you’re calling “dual” is called three-way in the US, two switches controlling one load.

Have you tried opening and closing the breaker for the switches again? This would reboot the switch itself. Are the LEDs on the switches behaving normally?

1 Like

Sorry, you are correct. Like I said, it’s been awhile since I’ve dove into this stuff because everything has been working as intended for quite awhile. I was going off of my order history on Amazon as to what switches I have since I’m not currently at home. I have 6 switches total controlling 4 lights. 2 of those are 3-way switched, hence the companion switches. So all of the Z-wave ones should be DZ15S. I’ll have to pop off some faceplates to conform though.

I have not tried that. When this happened I had flipped pretty much every breaker in the house trying to find the one that controlled the hallway ceiling lights. It ended up being tied into the bedroom the breaker box was in, which I never would’ve guessed. Hence why I flipped every other one, LOL!!! What makes this even more odd is I have installed a new ceiling fan/light, kitchen light and sink light all within the past few weeks. Obviously flipping the breaker to that switch each time. The sink light is a smart bulb to a standard switch, but the other two are the DZ15S switches and I’ve had zero issues with them after the install until 2 days ago. The sink light works as intended, but the two switches are now part of the problem.

Totally understand! I have to keep a spreadsheet with info or would have no clue what I have where.

I can also relate to the hunt for a breaker. Our house was newly built in 2018 and the breaker box was nicely labeled… but not completely correct! Somewhere here I was given the idea of writing the breaker number on the wall by the switch where it is covered by the plate.

I’ve got more Zooz devices than anything, but I do have two Leviton DZ15S switches and three DZ6HD dimmers (two of which have companion DD00R-DLZ for 3-way). One of these days I’m going to get two more DZ6HD/DD00R pairs for the TV room. Other than needing to update the firmware early on, the Levitons been solid for almost 4 years.

Except for “rebooting” the switches, I don’t really have any ideas. Others here have mentioned Leviton support forums, that’s another possibility to try.

Thanks!! I will give this a try. I cannot imagine killing the power, or even flipping it on and off a few times, would cause each and every switch to loose it’s radio, or whatever, permanently. It’s just maddening trying to chase down the issue and get it resolved.

FWIW, the one switch that I removed and then reinstalled into Smartthings via the app last night is saying “This device hasn’t updated all of it’s status information yet” when I click on the switch on the app. It’s still showing up, as a switch how I labeled it but it’s status is simply “connected”. Not sure if that gives any additional clues or not.

I forgot this in my previous post. I had one of these switches, a dimmer, go bad a few years ago. Leviton sent me a new one saying the firmware needed updated. Is there a way to update the firmware on them simply? I’ve read it get’s pretty involved and requires a specific USB drive.

It’s kind of involved, yes.

SmartThings doesn’t support updating the firmware on Z-wave devices within the platform as it does for ZigBee. So you have to set up some PC software and a separate Z-wave controller in the form of a USB Z-wave “stick” And, of course, get the updated firmware image.

In the best case you will be able to add the Z-wave stick to the SmartThings mesh as a secondary controller so you don’t have to remove the device(s) you’re updating from SmartThings.

The less desirable method requires that you set up the Z-wave stick as its own primary mesh controller, completely remove the devices from SmartThings, do the update, remove devices from the Z-wave stick’s mesh, and join them to SmartThings where they’ll be seen as new.

When I updated my Levitons their issue was falling offline at random times. So I had to do them using the separate primary Z-wave mesh. I’ve also updated some of my Zooz devices. At the time I did it, and possibly still, Zooz devices needed to be reset after a firmware update so I also had to do those the hard way.

If you need to pursue this, Google “silicon labs z-wave pc controller download” for the software. Several companies sell Z-wave USB sticks. I got mine from Zooz (www.thesmartesthouse.com).

@HalD Thanks. I hope it doesn’t come to needing to do that. It’s odd that they all went out at the same time. I’ve also got a ST Multipurpose Sensor that stopped responding at the same time as my switches. Makes me think it’s more of a Hub or software issues versus something directly with the switches. You think a hard reset of my hub is worth a try? I would do that while I also power reset the switches by flipping the breaker for each, as we already discussed.

Appreciate the help. It’s been frustrating!!

I don’t know your particular devices, but I’d try the general steps for getting “lost” Z-Wave devices to work:

  1. Delete the device from the SmartThings app
  2. Double check the SmartThings web, make sure the device is not listed. If it is, delete from there.
  3. In the SmartThings App, go into Z-Wave exclusion mode
  4. On your device, do whatever is required to do a Z-Wave exclusion. You should see a confirmation message on the app if the exclusion works
  5. Re-add the device in SmartThings

Thanks!! Do you delete the devices first from the app and/or IDE and then do the Z-Wave exclusion?

  1. Delete from the App (I’m assuming this is the DZ15s that you’re deleting since it was noted that’s the only device with a Z-Wave radio)
  2. The device should not show up in the IDE at that point, but if it does, delete from there too
  3. Then do the exclusion (looks like the instructions for that are in here):

And then, as I stated, use the app to find a new device, and put the device in inclusion mode so that it can be found

And let me know if this works!!


Good suggestion!

Also this should get the devices converted to Edge drivers if they have not already. My two DZ15S switches auto-migrated a few weeks ago and are using a standard driver.

I’m assuming this is ultimately the issue since they ALL stopped working after power outage.

One last question. Maybe it’s better for @ScottF100, but should I be doing this one switch at a time? Do all steps 1 - 5 for switch A, then do all steps 1-5 for switch B and repeat until all switches are done?

Are the existing switches using an Edge driver or a DTH? If DTH, is it custom or stock? You can tell by checking in the IDE, if the device type is “placeholder”, then it’s been converted to Edge.

If they’re all still using DTHs and are on a custom DTH, then I’d delete all the devices. Then remove the custom DTH via the IDE. And finally add them back one at a time. Clearing out any custom DTH will get you on Edge which is where you need to be.

If they are already on Edge drivers or are on a stock DTH then I’d probably do them one at a time.

Note that the stock DTH for a DZ15S should be either “Z-wave Switch” or “Z-wave Switch Generic”.

1 Like

You could delete them all at once, but then do the exclusion and re-add one at a time. In theory the order doesn’t matter, but this way seems logical to me.

1 Like