In Wall Light Dimmer - ZigBee ZLL


#1

Hey all,

I’m new here so please be nice :slightly_smiling_face:

In Australia (where I live) we are limited to ZigBee and LAN devices dues to ST using a different ZWave frequency.
Because of this I have been trying to hunt down some in-wall ZigBee switches and so far I have only found one.

It is a glass capacitive touch in wall switch and dimmer and runs ZigBee HA and ZLL according to the box.
It is designed to connect to a Nue ZigBee hub (which I didn’t buy).

I want to get it to work with ST.

So far I have gotten it to talk and added it using the “ZLL Dimmer Bulb” handler.

However, my issue is that I can’t control the switch from ST.
I can see the status, for example when I turn the switch on and off, I see the switch turning on and off in the events and in the app.

Also when I use the dimmer, I see the level percentage change in the device events and in the app.

However, I can’t control it.
Anything I press in the app has no effect.

What am I doing wrong?

I have tried the following device handlers “ZigBee Dimmer” and “ZigBee Dimmer Power” they show the status of the dimmer but not the power on and off, but still don’t allow me to control the switch/dimmer.

Here is the catch all if that helps:
catchall: 0104 0006 0B 0B 0100 00 F781 00 00 0000 01 01 0000002000

FYI, I am not a developer so fairly new to all of this and Home Automation.

Here are some photos:


#2

Tagging @Sticks18


#3

Can you send the device’s fingerprint? It should be listed under raw description in the device information in IDE.

The catch-all:

seems to be doing a toggle. I don’t think the default DTHs work that way. (00 - off, 01 - on, 02 - toggle).


#4

sorry, I am pretty new with all this.
I cannot find the raw description field you mention.

Below is a screenshot of the device info:

can you point me in the right direction on how to find the fingerprint?


#5

Here’s my favorite example where someone wrote a zigbee device type handler when they didn’t have any experience coding. Other community members helped them and you can see the steps they went through. Give it a glance, I think it might help you understand the process. ( this is a clickable link.)


#6

So if the Data field is populated, the next field is Raw Description. It looks like the device did not pair correctly. I guess it is also possible the device does not return model information aspects of the Basic Cluster. I’m not sure how SmartThings will respond to an unknown model. Technically those are optional attributes but I don’t think I have ever seen them unused.

I’d try to remove the device, reset it, then try pairing it again. Some ZLL devices are a little troublesome to pair, as they need to fall back to ZHA.


#7

I just spent the weekend learning how to put a device handler and app together by hacking about with code from sticks18 and motley. It was fun, here’s some starters:

Fingerprint: found in your RAW Description In the Web GUI go to My Devices -> Click on Device Name -> Find the RAW Desc field. If you have the LIVE logging turned on when you add the switch to the hub you will also see in the zbd join log entry which includes the fingerprint and a whole bunch of useful stuff.

Edit: As @jhamstead pointed out, it seems to be missing from your screen shot. In which case try remove the switch from the hub, and reset the device (if you know how). Then go to the Live Logging page on the web GUI. Re-add it to the network and you should hopefully see the join command process run through. N.B. The logs can get noisy if you have a lot of stuff on the network so it can be tricky to spot.


#8

Thank you for all the replies, everyone!

I am going to give all the suggestions a try and write my own handler, however, it might take a while. I am a new first-time father of a 4 month old girl who fights sleep like it’s her enemy. :frowning:

Regarding not having a RAW description field…
I could never get the switch to just add via the app while searching. It never came up as a “thing”.

The way I added it was looking at the log from the hub, saw the catchall, identified the Device ID and added it manually using the IDE, “My Devices > New Device > Entered the name, device ID and selected ZLL Dimmer Bulb for the Type > Create”.

I know that doing this worked to an extent because when interacting with the switch itself, the changes are reflected on the smartthings app, turning on, off and changing the dimmer level (just can’t control via ST).

So from peoples comments here, it appears that this way of adding a device is incorrect and I have to add it as a “thing” first to get all the information (fingerprint) before I can use it?

If this is the case, would anyone know why it doesn’t show up as a “thing” when searching?

The switch itself has one multipurpose button. When you hold it for 10 seconds it removes any pairing, regenerates the device ID to something new. If I have smartthings in discovery mode the switch would pair (or some form of pairing) as the light on the switch/dimmer turns off which according to the instructions indicates successful pairing.

The box says its ZigBee HA and ZLL, but I have a feeling it might be just ZLL, would this be a problem?

Sorry for all the questions, just trying to get my head around how the ZigBee protocol works and if I am going down the right track.

P.S All my other ZigBee devices (all Xiaomi ZigBee Outlets / Plugs) didn’t show up as things either, I had to add them manually in the IDE. The difference is, they all work.


#9

Also to clarify, when people refer to “Live Logging” they are referring to:
My Hubs > List Events

or is it somewhere different?

The “Live Logging” tab just shows “Waiting on Events”.


#10

Click on the live logging tab where it shows waiting on events. Then rejoin your switch to the SmartThings hub. Then paste the output that shows up.


#12

ok guys, update…

Deleted the device and reset the switch. Had the Live Logging screen open and re-paired. There were no join / any entries for the dimmer switch.

Had a read of the post JDRoberts attached regarding the Securifi Key Fob.

Installed the ZigBee test device handler and assigned it to the dimmer switch.
Checked the Live Logging, only the “parse description” events appeared which are the same as in the Hub events.

Reading further down the post JDRoberts posted, it says to look for the description entry in the hub events:
description desc: 38 0104 0007 00 03 0000 0003 0004 01 000C

I couldn’t see anything like this.

However, I also did some reading on the product page of the switch/dimmer I purchased it says it is ZigBee 3.0:

What is ZigBee 3.0?

  • ZigBee 3.0 is the latest version of the popular ZigBee wireless mesh networking standard to combine the various different components and device profiles, such as ZHA (ZigBee Home Automation) and ZLL (ZigBee Light Link), into a single unified specification and platform.
  • ZigBee 3.0 defines more than 130 different specific devices and a wide range of device types, including home automation, lighting, energy management, smart appliances, security, sensors, and healthcare monitoring devices. All the device types, profiles, commands and functionality that are currently defined in the ZigBee PRO standard (which ZigBee 3.0 is based on) are available in ZigBee 3.0.

What are Benefits and Features of ZigBee 3.0?

  • Low Power: Zigbee 3.0 compliant devices support low power and low data rate. IoT devices require long life battery. Hence this standard is widely used in IoT (Internet of Things) network.
  • Reliable and Robust: The zigbee 3.0 supports mesh topology and hence such network will avoid single point of failure and hence ensure reliable delivery of packets.
  • Scalable: The devices can be added any time in zigbee 3.0 network.
  • Secure: It supports AES-128 encryption type and hence it is secured network.
  • Global Standard: The frequency band 2.4 GHz is used widely across the globe which is used in zigbee 3.0 based devices. Hence it is a global standard.
  • Zigbee 3.0 support large number of nodes about 250.
  • It also supports dynamic nature of the network.
  • It supports rejoining of orphaned nodes with the new parent node in the event of loss of parent.
    Zigbee 3.0 provides backward compatibility with other zigbee application profiles such as zigbee light link 1.0 profile, zigbee home automation 1.2 profile etc.

So the question now is… does SmartThings support ZigBee 3.0? (crossing fingers)


#13

Not yet, but hardly anybody else except Ubisys does yet, either. Phillips has announced that they will add some zigbee 3.0 support to their bridge in 2018.

I don’t see the new devices listed on the official certification page, but that page sometimes is slow to be updated. So doesn’t mean they aren’t zigbee 3.0 certified, but even if they are, they won’t work with SmartThings.

http://www.zigbee.org/zigbee-products-2/

Although zigbee 3.0 is intended to be “backwards compatible” that means that a zigbee 3.0 hub can handle older devices. It doesn’t mean an older hub can handle zigbee 3.0 device, which is why Phillips is adding new features.

If the device is certified for ZLL, those are supposed to fall back to a ZHA profile when connected to a ZHA hub. But I’m not seeing any Nue Devices in those categories either.

It’s possible that these devices are manufactured by somebody else and have just been rebranded by Nue. You could write the manufacturer and ask for a copy of their certification and tell them you’re having trouble getting the device to join to a certified “ZHA” coordinator.


#14

Ohh man… :disappointed:

I don’t have any other options for a in-wall dimmer here in Australia.

Here is their website:
http://3asmarthome.com/products

Supposedly all their products are ZigBee 3.0.

So you are saying I should ask them for their ZigBee certification, is this a document of some sort?
Would it help me get the switch connected at all?


#15

Yes, it’s a document.

If it’s certified as a ZHA Device, you should probably be able to get it to work with SmartThings, although it may require custom code.

If it certified as a ZLL device, you can probably get it to work with SmartThings, again with custom code.

If it’s certified as a zigbee 3.0 device it might work or it might not. If it joins via touch link commissioning, then it won’t work with SmartThings. If it joins via classical EZ mode commissioning, then it may work with SmartThings although it will require custom code.

The following technical whitepaper Will discuss issues that can arise for those interested in forward and backward compatibility with zigbee 3.0. You don’t need it for your particular situation, but I’m including it here because some people who may want to help you might find interesting. :sunglasses:


#16

OK…update.

Contacted our local supplier of these dimmer switches and he didn’t have any certification documentation to give me.
He did mention however, that other customers were able to get these switches to pair and work with SmartThings. He shared with me contact details of someone who was able to get them to work.

I contacted him and he shared that we successfully paired the same make of 3 gang switch, however he didn’t have any experience with the dimmer switches.

One thing he did mention was that when pairing that the switch came up as a “Thing” on the app and allowed him to pair the switch before customizing a device handler.
Other posts here on the community also indicate that unknown devices do appear as “thing” when adding devices.

I have captured some videos of some tests to show you all what is happening:

Here is me trying to pair the 3A Smart Home dimmer:

As you can see I have taken my hub out of the network cabinet and put the device very close to the hub, but no “Thing” appears on the app.

The hub log shows the join request for the relay, but no “Thing” appears in the app.

Is my hub faulty? Is there a setting I have turned off?
My hub is running version 000.018.00022 which I beleive is the latest.


#17

Hi, I have the same dimmer switch and it also will not pair with the ST hub. Must be something different about it compared to the other 3A smarthome products.

Their other products, 1,2 and 3 gang switches all successfully pair with the ST hub.

Also their power plugs and inline switches work also


(Joel) #18

apparently the company is working on the device type right now - couple weeks away.

curious for those in Aus if you found any other options for zigbee dimmers? i’m a bit torn in getting zigbee downlights (osram) or just a zigbee dimmer switch as it will be a lot cheaper that way.

i asked the company if these dimmers let you have the following occur:
Light is off - was at 100%
Rule say turn on light at 1% brightness

he said it will turn on at 1% and not go from on 100% to 1%.

also curious about the quality… designed here in Aus and made in China. have you guys had any issues at all other than smartthings connections?


(Joel) #19

this must have been frustrating - have gone through it. you should give them a call ask about the device type


(Joel) #20

any luck getting it going?


#21

Hey Joel,

Unfortunately no.

I contacted the supplier and he told me there wasn’t official SmartThings support and that if I wanted it to work I had to create my own device handler.
I am willing to do this, but the problem is I can’t get the dimmer to actually pair properly with SmartThings.

Other people using the standard switches (without a dimmer) report that they pair and work fine, however, the dimmer models are apparently different in how they operate and pair.

There is one more thing I want to try, however I have been really busy recently and haven’t had the time to try and get it to pair again.

In regards to other options for ZigBee In-Wall Dimmer switches which conform to Australian standards, I haven’t found any. I have asked on a few other Australian smart home forums and they all report that there is nothing apart from the 3A switches. All the locally made switches are Z-Wave and because we use a different Z-Wave frequency here, they won’t work with SmartThings.