In Wall Light Dimmer - ZigBee ZLL

yeah i’m in the same boat re the z wave stuff of course. i did consider using it but didn’t want to risk it due to causing issues with emergency calls (low risk but still).

3a did tell me they were working on a device driver for it. but if you can’t even pair it… what’s the point?

From your catchall data, the networkid is F781 and the endpoints is 0B. You can create the device with networkid F781 . Please have a try.

1 Like

When you pair the device you should see a “zbjoin” event that’s visible on the hub “List Events” screen. If you can share that it’ll provide more information for us to determine what’s happening.

1 Like

See if giving the info to Tyler helps

Have you got this smart dimmer working with SmartThings yourselves?

Yes, I did.

Hey guys, finally got some time to try and get these dimmers working with ST.

I tried using the catch all to get the networkid and used the ZigBee Dimmer profile, this is what happens:

As you can see, ST looks like it can see what the dimmer is going (some of the time - notice the power button doesn’t display the status correctly every time), however I can’t control the dimmer from the ST things app.

What profile are you using? Can you please share the profile you are using if you have it working?

Doesn’t matter what I try I can’t get a “zbjoin” event to appear. All I get is “catch all” events.

so close! hopefully @Tyler can advice here.

Fully with dimmer working correctly ? Or are you still work on the device type ?

hey i got mine working with help from 3asmarthome. i had a similiar response (tho initially it did nothing) where pushing it on or off would immedietely have it set back to original setting as it was doing in your video.

did you set yours to self published? or published? I missed that in instructions. And set to published. Which didn’t work.

once it was set to self published my smart dimmer seemed to be quite stable except for if you tried to set it to 100% it woudln’t work but anything under 99 worked.

i also found if i ran it with a smart lighting app, i.e turn on and set level. even if light was at 100% brightness and off, it would turn on at set to 10% if that’s what the smart lighting app asked for.


I did notice if you change dimmer on hardware switch, it does not relay back to ST. also if you change brightness whilst switch is off from ST, it will turn switch on, but not have this reported back to ST. hopefully this is fixed in an update on device type soon

but for my use case, the unit works great.


Glad to hear yours are working.

Can you share with me what device handler you are using?

I have not published/ self published any handlers for this dimmer, I am using the default ZigBee Dimmer one.

3a sent me a device handler. Did they not send one to you ? I’d email them and ask for it as I don’t want to share it without permission.

I then added it as custom per their instructions.

No worries, I sent them an email.

Hi guys,

I’ve just bought a Nue Light dimmer and can’t seem to get it to join smartthings. I’ve put the switch in pair mode as indicated by the red led. When I try to add a thing on smartthings, the red light goes out, so some communication has happened, but the smartthings app keeps searching with no discoveries. I can’t see any zbjoins or catchalls in the event list. Just a zwave include search. Any ideas?


Do these show up as devices in Google Home, and respond directly from Google home, or is it a case of requesting smartthings to turn on/off the switch? Also it says a Neutral Wire is needed. I thought that was a US thing.

did you get it going?

Yes, I had the same problem, no zbjoin or catchalls. Then I managed to get a ‘read attr - raw’ message by playing with the +/- on the dimmer panel.

It was then a matter of grabbing the DNI address (Device Network ID) and setting up MyDevices following the instructions that are on the 3Asmathome website.

1 Like

yeah i had that same discovery
however after adding the device and selecting the DTH “Zigbee Dimmer” from 3a. if i push buttons on the dimmer it will show these changes in smartthings device

but i cannot control the device from smartthings

3a helped me before get it going but all they did was change it to self published… this doesn’t work for me…nor does published… etc

i have also re saved and published the custom DTH - no luck

the 1 gang switch actually shows up as a thing and is much easier to get going - and I can control it from the smartthings app.

did you have similiar trouble?

EDIT: turns out there are two dth’s called “Zigbee Dimmer” - the ST standard one and the original custom one - 3a have renamed theirs to Hue Zigbee Dimmer

My dimmer is working perfectly from the smatrthings app i.e. I can control on/off and dim%. It also updates in real time the status and dim% when using the wall panel.

There are two DTH’s called Zigbee Dimmer, you need to choose the custom one at the bottom of the dropdown list.

I was sent a new DTH recently from 3a. Happy to send this to you in case they have improved the code.

1 Like

thanks Scott - that was the reason. 3a found that issue… makes it hard when they are the same name!