IKEA smart dimmer

I have this IKEA two-button Dimmer. I’ve tried uninstalling and reinstalling several times. It detects the device and adds it to my devices under the edge driver Zigbee button. On the smartthings app, it shows the battery percentage which randomly goes from 50 to 100, and everything in between. It shows it on standby with no button presses registering and the history on it is blank.
I’ve tried installing Mariano’s Zigbee button driver. When trying to change the driver, Mariano’s Zigbee button Mc driver doesn’t appear as an option. It only gives me the option to switch it to Zigbee thing and Mariano’s Zigbee thing Mc. And it is installed because when I change my edge driver in the Samsung button, Mariano’s Zigbee button Mc driver does show up as an option.
I tried looking into other posts in the community with other people having the same issue, but I haven’t seen any with an answer.

Hi @numba_4
It does not appear as an option because the fingerprints of that button are not in the driver.
They are not because it doesn’t work with my button driver.

I think it should work with the stock smartthings zigbee button driver

It currently has the stock Zigbee button driver, but button presses do not register. Thanks for the reply.

I haven’t tried my buttons of this type lately because I suffer badly from battery drain with them. Do no button presses register at all or does held work? I thought I’d given them a go when the driver was first released and they worked, but maybe not.

To my eyes, the Edge driver seems to be using the OnOff Cluster (which doesn’t seem to be explicitly bound as it is in the DTH) for pushed, and the Level Cluster for held (which I assume is bound by default). However in the DTH the OnOff is only used for the middle button in the five button remote and this device (the On/Off switch) uses the Level Cluster for both pushed and held on each button (referred to as top and bottom in the DTH).

@nayelyz would you mind running your eyes over this? I thought people had been using this button successfully but maybe they haven’t?

After hours of trying to make it work, i finally did it.

I had to remove the ikea dimmers off smartthings. Then i had to remove the official zigbee button edge driver. I installed the ikea dimmers with the old dth drivers. They worked with the old dth drivers. I then removed the dimmers again and reinstalled the edge zigbee button driver. Re-added the dimmers and the buttons are finally registering. I can finally sleep.

@nayelyz Oh well, looks like I must have seen a problem where there isn’t one. Still think it looks odd though.

Hi, all!

@numba_4 or @orangebucket, do you know the exact fingerprint of the device? I see some similar fingerprints in the driver:

It is odd that you had to rejoin several times the devices for them to work, it would be useful to know if it happens for other users or if it was a temporary glitch in your case…

It is the TRADFRI on/off switch. Something doesn’t sound quite right to me.

1 Like

The person on the post I sent seemed to be having the same issue as well. Seems like he just reverted back to dth rather than finding the solution.

Maybe just reinstalling the zigbee button edge driver did the trick for me.

I tried that trick, but without removing the IKEA driver, only the device as I didn’t want to remove my other 4 buttons functionality.
I managed to get it running with the “placeholder” driver, after change the driver from “IKEA button” to "placeholder, but it wouldn’t load or use the edge driver and all routines were not locally run.
So guessing the finger print for this device isn’t included in those edge drivers.
I suspect my button are running an older firmware version that maybe cause the issues and I don’t have a way of updating. it’s more of a theory…

Did you unistall the zigbee button driver from the beta channel and then reinstall it into the beta channel?

Yup sure did.
Removed ZigBee button and ZigBee dimmer remote(just incase) from the hub

Hi, @Ace2!

Just as a reference, Edge drivers are not fully supported on the IDE, so, changing the device type could cause more issues. There, “placeholder” means any other thing that isn’t a DTH, not specifically a driver.

For the device to be connected to the driver, you need to:

  • Have a compatible driver installed. There are some that are installed automatically but not all fingerprints are enabled yet. For example, the “default” Zigbee button driver has enabled only the three fingerprints at the bottom (for Samjin and eWeLink)
    So, in this case, you have to install the one in the official beta channel invitation where all the fingerprints are enabled.
  • Don’t have a custom DTH published in your IDE that contains the device’s fingerprints
  • Once you verified the above points, you need to uninstall the device and pair it again. In the app, you only need to select “Scan nearby” while the device is in pairing mode.

Note: If you’re not sure about the device’s fingerprints being included in one of the official drivers (in the beta channel), you can go to the official repo and enter each driver’s configuration to see the fingerprints.yml file and look for it.
You can also ask us here but we would need the fingerprints, or if you don’t have them, the device’s model and brand.

Hi everyone, i just tried to connect this dimmer to my hub but it doesn’t really work.
One button press is registered but when i press the other button it registers both buttons as pressed at the same time (so it cancels each other out).
Is this dimmer really compatible or is it not worth the trouble? are there other drivers for it that work?
thanks everyone!

I have 5 of these buttons working with official Zigbee button edge driver.
It looks like is compatible also with “Zigbee button groups” driver from “Lrmulli alpha channel”.

yeah, it seems like they connect fine and all but when i click the “off” button it shows both buttons as pressed. i guess i will try the other driver but that is just strange…

Your descriptions make it sound like you are watching the Main (either button pressed) and Button 1 (0 button) components, rather than Button 1 (0) and Button 2 (1).

The button can have severe battery issues but it does work fine with the stock Zigbee Button driver.

oh, you might be right, i will check this out.
yes, i read about the battery problem, well, if it occurs i guess i have to get different switches anyway.

i am very new to this and until now i was mostly using google home but it’s so limited in many regards that i wanted something else.