IDE 500 Internal Server Error


(Paul) #1

I’m getting a 500: Internal Server Error every time I click the “create” button on a new smartapp. Anyone else having the same problem? Anyone have a workaround?
Thanks…


Keep Me Cozy II creation gives error "Failed to save page: defaultPage"
Groovy strings with < and > characters
Adding Nest Protect
(Gary D) #2

Are you able to get a device list? When I try, I see this:

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/device/list
Reference Id
a5d87bd3-418d-41fa-b65e-ef74ba896df8
Date
Sun Feb 08 21:31:57 UTC 2015
Class
org.hibernate.StaleObjectStateException
Message
Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [physicalgraph.auth.UserClientDevice#67962776-f9d4-4a58-8f80-fd7f5d49857f]


Anyone noticing ST being slow tonight?
(Paul) #3

I can’t even get to the IDE screen where I would start writing the code. I get this:

Error
500: Internal Server Error
URI
/ide/app/editor/4f62bca9-0f9c-4713-8a6e-7ca8538b0f9f
Reference Id
9206bb85-95d2-493e-92d5-6d6301eaaebc
Date
Sun Feb 08 21:29:52 UTC 2015
Class
java.lang.NullPointerException
Message
Cannot get property ‘latest’ on null object


(Michael) #4

I am having the same troubles. I cannot create a SmartApp either and I receive the same 500 error. I attempted to delete a SmartApp earlier and the app still shows up in my SmartApps list too. When I click into it, I get an access denied error.


(Hugo Donis) #5

I’m having the same problem.

Oh No! Something Went Wrong!
Error:500: Internal Server ErrorURI:/device/listReference Id:6cf9c14b-6064-4a1f-b157-0af822d6de5cDate:Sun Feb 08 21:41:59 UTC 2015Class:org.hibernate.StaleObjectStateExceptionMessage:Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [physicalgraph.auth.UserClientDevice#0ad848d7-c5b2-4cd4-b0ac-de1c83b4155e]


(The fish is still dead.) #6

Ugh, glad to see it’s not just me. Already have a ticket in on this. Will point them at this thread for reference.


(Michael) #7

Things appear to be working again for me.


(Gary D) #8

If you ever get bored, wait until your device list gets trashed, and start playing in the mobile app. I’ve crashed it about 2 dozen times in the past 5 minutes.


(Geko) #9

I’ve been having the same issue this afternoon - unable create/update/save/delete apps.


(The fish is still dead.) #10

It was working for a few minutes, now I’m getting this:

java.lang.IllegalStateException: Method on class [physicalgraph.device.DeviceType] was used outside of a Grails application. If running in the context of a test using the mocking API or bootstrap Grails correctly.

(Kris) #11

Did anyone find out how to fix this?

I’m getting the same error when I try to open the devicetypes in the IDE.

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/ide/devices
Reference Id
0e124d05-1671-46d3-a428-372d14fac64a
Date
Tue Dec 15 23:47:39 UTC 2015


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #12

Lots of possible causes, some temporary.

It can be Authentication related… Are you perhaps running SmartTiles in another tab or window?


(Kris) #13

Thanks @tgauchat, no I don’t have SmartTiles running. I’m not actually sure what that is.

But If you are talking about another tab in my web browser I’ve tried the IDE on 2 different computers, and 2 different browsers on each.

Smartthings support says it’s a known issue and they are working on it.

I’m just not very patient!


(Kris) #14

So SmartThings got back to me, said it is a Github integration issue.

After doing some testing I found that the issue came from the following:
noname4444/smartthings

Not sure why, but I removed that repo and it works now.

Any thoughts as to why that repo is causing an issue?


(Dan) #15

I’m getting it too when trying to create some devices. It’s convoluted enough trying to navigate such a stupid interface but to have to content with site issues makes me miss micassa verde. They had a much more evolved and mature SDE.


(Võ Thanh Minh) #16

I too
Help me!
Help me! I can not change name of device and delete device


(Dennis Reiter) #17

I’m stuck with this also. It first failed trying to change the DTH for a motion sensor, then I’m trying to add Bangali’s room manager smart apps and also get an error (though the DTH published just fine.)

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/ide/app/doRepoUpdates
Reference Id
e5dc5e15-6adc-4ebd-8fea-d1ddf4b78be9
Date
Sun May 27 14:37:29 UTC 2018


(jkp) #18

Try logging into IDE with an incognito/private tab


(Dennis Reiter) #19

Nope, same result. I tried incognito mode and even fired up Firefox and attempted there.


(jkp) #20

You login to IDE with https://account.smartthings.com