Keep Me Cozy II creation gives error "Failed to save page: defaultPage"

Please let me know if this isn’t the correct place to post this type of question - I’m still trying to find my way around here.

I’m trying to create the SmartApp “Keep Me Cozy II” and use it with my nest thermostat and the Everspring ST814 remote temperature sensor. If I pick any temperature sensor (Aeon, Everspring, or smartthings) I get this error. So I guess it is the nest thermostat that is causing this problem?? I’m just using an iPhone and the SmartThings app to create the smartapp.

Since the app won’t even save it seems that I’m not even getting as far as others in the community seem to have so just wondering where to start. I do have the new firmware if that may be a possibility. I believe that I have the latest nest device type code but given the variety of places and threads with this I just can’t be completely sure.


1 Like

Several other people, some of them very experienced ST coders, are reporting the same error today, no matter what smartapp they’re working on.

Check the following topic for more info:

Thanks for responding. I was just able to create a Pollster smartapp but it looks like there was just a new version posted (1.2). It looks like pollster isn’t even listed in the shared community, convenience apps now so I pasted in the code directly from Github. Reason I mentioned it is that I was actually able to create a new smartapp, but that one is probably different then the regular ones in some key way, I’ll bet.

I saw reference to the 500 error but I didn’t see that in the iPhone app anywhere. Is there someplace I should be looking closer in the iPhone app in the future for more details?


Pollster is temporarily off-line because it’s being updated.

Im getting the Failed to Save page, and then unexpected error too and its nearly a month after you posted. Did you ever get it to work?

Yes, it started working a bit later. I think it was a more general system error.

I’m seeing this issue now… Any idea how it was fixed?

I created an app based on Keep Me Cozy II…

I, too, am seeing this issue. I had it setup and then deleted it due to a different error and now I can’t save the settings in a new smartapp.


I have some issues with datatypes I think. Still working on it.

Ive tried reinstalling it a couple times. Can never get it to set up properly. Hope to see it fixed!

I just installed it fine. Maybe mail support since it’s an official SmartApp.

I think I’ve figured out the source of the problem. Line 85 has a log trace that tries to output all the current settings. I narrowed the error down to when it tries to log the value for currentHeatingSetpoint. I think this errors on SOME systems because some systems are in Cool only mode so there isn’t a value for heatsetpoint in that mode.

If you want to play around with fixing it, you can make a new SmartApp using the developer IDE and base it on the Cozy II template. Then you can comment out line 85 and everything should work.