Internal Server Error on My Devices

I can’t load my devices in the app or on the Graph dashboard. I’ve deleted all of my smartapps and all of my device handlers, but still get a 500-Internal Server Error. Now I can’t delete any other devices or device handlers because I can’t get to the pages where I would do so.

Error: 500: Internal Server Error
URI: /device/list
Reference Id: 735c7e42-8103-4223-9d22-36db89b89ea2
Date: Fri Jan 25 16:58:19 UTC 2019

I also can’t load My Hubs screen because I get the same error.

Any ideas? My entire house is unavailable now because I can’t see my devices.

Does your My Locations page load in IDE?

Yes. I created a new location, which worked. I’m unable to delete the old location (500 error)

In the old location, try selecting devices or Smartapps. You may want to remove the new location if your hub is on the other location.

Not that this will have any effect but try logging into IDE using an incognito/private tab in your browser at

Results from Incognito tab

Logged in successfully. Redirects me to:
My Locations works.
Selecting the old location works.
List Devices throws a 500.
List Smartapps works.
My Smartapps works.
My Device Handlers works.
My Hubs throws a 500.

Best if you contact ST support at this point and play the waiting game with them to contact you.

Phone is generally the fastest form of communication

Thanks for the quick diagnosis. I’ll give support a call now.

Also try using an incognito windows to access the IDE.

No reason that should help - but it has been known to.

I am having the same issue today. Did support solved your issue?

I called support multiple times and finally just created a new location and activated my hub from scratch, then added all my devices again. Literally started from scratch. I still couldn’t delete the old location. It took multiple calls to support and over a month, but they eventually were able to delete the location that was broken.

I started having this problem last weekend. I emailed support and hadn’t heard back by last night (Friday), so I called them. They said I had to do a factory reset and start with everything from scratch.