I was Stupid and in a Hurry!

So, yeah, was trying to delete a device, tired, in a hurry, and dam***t, deleted my entire hub. decided to install a spare v3 hub I had on hand (since old one was v2), reset it and installed it fairly easily…well. . . I barely get a few things installed and already, most of them are showing offline. . . always made sure I went into deletion mode first, reset each, installed. . .they came on easily enough, but then I ran into two problems. . . even though I loaded Inovelli, Phil, Aeotec, etc edge drivers onto the hub, not a since inovelli product even shows the option to use and proper edge driver and I’m getting multiple items self-adding when I try to add just a single switch outlet, or a light switch, GE/Jasco or Inovelli. . . . it’s like every time I attempt to add a single device I get 2 or more just adding on their own. Anyone run into these problems???

I should ask - how did you delete the v2 hub?

very strange! When you login to the Advanced Web App do you see the duplicate devices or any other oddities such as devices from the wiped out hub still appearing? Look through all the sections. one suggestion - run z-wave to see if any errors show and run it again after adding a batch of z-wave devices and repeat.

1 Like


I see them all in the advanced web app. I see no devices from the old hub. I’ve tried the zwave repair on the phone app. . . never appears to do anything.
added drivers in one of these clips

more of the devices I added yesterday are offline than online, yet, the ones that ARE online work well, and it’s frustrating that most of the drivers I added never appear as choices when adding those components

I have not been able to find a place to see the repair logs. . .I can request it, gets a green success notice, but don’t know anything from there?!?

the ones that are online… any pattern that you can see… those closer to the hub or particular devices that are working?

nope, not the first nor last, neither closer nor farther than the rest. . . and nothing I’ve added is very far from the hub, as I planned on building outward…all these were in place, working well with the version 2 hub…and this version 3, well, I had used it in the past and had no problems, but ,of course, reset it to factory and did updates before I ran into this problem.

I was simply doing to delete a device and I guess not paying attention, and deleted the hub itself. . . and it was too late to stop my finger! :tired_face:

and you installed these drivers on the v3 hub before installing the devices… just checking that you were referring to the v3 hub and not the ones installed previously on the v2?

correct, installed the drivers, THEN the switches. . . . tonight, deleted the offline devices and deleted them, excluded and then re-included the first Innoveli switch, and for the first time ever, Smartthings actually identified it as an Inolvelli switch, even though it originally assigned the wrong driver, but I was able to tell it to use the black and it seems to be working!?! It’s as if the hub needed to “settle in” or something, which is crazy, because the FIRST thing I did was all updates on the hub itself. I’ll keep updating as I try more devices.

1 Like

You aren’t the only one - it’s poor UI design, many folks including myself have accidentally deleted the hub :frowning:

Try to delete the driver and re-add it back. I had faced this issue also after a hard reset for some devices. I think it was a firmware quirk but it was resolved after the last hub firmware update.

2 Likes

I’ll try. . . I’m also having problems with Aeotec 6 sensors wanting to add as smart thing. . . . I may have to go unplug every darn zwave and zigbee item in the home, as every time I try to add a device I get anywhere from 2-6 additional ones added at the same time…arrrrgh. I had a single Aeotec sensor add using the edge driver, all others came on as things no matter how many hard resets I did on them. Such fun. :rage:

Just this afternoon I updated firmware on two of my Aeotec Multisensor 6 devices. One went smoothly: it was maybe 15 feet from my hub on the same floor. The other, which is in the basement, seemed to take forever to re-pair with the SmartThings hub! I finally took it from it’s mounting place, held it out away from the other wiring & network equipment mounted adjacent to it and was able to successfully pair it.

You might want to try pairing the device nearer your hub, then move it to the location in which you want to place it and perform a Z-Wave network repair.

Thanks, although this isn’t the case here, I agree totally with your method, and do pretty much always pair in close proximity and then repair zwave once it’s in it’s final location. I also reboot occasionally after working on the hub.

I probably should have led off my question with explaining that I have been with Smartthings since 2016, and currently have seven operating hubs in various locations, with anywhere from 8 to 80 devices per hub. Due to time constraints, (and perhaps upgrade/old app/new worse app/basic api/new Beta changes fatigue) I’ll be the first to admit I’ve learned very little about edge drivers other than 1. how to add them to the hub, 2. you can only have 80, and 3. you’re supposed to be able to choose among them.

Well, I’ll keep swinging at it and update when I figure something out.

1 Like

You can only have 50, but there is also a memory limitation so many people find they start hitting the memory limit closer to 20.

You may already know everything that’s in the community FAQ, but just in case, here it is:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

2 Likes

It’s actually very easy to delete the hub when trying to remove a zwave device. This happened a few minutes ago, I almost deleted my hub a second time.

So I wanted to exclude a zwave device (which wasn’t paired), I opened the hub and hit the menu option - staring at me right in the face - REMOVE DEVICE - my brain in a moment of hurry interprets this as click this to remove your zwave device.

For the Hub, that option should be thank renamed to DELETE HUB or REMOVE HUB - the hub needs to be treated as a special case scenario and not just like any other device.

@nayelyz @alissa.dornbos some feedback for the mobile product manager, this is happening to many folks and even to us who’ve been using SmartThings for over a decade now. It’s an easy enough and costly mistake which can be avoided with a slight UI tweak.

5 Likes