V2 Hub - same ol' forgetfulness (GE zwave loses connection)

Ever since the Beginning of Time, my system will just “forget” a random device (always seems to be z-wave, but I have 90% z-wave devices). Once this happens, no amount of power cycling (i.e., cutting power at the breaker), z-wave repair, etc. will bring it back.

I have to go remove it from all the apps that are currently using it, put the hub in general exclusion mode, exclude the device, then “Force Delete” the device from the app, then re-pair the device, and finally re-add it to all my apps.

I was hopeful that v2 Hub would change things. Well, it made it about 3 weeks and tonight one of my door actions didn’t turn on the light it was supposed to… and, yep, forgotten device.

Here’s what the error looks like in the Z-Wave repair:


That sounds like you may have some radio interference in the area. Where is the hub in relation to the router for your home?

No no. I’ve had this switch (and hub) in the same place for two years (first v1 of the hub, then v2). This has been happening to me since forever. About once a month ST will just pick a switch (and once it was the one about 2 feet from the hub) and drop it.

I know it’s a corruption occurring in the device table because if I go into the app and “exclude” the device (which puts the hub in exclude mode), the instant I press the switch, the app will tell me an “unknown device” was excluded. So, somehow the hub gets confused the switch’s actual ID and the ID in the hub get disconnected.

1 Like

Ok, if you are sure it is not interference than we will go with a table corruption. I know from using other hubs, that this happens with Wink, IRIS, and with Revol. I have it happening less so with ST. Truth be told, I have always felt it was more the connected hardware than the Hub that was at fault. For me the GE Link lights are horrible. Cree is better, but still on occasion fall off the network. Doing the same thing as you noted above.

Now I am interested. How many of us here have random falling of of a IoT device over time? And how long does it take?

It seems to be a problem with SmartThings and the GE Z-Wave switches. I get the same problems every month or two with one of my many GE switches. SmartThings really seemed to encourage interest in the new Zigbee GE switches when they launched. I assume there was a reason for that.

Note, I also get occasional non responsive/falling off network issues with SmartThings and Zigbee SmartSense motion sensors. So the instability and lack of automated healing is not limited to Z-wave stuff. It’s just part of life with SmartThings.

1 Like

There are two specific models that are known to have problems with staying connected to the network.

The first is the GE/Jasco zwave light switches that did not require a neutral. A few months after the end of the warranty. Some fairly large percentage of these, i’m guessing around 15%, but that’s purely a guess, begin having trouble staying connected to the network. This has nothing to do with smart things, you will see the same complaints on forums from other controllers. Since the switches are out of their warranty., They are technically not defective. But it’s very annoying and it only seems to happen with this brand. You have to recycle power to the circuit, not just the switch, to fix it.

The second is the GE link zigbee lightbulbs. They drop off The network even when you’re still within warranty. Again, it doesn’t matter what the controller is, the Hue bridge has the same problem with them. Tyler has said there’s a firmware problem with them which is the reason they haven’t been certified for smartthings yet. There have been similar discussions in Phillips groups.

There are lots of other people that have problems with lots of other devices, but those all seem to involve local factors, not necessarily the model itself. I haven’t noticed any particular problem with a SmartThings controller versus a controller of another brand. It’s usually just either local interference, the way the network was laid out, or bench pairing without doing a network heal afterwards.

Much discussion about all of these in the forums.

Same here. It’s always a z-wave device. It’s random. The device worked flawlessy for 6 months or more. Sometimes it says incorrect device deleted during the exclusion. Something is corrupt. I have contacted support. They have never seen it before (???). I think something in their database is corrupt. Maybe a failed update query or something.

For me it’s usually the GE/Jasco that do require a neutral. And one time it was one of the GE/Jasco dimmers. I didn’t know they made an on/off switch that didn’t require a neutral.

Good to know, thanks.

The older models didn’t require a neutral, but were only intended for incandescent bulbs, not CFL’s or LEDs, so they were eventually replaced with the newer models.

This might be related, assuming something is corrupt in the table containing references to the devices.

A new device named “Z-Wave Device” just magically showed up. I didn’t add any devices. I wasn’t changing anything. I just noticed a new device in the mobile app.

Anyone else experience this?

I’ve got a GE/Jasco switch with neutral that I’ve “lost” about three or four times in the past 1.5 years, plus a GE/Jasco outlet that I’ve “lost” a couple of times.

One thing I discovered recently… I tried the new “replace” feature in the Mobile App with the outlet. When I did this it did a health check on the device and re-discovered it without having to delete, uninstall, exclude, include, etc. etc… Anyone who’s running into “lost” devices might want to try that and see if it helps.


Wow - I will definitely try that next time!

1 Like

Yeah, I kinda stumbled across it by accident. The one outlet that gives me trouble isn’t a huge need area so I kinda let that go for a while. But then when me switch went out too I decided to take the time to tackle 'em both. With thru the whole process with the switch:

Delete from installed apps, exclude, force delete, include, configure, re-install the needed apps.

Then I went to the outlet and accidentally hit the wrong button and Bam… the app said it found nothing wrong with the device and it started working again.

Obviously this may not work for everyone, but it worked like a charm for me.

1 Like

While this sounds like a more convenient workaround, it’s definitely not a solution…

I’d love to hear an official response from SmartThings about why this happens with z-wave devices and what (if anything) they could do to fix it.

1 Like

Doesn’t happen with most zwave devices, and it doesn’t appear to have anything to do with smartthings.

It’s a behavior that people see with GE zwave switches, usually a few months after they’re out of warranty, and it happens with many different zwave controllers, not just SmartThings. You’ll see the same discussions on the mirror and homeseer forums.

Since the devices are out of warranty, they’re technically not defective.

Since it only seems to happen with this brand, the people to talk to are the manufacturers of the device.

Sometimes devices are cheap for a reason, and shorter lifespans can be one of them.

It reminds me of the old Buzz Aldrin story (yes, this is an engineering joke):

Someone once asked aldrin what it really felt like to be an astronaut.

And he said

“everything feels pretty good right up until the moment when you’re about to blast off and you realize you’re about to go into space in a machine made with 34,000 different parts, every one of which was built by the lowest bidder.”

Just sayin’… :wink:

Interesting, I have a 12722 and a 12730 and have never had an issue with them on the Wink Hub and since I’ve been running them on the ST V2 hub, in fact they’ve been the most stable devices out of everything across either hub :smiley:

Doesn’t look like we use the GSM 900 band here in the US but lots of long range wireless radios such as those from Ubiquiti do use that band, so you may still find it’s interference.

The described behavior is not usually attributable to interference. Once it happens, the switch cannot be reconnected even for days. The usual workaround is to cut the power on the circuit for that switch altogether, then restore the power, then the switch comes back. Again, not a typical interference behavior.

No one is saying that this happens with all the switches of this brand or even most of them. It’s just a higher percentage than of other brands. Still probably well under 20%, so it’s not surprising if someone never saw the problem.

It also does appear to be associated with aging.

In the US there now only a few commonly used devices that would interfere with Z wave, usually older baby monitors and cordless phones. Much more common to get interference issues for zigbee devices here.

So it’s certainly not impossible that any one person may have interference issues. But those typically show different symptoms. And they wouldn’t normally be restricted to one brand. :sunglasses:

You know waaaaay more about the protocols than I JD so could there be anything with the way they network such that a temporary burst of interference could mess with their radio firmware or otherwise knock them off the ‘network’ with no recovery?

Temporary burst of interference are like turning on the microwave and having your Wi-Fi drop off while the microwave is running, and then come back again when the microwave goes off… It doesn’t knock your device off the network altogether which is what these GE switches act like.

That’s why I said it just doesn’t act like an interference problem. It acts like the radio in the device can’t maintain power, which is an entirely different issue.

It’s weird, and annoying, and as was said pretty much defeats the convenience feature of a networked switch. :sweat: but it does look like most of the time with this one that it’s the device, not the quality of the network.


To add a data point I had one GEJ/Jasco zwave that fell off for no reason after about 4 months. Added it back and it seems to have kept working on V2. This is only one data point but there seems to be a common thread in this… thread.

It was just an inconvenience at the time.