I am having trouble seeing the "My Testing Devices" in the smartthings app with developer mode

Hello,

Hope this is the right subgroup to post this.

I (and some of the other folks in our group) are having trouble getting the “My Testing Devices” to show up on the Smartthings Android app (ver 1.7.67.29). I don’t get the selection to show up next to the “Other” devices.

Things I have tried:

Enabling/Disabling developer mode
Clearing the cache of the smartthings app

Appreciate any ideas or help on this. Thanks!

Hey, @gunhunter

Have you already logged in to the Developer Workspace with that account? If so, try logging in again at the SmartThings App to refresh the account settings.

Hi Erick,

I didn’t try that until you mentioned it.

I just gave it a shot - logged into the developer area and logged out of the smartthings phone app, then relogged back in the phone app.

Still can’t see the My Testing Devices icon.

Thanks,

Paul

One other thing. I do have an active developer workspace registered to the same email address I am using the phone app from. Some of the other developers have the same problem, for some others the my testing devices works fine. Here are two screen shots to show that I think I am setup correctly.


Hey, @gunhunter

Thanks for following up.

Fortunately, I’ve been able to replicate this issue but it seems that it is a account-specific issue. I’ll share this with our team and as soon as I have an update, I’ll share it with you.

Most appreciated!

1 Like

Hi Erick,

I was wondering if you had found anything out with regards to this problem! Thanks!

Hey, @gunhunter

At the moment we’re still gathering the information that our team needs to keep investigating further.

1 Like

Hey, @gunhunter

I have good news!

The team has applied an update and I’ve been able to access the “My Testing Devices” section with the same buggy account referred above.

So, I was hoping you can help us to confirm the update by doing as follows:

  • Disable Developer Mode
  • Deploy a new project (either ST Schema or SmartApp)
  • Enable Developer Mode and check if “My Testing Devices” is there

Hi Erick,

The update did solve the issue. I was able to see My Testing Devices. Thank you and your team. A question I have is was this an update to everyone’s account or just mine? There are others in our development team that are having the same issue. Thanks!

Hey, @gunhunter

The fix was applied globally since it actually fixed the dummy account I used to replicate this issue.

Can you tell if these accounts are still facing the issue? If so, make sure they’ve made these steps: