Having trouble seeing the “My Testing Devices” in the smartthings app with developer mode

Hello. I know this is an older thread, but I recently created a device in my Private Workspace using the same email address that I am signed in to my Smartthings App with and Deployed it to Test. I have Developer Mode enabled in the app and don’t see My Testing Devices anywhere when clicking + to add a new device.

I tried following the guidance above by Disabling Developer Mode, Unlisted my device from Test, re-Deploying to Test, re-enabling Developer Mode and checking again. I also tried Unlisting from Test, disabling Developer Mode, re-enabling Developer Mode, Deploying to Test and checking, also with no luck. Anything else to try?

Hi, @smrtdrmmr
I moved this post to a new thread for visibility and because there were recent changes to the app’s “add device” section, so, we’ll discuss something different here.

Currently, when you go to “add device” in the app, you get two options at the top, in this case, you need to select “partner devices”.
Then, you’ll see “My testing devices” at the top section called “Recommendations” of that page.

Please, let me know if you cannot see this option. Thanks!

Hello and thank you for the guidance. Yes, I see it showing up in the place you specified as a device and Smart App. Appreciate your help! The docs could use some updating to indicate that.