SmartThings Community

Hub will not pair any new devices

#1

I have been using smartthings for a couple years and have around 40 devices on my network. Was trying to add a new dimmer a few days ago and could not get it to pair. After a frustrating 3 days of trying everything, I’m hoping to get some help. It’s a GE/Jasco zwave plus dimmer. I have at least 15 of these on my network with no problems.

I’ve tried a lot of stuff. I tried the general exclusion, and oddly enough when I run that and press the dimmer, it pops up and says that the device has been removed. But even after that, I can’t add it.

I tried removing another dimmer from my network and re-adding it, and it won’t add.

I’ve tried rebooting the hub both via software reboot and unplugging it.

Tried repairing the zwave network. Initially this came up with an orphan device I found in the logs, so I fixed that thinking I would be good to go, but still can’t pair new devices.

Tried resetting the dimmer although I can never get the LED to blink indicating a reset.

When I do a “Add thing”, I never get another on the app no mater how many times I cycle the dimmer on/off. However, when I look at the events on the IDE, I can see that it is finding devices… but it’s not presenting anything on the screen. I’ve tried reinstalling the app.

Tried to reach out to support, haven’t heard anything.

My home automation rules are dying because switches are missing. I have a lot of stuff in webcore. I complete reset would really not be preferred.

Any tips would be appreciated!!

(sidjohn1) #2

New app or old app?

#3

Old app. Was thinking of trying the new, but I remember trying it a few months ago and didn’t care for it. Have there been issues with the old app going forward?

(Tony Fleisher) #4

You might try rebooting the hub by removing any batteries and then removing power for a few minutes.

#5

Isn’t unplugging the power cord essentially the same thing? Tried that twice.

(Col) #6

Try saving and republishing the device handler. I had something similar with a couple of Fibaro dimmers. I was fiddling with the code and although I ultimately changed nothing I did save and republish it a couple of times. I may ultimately be a coincidence but has to be worth a try.

(Jimmy) #7

Look at the hub event logs in the ide and see if it is finding the device in the logs, but just not creating the new device in the cloud.

1 Like
(Greg) #8

This! I had this happen this weekend. I could not pair a device at all but was able to general exclude it without issue. Eventually caught in the hub logs that a device was pairing but no device was being created. If this happens to you - grab the DNI in the hub log. Create a new device using the same DNI and assign the proper DTH. Worked for me.

1 Like
6x GE Smart Fan Switch will not pair with replacement hub
Schlage Connect lock won't pair
Utilitech water leak detector issues: automations don't work
(Jimmy) #9

I had the same thing happen, but thought it was a hub firmware beta bug. Good to know about manually creating it. Those of you seeing this, are you on hub firmware 24 or 25?

1 Like
(Greg) #10

I’m on 24

extra words

(Jimmy) #11

Was yours a zwave or zigbee device? Mine was a zwave August Lock.

(Greg) #12

Zwave - Utilitech water sensor.

(Jimmy) #13

@Brad_ST is there an issue with creating new zwave devices in the cloud right now?

#14

In the hub logs, which is the device network ID? I see a bunch of stuff, like:

devicetype, mac, networkAddress, deviceAddress, etc

The rest of my dimmer switches like this have 2 digit device network ID’s such as 4C, 43, 40, etc.

I tried using both the devicetype and deviceaddress as a device network ID, but neither worked.

Thanks for your help

(Greg) #15

In the hub event logs it will be the value column.

Do you see the device joining?

#16

Ok so wow, spent so much time on this. Yes, I found the device trying to join but it never on the hub events from the IDE. It was network id “4B”. This is a GE/Jasco Z-Wave Plus Dimmer Switch. So it saw it and I created a new device in the IDE, but it still wouldn’t work.

I have a lot of these switches throughout my house, all with this great DTH that I have never had a problem with:

At any rate, on the hub log it was finding this using the DTH above, but the switch wouldn’t work. Keep in mind, it never found this on the app.

So I made a new device like you said using the network ID from the value column (4B in my case). Still wouldn’t work. I tried to switch the DTH to “Zwave dimmer switch generic”. Still wouldn’t work. Then I noticed a few of my dimmers have the original DTH of “Dimmer switch”. I switched the device that wouldn’t pair to “Dimmer switch”, and presto, had some luck controlling it. Then I switched to the custom DTH shown above, and it actually kept on working.

I have a feeling this isn’t a random problem. I’m not sure what the issue is. I bought a bunch of these dimmers in 3-4 group batches over time. When I installed it and couldn’t pair, I swapped it out for another one but the second one wouldn’t pair either.

My guess is something with this DTH is messed up? But I’m not sure why it all of a sudden started now. I’ll reach out to the author see what he says.

I have the other dimmer switch that I swapped out, same model, might try to throw that in to another switch to see if I have the same problem.

Hope this helps someone and thanks for your help. Wasted a lot of time on this! I’ll report back to this thread.

2 Likes
[BETA] GE/Jasco Z-Wave Plus Dimmer Switch With Double-Tap, Associations, And All Configuration Options (14294)
(Sylvain) #17

Thank ,
I had the same problem and solved it by doing your trick thanks.
Even the smartthings support was unable to help me.
They say , your dimmer is not support anymore .

(Broderick) #18

Oh man, thank you so much, I could not figure out why my hub would not pair my new GE Z-wave toggle light switch. I checked the logs, got the id (33 in my case) and created a new device using the correct device type (the first “Z-wave switch” intead of the 2nd one) and it worked!

I also use nutty-tree’s device type to enable multi-tap on my switches that support it.

(Jimmy) #19

Did you try republishing the device handler? There is a bug with them going stale.