Utilitech water leak detector issues: automations don't work

Are you willing to try doing the same thing in the Classic app? I have a couple of those sensors, and they’re working fine via the Classic app.

I tried it with both apps but will try again if you have suggestions of how to try it differently. Maybe I’m missing something.

What does it look like in the IDE? Similar to this:

1 Like

Yes, mine is similar. Although mine has nothing listed in the “in use by” catagory.

@johnconstantelo - I also notice that under status yours says, “ACTIVE” and mine says, “ONLINE”.

Perhaps this is a better way to go if I can’t get the Utilitech to work. Dependable leak alerts is one of the top requirements for my system. I’ve had basement flooding in the past. :worried:

The Utilitech sensor definitely works. I have one.

on your device page in the IDE what does your device say next to Type?

“Everspring Flood Sensor”

That’s OK. That will get populated as you add SmartApps that use that device.

Let’s try a couple things:

When you click on List Events, click on All events. When you try to trigger the sensor with water, do you see any events show up when you refresh the window? Like this:

What happens when you tap on the Configure tile in the Classic app? Do you see those message in the event log?

I just triggered the sensor with water and this is what showed in the IDE.

Tapping the Configure tile in the classic app does nothing. I makes a click sound but that’s it.

Ah, ok. Looks like the device didn’t properly get set up right.

You can try a couple things:

  1. Go to the device’s preference’s page (the gear in the upper right hand corner). Tap on Replace and then on the sensor press the inclusion button. Monitor the event log for the device and the event log for the hub.

  2. If that doesn’t work, Remove the device and then add it back, but this time do it close to the hub and then move it to it’s final location. Keep an eye on the hub’s event log too.

I’ve not heard mine click before, so I’m not sure what that could mean.

1 Like

Definitely watch the hub logs as John suggested. I recently had to remove my utilitech leak sensor and add it back in and had an issue where ST was recording the pairing but not creating a device. You can then create the device manually if that happens.

1 Like

Thanks! I’ll give it a try! :+1:


That’s the ticket! I had to cut some wires in order to move it but getting it closer to the hub solved the problem. Hopefully it still works when I move it back. THANKS!


I thought my “Everspring Flood Sensor” (monitoring sump) was broken since I had not heard from it in literally 6+ months. No battery update… forgot about it and flushed my water heater and it reported immediately.

Really impressive, but it should report battery more often for reliability checking.

Flood prone-areas, might as well have redundant sensors. Even a dumb leak beeper is a good backup. For an alternate notification path, eventually Alexa may notify you that she hears the beeper.


Switching over from HomeSeer, new to SmartThings. I added (exclude/include) 2 Everspring leak detectors. Devices created, but when I went to automation, the only “condition” is battery. How do I program alerts on a water leak detection? The status has a cloud with a slash thru it

gwesleyr, Exact problem description I have now and not getting anywhere…

I disassociated Everspring sensor, reset sensor and reconnected to network. SmartThings home monitor still shows no leak sensors connected…But I was able to set up automation that works (text manage sent when sensor detects a water fault).

I ended up installing the SmartApp “SmartThings Home Monitor”. From there I could do all the automations I would expect to see - very powerful.

1 Like

If anyone is still looking to get the Utilitech TST01-1 sorted out, here’s how I got two of them to activate the water sensor and eliminate the cloud with the line through it icon on a V2 hub: Add the device to ST as an Eversping Leak Detector, then go to the IDE and change the device handler from Everspring Flood Sensor to Leaksmart Water Sensor. You should then get a message from the ST app that the sensor is back to normal. Go back to the IDE and change the device handler back to Everspring Flood Sensor. You should then have a fully functional sensor that detects leaks.

I had 4 of these sitting in sealed boxes from when Lowes cleared them out for $7 a piece so that’s why I am just getting to it now.

1 Like

Thanks for this advice. Does this mean you are not yet using the edge connector?

that’s a crazy deal on a great device. It has audible low-battery alert (3 beeps) that is a little mysterious when you don’t remember which device is doing it. Crazy-long battery life and it works with rechargeable batteries. The only issue(s) I had are this cloud-connection which you seem to resolve, and the nearly silent history. There was a post to change parameters to report battery more often but I cannot find it now. I see there are old reports of faulty/sticky dry/wet status in some early hardware.