SmartThings Community

Cannot pair GE 12724 Dimmer to v3 hub

Hi everyone, my v2 hub recently died and I had no choice but to purchase a new one. So I bought the newest v3 hub and started the painstaking process of pairing all my devices.

I have three GE 12724 dimmers that I cannot pair. I have no issues excluding them, as soon as I put my v3 hub in exclusion mode and click the paddle the app immediately tells me that a device has been excluded. However, I cannot get them to pair afterward. I’ve researched and tried so many methods to get them to pair but no matter what I try they will not pair.

I’ve tried clicking rapidly, slowly, pulled the air gap switch, tried clicking up 10x, down 10x, etc, etc, etc. I’m at a loss now. It’s frustrating that I can exclude it over and over again but I cannot pair them.

I also have several Evolve switches & dimmers and I was able to exclude and join them without any trouble.

HELP!!!

if you have any custom handlers in the IDE, re-publish them/

1 Like

It happened to me lately (after last V2 hub firmware upgrade ). They actually pair, but do not appear.
Right after pairing I looked at logs in IDE and saw the network address they received. Then I manually created a new device with that address and the proper DTH (z-wave switch in this case) and everything works good.

Yes, I see that sometimes notification takes awhile between the cloud and the app.

I would recommend waiting until it picks a dth and not do this manually.

I would leave the SmartThings in pairing mode for a good long while.

Then reboot hub, restart SmartThings app and see if the device is then showing.

Or wait a day to see if the cloud is less congested and pairing is easier.

This did the trick. Even though I don’t have any specific custom handlers for my GE dimmer switches, I still went ahead and re-published all of them. All my GE dimmer switches paired immediately afterwards… go figure!

I don’t understand how these two are correlated but nonetheless it worked.