Hub stays offline after Internet outage. Requires reboot (AT&T UVerse)

Recently my Internet connectivity has been intermittently going down for a few seconds and then it restarts. (I’m working with ATT on fixing that) But every time it goes down my hub goes offline and stays offline even after the Internet connectivity is restored, usually in a few seconds. I’ve waited many hours for it to come back on its own but it doesn’t. The only way to get it back online is to power it down and up. It seems that this is a new issue with the hub and that in the past it has recovered on its own. Is there anything I can do to fix this? Very often it goes down while I’m away and I can’t reboot it for hours.

Please report this issue with SmartThings at

But meanwhile just to make sure. Have you replaced or updated the firmware on your modem/router? I previously had a wireless to wired bridge that after a firmware update caused the same thing you’re seeing. I rolled the bridge software back and it is working good to this day.

1 Like

I have not updated the router any time recently. I noticed there was a hub update last week though and I’m wondering if that caused the issue.

The hub doesn’t lose power does it? I thought i runs on the batteries for a time. It doesn’t reset by pulling the power cord out. I suspect your router has given it. DHCP address and when the router went back on it didn’t acknowledge that number anymore. There are router settings for DHCP refreshing but this is not the place to discuss that. A simple reset of the hub with the button on the back of it should take care of it. That may seem inelegant, but it’s simple and certainly the path of least resistance in “fixing” the issue. That’s my free opinion and it’s worth evry penney.

I am seeing the same issue. I know atleast 3 other people who are having this issue. It may be a good idea if some of you can test it out to see if it is a wide spread issue. I can confirm 4 cases totally and a support ticket has been created. @slagle @jody.albritton.

What happens if you give i a static IP? Wondering if it’s a DHCP issue.

Did not try it, will try it tonight and report.

1 Like

I’ve unplugged mine a few times on purpose just to see how it reacts during outages. I do this with almost all of my electronic gear. When power was restored, everything came back in quick order. No problems. Same with the Hue hub.

Found something interesting. The hub does not get connected again ONLY when the internet service provider is AT&T. I have two hubs , one at home and one at office. The one at office is AT&T and the one at Home is Verizon. When I disconnect Internet with verizon, the hub connects back after connection is restored . But with AT&T it does not. The 3 other people I know who are having this issue - All have AT&T Uverse. I guess we need to check some setting on the AT&T router. I still have to try what @slagle suggested.

1 Like

I’d call ATT up. It’s DHCP or a “security feature” they may be able to change for you by using MAC address, or if you can change your router assign a static Ip address as someone suggested earlier. You could probably fix it yourself if you’re versed in router setup. Google will help too of course. Good job diagnosing BTW!

I finally got to test this and it still does not help. I am trying to figure what settings on the router need to be changed to fix this. Any ideas?

My point of view on this is that the ST hub should not require any special router setup in order to simply communicate back to the ST cloud. No other software/hardware that I own has issues with very transient Internet connectivity issues; that is the very nature of TCP/IP, it’s resilient to transient issues. Certainly I can understand when the connectivity is gone that the hub may complain but it should simply retry again later to communicate and eventually it will succeed; in my case within seconds. This is really just very poor communications handling code in the hub, not something that should require special router configurations. Can you imagine any serious home automation product that requires customers to make special changes to their routers??

Is there any update with this issue? I am an AT&T Uverse customer and am having this exact problem. I get small internet outages at least once a day. Every time the internet goes down, the SmartThings hub requires a hard reset to go back online. It has make SmartThings almost unusable for me. It clearly seems to be AT&T’s fault, but would love some advice to fix it.

There is clearly an incompatibility between the ST hub and the AT&T U-verse network. Multiple users are reporting the same issue and I’m seeing at least one or two hangs per day on the hub at my vacation home where AT&T was the only Internet option. A static IP is definitely not the fix since I tried that first thing.

I’m not sure if it hangs after a network drop or if there is some other catalyst because the only effect I ever see is that the hub is offline and it never recovers. I have more devices on my network than most and none of them has any problem, just the ST hub. If it’s a router setting it’s going to be like finding a needle in a haystack without some clue from ST about where to start. I think mccarbc is right, networks are by definition going to be unreliable (that is to say there WILL be disconnects and drop outs) and it’s the responsibility of the hub to deal with that reality - everything else does.

This issue seems to have started with that last big firmware update a few weeks ago because I never saw this behavior before then. Since that day it’s rare to go more than 24 hours without having to do a hard reset.

I also am having the same issue, have tried using different switches and hubs and a new modem from AT&T but nothing works except for resetting the ST hub. I have sent a email to, if this continues to be a issue we’ll have to find another home automation system.

I had this similar issue. I lost connection and no matter what reset I did I couldn’t fix it. Found the issue in that some update that UVerse pushed down enabled IP-v6 which caused all types of issues. I disabled and it seemed to fix my issue part one. I have since had internet outages of short periods and the hub will not reconnect on its own. If I push the little button on the back of hub v2 it takes about 2 min and service comes right back up.

That is correct, I can reset mine by pushing the reset button but that does not help when at work or out of town.
The issue needs to be fixed.

Agreed! So exhausted from fighting with this system. Today the hub is green but the phone sent commands don’t show up in the app or live logging. Commands from smarttiles seems to work. Except for one outlet that didn’t fire at sunset and won’t seem to respond. Staying glued to this thread in hopes someone finds a fix.

I work for U-Verse tier 2 tech support and would gladly assist you with the problems you’re having. Can you confirm the modem model number (shown below the lights on the front of the unit) that you guys are using?

What I suspect may be happening is the disconnect that occurs on some of our newer modems are taking longer to reconnect to a WAN connection, so the hub may be not getting a connection when it tries during the first say 5-10 minutes, then it for some reason wont retry. This is only a theory, but I’d like to assist you guys any way I can. The particular delay I’m referencing should be resolved soon, but it’s only a guess - I don’t know for sure if this is related to the problem.

Also, if anyone is having issues with their U-Verse connection dropping and needs help please feel free to ask I will gladly provide any help I can.

As a final note, I am writing this message on my own time on my own accord - this is not a paid company response in any way. My responses are my own and is not an official representation of AT&T.


That is awesome that you want to take time out to help others after you do that all day. In looking deeper into my problem it seems that my issue may be two parted. The disconnecting happened twice but seems to have been working once IPv6 was turned off and/or the modem hasn’t reset. The other issue seems that one outlet has gone rouge. Lost all settings and will not respond to commands. I have run the repair utility several times with no luck at all. Anyways- info listed below if it helps and thanks for your time.