Hub went offline after rebooting the router

I am using a Asus RT-AC66U Wireless Router with DHCP enabled with a Motorola cable modem. I am used to schedule a weekly automatic reboot for the router. The Hub V2’s lights will turn blue and blinks when rebooting the router. It will stay like that for hours and will not turn green again until I unplugged the power and removed the battery from the hub, plugged back the power and battery.
If I just unplugged the power from the router. The hub will turn blue and blinks. Even after the router back to the normal operation, the hub will not recover.
When everything is working, I unplugged the Ethernet cable from the hub, it will turn blue and blinks. I waited for few minutes and plugged in the Ethernet cable. The lights will turn green and start working again.
So, when the router losing internet is not a problem but losing power is. The Hub Firmware Release Scheduled for 4/21/16 (Hub V2) fixed the AT&T UVerse losing internet issue, but my router losing power and caused hub stay offline issue started after the released of that firmware.

Try assigning a static IP to the MAC address of the hub. I think that you are running into trouble with the IP lease within the router not playing well with the IP that the hub thinks it has.

1 Like

Tried it. Same issue.

Refer to this discussion. This issue is solved there.

Thanks for the link, the UVerse was fixed on the 4/21/16 (Hub V2) update. UVerse issue was related to losing internet and the hub went offline. My issue is the router reboot or lose power, the hub went offline and stay offline even after the router resume operation. It may looks and sounds the same but it is not.
I am not sure if this is specific to certain manufacturer\model of router or a general issue.

This update does not necessarily fix the issue as mentioned by @slagle in another post. The fix would still have to be applied. Did you try applying the fix?Who is your ISP?

My router does not have the settings mentioned in that post, no such settings in the Asus router or Motorola cable modem. Cox is my service provider.
Isn’t the UVerse issue related to losing internet connection and hub remain offline even after the internet resume? The weird thing is I don’t have this problem prior to the 4/21 update. I can easily replicate this problem by restarting my Asus router or unplugged the power from the Asus router. Only removing and reconnect the Ethernet cable does not cause this issue.
@PhilB also has a same issue as I where he mentioned at that post just now.

Nope, you aren’t the only one. I have 20 network connected devices in my house consisting of desktops, laptops, ecobee, game console, roku boxes, and wifi cameras. Some wired and some wireless. Not a single one requires attention after rebooting the router. When that many different devices from a variety of manufactures recover from a router reboot and one does not (ST Hub), that tells you a lot.

1 Like

Do you mind sharing your router’s manufacturer/model info? Thanks

I’m using a Vizio XWR100 and I also have a Motorola cable modem.

Well it’s offline again…that’s twice today. Of course when I’m not home and can’t do anything about it. First time was about 10:30am central this morning. When I got home I rebooted the hub and it came back up. Then I left at 230pm and it went offline at 330pm. I won’t be back till 10pm tonight so guess none of my lights will do what they are supposed to tonight.

Of all the widely varied connected devices I have in my home this is the only one that can’t seem to get itself back online. That’s a problem!

We two seem to be the only experiencing this. :tired_face:
The hub still went offline permanently when I reboot the router as of last night.

I don’t know what is going on since the update yesterday. I’m not home so can’t see what is happening with any devices. My hub went offline twice yesterday and it’s now 9am central time and it’s already been offline twice today. The first time it came back online after 16 minutes without intervention. Don’t know if that will happen again. It’s been offline now since 8:43am with no indication it will be back. My internet is not down. I know this because I can access my IP camera.

Please contact and see what they say.

I’m afraid my life right now keeps me away from home a lot during the day. Just not in a place to provide them good information to work with now.

The Hub update on 05/26 fixed the problem for me.

This still happens to me. Any update?

Does assigning a static ip address work?

Static ip does not fixes the problem

My hub is still offline after the maintenance that happened 5 hours ago.