Hub Firmware Release Notes - 21.13


(Zach Varberg) #1

We apologize that we were unable to provide advanced notification of this update as we strive to alert you to updates before applying them. However, due to a critical concern regarding support for LAN video cameras, we needed to apply the update without advanced notification. Your Hub will briefly experience downtime of less than one minute as it reboots to apply the update.

Version

  • 0.21.13

Hub Target

  • Samsung SmartThings Hub (Hub V2)

Release Date

  • Thursday, May 3rd

Release Notes

  • Resolve inability to discover and control some models of Samsung appliances.
  • Security & bug fixes in LAN based video camera support

(www.rboyapps.com - Make your home your butler!) #2

Does this fix the parsing large camera image issue in the firmware which was causing the hub to lose connectivity?


(Allan) #3

My Ring Pro doorbell/camera which the video didn’t work at all a few months ago then did work with crystal clear video magically a month or so ago then only showed a green screen last week is now mostly working with random green thrown in. Take that for what its worth.


(Paul Osborne) #4

No, that is a separate issue which the LAN team is investigating. This has to do with locally connected LAN cameras like the Samsung/D-Link cameras (that work via video-core). E.g. https://support.smartthings.com/hc/en-us/articles/205380794-Samsung-SmartCam

I don’t believe there is any way this is related to anything done by the SmartThings Hub.


#5

My samsung room a/c still doesn’t work, it used to work but you guys managed to make a Samsung product not work with an app made by samsung, keep up great work and break more stuff!


(Paul Osborne) #6

Please double-check that your firmware is on the latest version (0.21.13) and engage support and hopefully they can help you get things working. Since the device may have been disconnected for some time while this bug was present there may be some extra steps required for the hub to find the IP address of the device on your LAN again.

If not, this information will be helpful for support to pass on to engineering.


(Allan) #7

The Ring Pro never had a video feed then magically it did then it broke then it came back without any changes to by the user. So somewhere there had to be changes on the backend, hub or DTH related.


#8

I was hoping for a patch on the hub to fix this since the last patch messed this up but guess i’m out of luck.
I did contact support 2 weeks ago and still no fix, the hub detects the Room A/Cs ip addresses but the app goes on loop and doesn’t add the room A/Cs


#9

My hub went offline randomly this afternoon and hasn’t come back online since! No idea what else to try!!!


#10

Have the samsung TV’s, model UN55MU6900 or lower been added to the devices that i can pair with my SmartHub?


#11

My Zigbee Bulb, Outlet, Open/Close Sensor and Multipurpose Sensor have gone offline since yesterday and don’t report accurate status or turn on or off.


(Jim Elliott) #12

When I woke up I had to reinsert the code to access my smartthings unit from my app like it didn’t exist anymore and was brand new and the only device I have so far on my smartthings hub, my front door lock (schlage camelot) is now not working. It’s almost as if I have to reset everything up again…is this normal occurrence when ya’ll push an update? I sure hope not.


#13

Hi @ all
Is it possible to download the firmware image somwhere?


(Kevin S) #14

This has been happening to my bridge a lot more lately. I’ve lost my scenes randomly or they’ve been reset as if restored from some previous backup, doing things I had them do before but changed more recently.


#15

Hi, can I ask you a question abour the Room A/C?
Its abot SSDP discovery, can yo see the UPnP device in Windows “Network” list?


(Javi Lopez) #16

Hi @Jim_Elliott this isn’t normal and is likely that you have logged into the wrong account without a Hub associated to it, hence why it asked you for the code. I’d recommend that you reach out to support as they can help you get things squared away.


(Jim Elliott) #17

Thank you, will do


(Tocker30) #18

I see there are ongoing issues with lan cameras and specifically Samsung cameras (ironically). I have an ongoing ticket for this but can you explain the parsing large video issue ? My hub doesn’t lose connectivity, but there is only one cameras video out of the three cameras that ever plays in smart home monitor and it is random on which one. I have no trouble with the live stream and never have. Is this the same issue or a different one? Thanks.


(Paul Osborne) #19

The other issues relates to devices like the community FOSCAM integration where the hub is downloading a large file (an image) from the camera via the LAN interface (which is usually used for smaller HTTP requests). Other cameras like the SmartCam HD Pro use a different process to handle video streaming that works differently.


(Tocker30) #20

Thank you for explaining that! So the issue with the Samsung cameras not playing videos in smarthome monitor is a seperate issue and is unrelated to the ability to stream the cameras. Is that correct? Thanks for your help.