SmartThings Hub no longer able to connect to Samsung Camera

Starting last night, the hub is no longer able to connect to the Samsung Camera (Pro HD). The camera did need to have a firmware upgrade today, and I can connect with the Samsung app, but not via the ST app.

Anyone else have this issue? It’s so hard to get through to support, I thought I’d try here first.

I am too. I didn’t think about the upgrade possibly causing that. No resolution yet. Did you submit a ticket?

I have three issues into them and they’re obviously buried in work. I guess this is probably a ST bug and can’t be worked around, so I’ll get another ticket in.

I had the same problem this past week. Deleting it and re-installing it worked for me. I wonder if it is related to that firmware update last week?

@obycode, how did you delete and re-install? What sequence of actions did you use?

  1. Removed all uses of the camera in SmartApps
  2. Remove the device (Things -> Camera -> Edit Device -> Remove)
  3. Add it as a new camera from the Marketplace (Marketplace -> Things -> SmartThings Recommends …)
1 Like

My pro cam is working just fine, and I didn’t have to do anything…

Thanks, I’ll try that exact sequence. Appreciate it.

Update: Unfortunately, ST can’t seem to rediscover the camera. I know it’s active on the network, because the Samsung app finds it. Did you have to hit the reset button or something to get it to start pairing? I’m using the “Connect existing camera” route, but it’s not discovering the camera.

I had the same problem after firmware update… I rebooted the cameras and then the hub found them again.

1 Like

Unfortunately, ST can no longer find the camera, so I’m assuming this is a dead issue for me. At least until support gets around to responding.

Hopefully if others run into this situation, your idea to re-boot will solve the problem before the remove the device.

You had your camera previously installed right? The platform can unfortunately cache DNI data for a small amount of users. Mention that it was previously installed on your ticket, support should be able to help get it cleaned up.

1 Like

I will, when they contact me. Thanks.

I had a similar experience. I was moving my camera to a different wifi (to which I had already moved my SmartThings hub to). In doing so, I was prompted for a firmware upgrade that I went ahead and did. But I could never get the live stream in SmartThings app. So I went ahead and removed the device from SmartThings, but I can’t add it back now. It simply can’t be discovered. The camera is connected because the stream is accessible from SmartCam app

Strange. It sounds like both of you are in the same boat. I definitely did the firmware update, and then was able to remove and re-add my camera and it still works now.

Hi Shelley,

After trying re-connection for a day, I stopped retrying for a day. When I tried again today, the camera was discovered. I don’t know what changed. I did not reboot the hub or the camera. And I had definitely waited for much longer in the past. So, for now, the problem seems to have been solved for me.

Most of our issues seem to be a disconnect between states in the cloud and on the devices. If the data on the cloud is cached, perhaps waiting a day allowed the cache to clear.

I’ve tried it, though, and no such luck. It’s almost as if ST doesn’t even try to find it.

I have a ticket out, so we’ll see.

Any update on this? Mine is doing the same exact thing yours is doing. Thanks!

Sorry, yes I should have updated.

I heard back from support, and they had to get the MAC address for the camera. They then deleted this from the cache, and I was able to then re-add the camera.

Thanks, I’ll open a support ticket as soon as I get home and can get the MAC address.