Hub Firmware Release Notes - 22.13


(Tom Manley) #1

Version

0.22.13

Hub Target

Samsung SmartThings Hub (Hub v2)

Release Date

Monday, July 9

Release Notes

  • Fix bug causing inability to control Zigbee devices for short periods of time
  • Local execution improvements and bug fixes
    • Add local support for the ZigBee Button DTH
    • Add local support for the Z-Wave Water Valve DTH
    • Add local support for the Cree Bulb DTH
    • Fix Dry events for some Z-Wave water sensors
    • Fix “Lock Code 99” bug for some Z-Wave locks
    • Fix Fortrezz Siren incorrectly reporting both the siren and strobe when only one is active
    • Fix for reporting 99% instead of 100% by Z-Wave multi-level devices
    • Fix incorrect attribute status after change for some Z-Wave water valves and dimmers
    • Generate power reports locally for locally running Zigbee and Z-Wave devices
  • Firmware updates for the following devices:
    • SmartThings - secure rejoin support
      • Water Leak Sensor 2015 US - FW 1F075310
      • Water Leak Sensor 2015 UK - FW 1F085310
    • OSRAM - various bug fixes (UK ZLL models)
      • Garden RGB - FW 01020412
      • CLA 60 TW - FW 01020412
      • FLEX RGBW - FW 01020412
    • Sylvania - FW 00102302 - Fix bug with light not always turning on
      • A19 RGBW
      • A19 TW 10 Year
      • A19 W 10 year
      • BR30 RGBW
      • BR30 TW
      • BR30 W 10 Year
      • Flex Outdoor RGBW
      • Flex RGBW
      • Flushmount TW
      • RT TW
      • RT RGBW
    • Sylvania - FW 00102303 - Fix bug with light not always turning on
      • RT HO RGBW
      • Troffer Kit 2x4 TW
    • Sylvania - FW 00102304 - Fix bug with light not always turning on
      • PAR38 W 10 Year
      • Troffer Kit 2x2 TW

Original & Aqara Xiaomi Zigbee Sensors (contact, temp, motion, button, outlet, leak, etc)
(Bill Gardner) #2

So will THIS update fix the non-connectivity issue with Samsung smart TVs that used to be compatible and work beautifully with SmartThings? It’s been broken for over a year and still not fixed. It would be nice for Samsung to fix this issue because the connectivity and compatibility is the only reason I paid almost $2,000.00 for this tv.


(Devesh Batra) #3

Generate power reports locally for locally running Zigbee and Z-Wave devices

Will we now be able to see IDE activity logs for switches and dimmers turned on/off by the switch or by locally executed routines now ?


(Tom Manley) #4

Previously the messages reporting power changes were handled in the cloud DTH for locally running devices. With the firmware update those messages are now handled locally.

The logs in the IDE are from the cloud DTH so for the most part there won’t be any logs if the device is running locally. You can see the generated events by clicking List Events on the device in graph. You can also force the device to run in the cloud by self publishing the DTH.


(Gabor Szabados) #5

Hi,

So this update is only for Zigbee and Z-Wave fixes? Or will be any fix for LAN connected cameras too, as the issue of the disconnecting Hub for the FOSCAM cameras image parsing to the cloud storage?

Thanks,

Gábor


(Tom Manley) #6

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.


(Paul Osborne) #7

(Andrew) #8

It looks like I’m updated to the new firmware, but when forcing an OTA update on my Osram Flex RGBW (UK version), I’m still stuck at the existing FW 01020492.

However, the firmware posted on these release notes (01020412) is a lower number so would appear to be older anyway?

Some clarity would be appreciated! This strip no longer speaks to my Hue Bridge since it was last updated through ST. I would like to pair back to my Hue Bridge and then control everything through ST if possible.


(Blaine M) #9

I received the firmware update and it seems to be working properly. I did not receive an email notification of the firmware push. I also did not receive a “hub offline” notification email. A colleague of mine had the same experience. Is there an issue with email notifications?


(Paul Osborne) #10

Email notifications should have been sent. If you DM me your email I can ask about why that might have happened. I received emails about the update for my work/personal emails with SmartThings accounts.

This is normal. Hub offline notifications are sent after ~5 minutes offline. A normal firmware update should only have downtime of ~30 seconds which is why no offline push notification was sent. You should be able to see the offline/online event in your event history still.


(Paul Osborne) #11

@Bryce_Geiser has been looking into this but I don’t think any patches landed for the 22.x release.


(Bryce Geiser) #12

The disconnect and image upload were 2 separate issues. The disconnect fix made it into 22.x, however the fix for image upload didn’t make it in unfortunately. There was a small change that made it in that makes it happen less frequently. A true fix will be in the next hubCore release.


(Devesh Batra) #13

not sure if its the hub firmware or something else, earlier, if i would go to a room, and click add device to room, it would only show me un allocated devices, now it lists all devices – iOS

Not a bad thing as now you can add same device to multiple rooms, but then makes finding devices harder


(Jimmy) #14

I noticed this too. I think that would either be app or cloud related.


#15

Yep but it was like that before this firmware update for sure.


(Beau Thompson) #16

looks like i was updated but got no email


#17

Ever since this update my Logitech Harmony hub will not turn on the dimmer lamp modules and switches. When you press the lamp button in the log it says: setlevel>>value:0. You have to slide the dimmer level up in the Harmony app for it to turn on. In the Smartthings app I noticed it now says 0 on the level when it is off. Before it showed the current level (ex. 99) even when it was off, and Harmony worked correctly then. It seems as though in needs to see the setlevel anything other than 0 to turn on. Is there a way to fix this so it work with Harmony again. The regular switches work fine, the problem is only with the dimmers.


Was there a change in how the level state is set in the zwave dimmer switch generic DTH when switch is turned off?
(Monty S) #18

Just want to echo what dcabtacoma said as well, experiencing the same issue and my jasco dimmer switches now dont work with the logitech harmony system.


(Steven Haas) #20

Regarding the upcoming reboot on Thursday 7/26/2018 - Will it fix the constant rebooting that I have experienced recently on a couple of my WEMO switches? They seem to be random but I have had 6 of them in the last couple of days.


(Ram) #21

I am in the same boat. Bought the Samsung tv specifically because of ST integration and it has been down for a year now. Samsung support doesn’t provide any timeline to fix this.