Hub Firmware Release Notes - 19.17


(Stephen Hill) #83

My hub has upgraded to 19.17 but now neither my Fibaro Dimmer 2, or my Osram Lightify bulb will work via Alexa! I keep getting getting errors such as:

“The Smarthings Hub that the DEVICE NAME connected to isn’t responding - please check on the hub.”

Please help!


(Allan) #84

A developer can answer better but my understanding is the “Smart Lighting” app is cloud based but the routines you create are either cloud or local depending on what you are controlling. I.e. the Smart Lighting app spawns child apps and those can run locally which is what yours is showing.


(Zach Varberg) #85

That’s exactly right. Smart Lighting itself doesn’t contain logic really, it’s just a convenient way for grouping all the lighting rules together. The individual rules will determine if they can run locally or have to run in the cloud and do so.


(Darell Craighead) #86

Cool, thanks for the answer.

Back to the discussion about sunrise/sunset… post said the are cloud then there was discussion they are actually local - which is true?


(Allan) #87

Local, scroll up or click this: Hub Firmware Release Notes - 19.17


(Dan) #88

When I had that same error message from Alexa about a week ago, I found the only solution was to hard reboot my hub. Afterwards, Alexa was happy again. Just be sure your firmware upgrade is truly finished before yanking the power cord (and batteries) out of your hub.


(Allan) #89

Look its that guy that broke my battery reporting. Ha. :slight_smile:

But seriously is there any plans on allowing the app to interact directly with the hub so we can use it locally if our internet is out? Example: We had bad storms a week ago and it took down internet and power for 4 days. I had a generator keeping the basics up (water heater, fridge, battery chargers for cell phones). I got my router up and running so our NAS would work but I couldn’t do anything with SmartThings even though it was “up”. Automation still ran (those with devices that had power) but I was still down for 4 days.

On the same token what about things like Konnected or ST_Anything that are network based from a device directly to the hub. Any chance of those ever working locally or would all their device handlers need to be verified and also run locally (which I’m assuming would never happen).

-Allan


(Stephen Hill) #90

Bingo. Hard reset fixed it. Thanks!


(Zach Varberg) #91

I did make that infamous change yeah. We had reasons for what we did, but it hasn’t exactly worked out as we planned. I can’t tell you how much of a headache accurate battery reporting is, but it’s being worked on. There are a lot of nuances and I’ve stayed out of the discussion because it’s hard to explain things without straying into stuff that isn’t external.

As for direct phone to hub control, and arbitrary device types running locally, I’m very hesitant to talk about potential future features and work. SmartThings doesn’t exactly have a sterling record when it comes to claiming features are coming and then delivering on them. So until a release is on it’s way out with the features claiming they are coming could just lead to more frustration and disappointment. I will say that those are both things that I would personally like to see, and we have recorded internally as desired features.

Sorry for the hand-wavy vague answers. I’m just a embedded software guy, big picture stuff isn’t my call.


(Ron S) #92

My hub went offline couple of minutes back and still is for past one hour.

In the IDE, I see

hub updater action: notify, status: SUCCESS, target: FFFFFFFF, version: FFFFFFFF, hardwareInfo: 000F and bunch of other info.


#93

My hub just updated! Local Hue control FTW!! Can’t wait to try it.


#94

Both my hubs updated OK … I think, LOL … I’ll find out when I get home (CA) tonight …


(terence peace) #95

Mine has now updated. So far so good.


#96

I just tried turning on/off a few of my hue bulbs and the device performs the action almost before my finger comes off the button. I already had really great response time when it was running via cloud, but it’s almost instantaneous now.


(Ron S) #97

How long did it take to update? Mine is stuck at more than an hour now. :frowning:


(Weston T Turner) #98

Not a developer but as I consider myself a “power user”, I absolutely agree…

I have a large number of inovelli dual outlets and all are running by “cloud” processing. This doesn’t make any sense since there are plenty of simple smart outlets that don’t require cloud processing and are processed locally.

Does anyone know a way to get the inovelli outlets to run locally? Can you just go in and switch the device handler to one that will run locally? Or would this be a big mistake?


(RH) #99

Is your system working right now otherwise? That’s way to long. Maybe your browser or app is hung up. IDK.


(Bob) #100

Hi @tpmanley anything you can do for this user.
I suggest you do not reboot until support can take a look. You might make things worse.
I would reach out to support if I were you.


(Ron S) #101

I did. And I am not touching it. :slight_smile: Thanks!


#102

I was in a deep sleep when mine updated so I don’t know how long it took. It was totally transparent to me. No issues so far.