Hub Firmware Release Notes - 18.18

The hub in my Samsung Connect did not update and is still on 17.54

Connect Homes are not on the same firmware as v2 Hubs so this is expected.

1 Like

I got an email from verizon (I have fios) today about about “Unauthorized traffic originating from your IP”. It looks like something from my IP tried to ssh into a fios node (or something) with root login. I only have a linux server running and I haven’t installed anything on that in awhile other than my home automation stuff. With the email last night about a SmartThings hub update for a vulnerability I wonder if this is related in some way.

Me too and I have siren

I had to reset 6 ST branded devices after the 18.18 update. Now I had to do two more after the 18.22.

Thanks for reply.

What is going on my android app presence function still not working while I cannot access the smartapp from android app to configure anything , no issue for last few updates except this one
Powered off the hub no improvement

Are you saying that your mobile presence is not working? That is completely independent of the Hub. The Hub firmware update would not impact that at all and rebooting the Hub would also not help.

I use that function to disarm my siren everyday when I arrives home after the firmware update there is some delay when running the I am back routine so my siren is triggered by my door sensor just before the disarm action in I am back routine is run,
I have raised a ticket and hopefully it can be fixed otherwise I need to disarm manually using my keypad

Another even more ridiculous thing is I have many timeout accessing smartapp/routines in the android app or just the favourite screen for the SHM section, I tried to update android app, reinstall it and fall back to old version I have and all not helping until I grab the android APK from another phone which is running much older version without the favourite features and seems it works perfectly fine, it is just too annoying

What am I getting so many errors with this release? 18.22 to be exact…

  • unable to load your home solutions. Plse try loading them again.
  • failed to start z wave network repair
  • an unexpected error occurred…

I also have a serious lag issues between turning on a light until the physical light is actually turned on.

I have 18.22 and sometimes the hub picks up my things other times they are not there in my android app.

I just signed in to my IDE\SmartThings locations and it says I don’t have a HUB or any device?

I have restarted it but it’s still the same. What can I do to get this working?

Thank you.

It’s picked up my Multipurpose Sensor. But it says it’s always open! wtf going on?

For this particular issue I would think you have logged on to the wrong shard.
When in the idea click on locations then home.
This will take you to the correct address.
Bookmark the address and use it in future.

Thank you.

I tried that but I’m still having problems.
I will follow the “how to factory reset” my hub 2 and hope that sorts it.


Try following these directions and if you are a fairly new user, make sure you select “Samsung Account” instead of “SmartThings Account”.

1 Like

Thanks again for your help. Trying to start a new I get

500: Internal Server Error
Reference Id
Sat Sep 02 13:55:32 UTC 2017

I have asked samsung support before but they did not know what to do.
I’ve posted on this forum about the error but no help either.

I will have to wait till the error is fixed.

For the first time in the year we have had our hub (I know, hard to believe) after 18.22 my wife’s ST presence sensor said she was not present while she was still at home. After about 10 minutes her sensor showed she was present. I hope this was just an anomaly.

Also, since 18.22 my Minimote has said unavailable.

You might try replacing the battery. The reported battery level on these sensors is unreliable.

The battery in the presence sensor is just a couple of weeks old and the Minimote has a fresh charge.

My Aeon Minimote is showing the same “Device Health” warning. I charged it, used it multiple times over a 2 day period and it still shows as being offline (yet it works fine.) So, I disabled the Device Health feature as it seems to be more buggy than it is worth, IMHO.

I use the very simple “Device Monitor” and “Battery Monitor” SmartApps which seem to work very well.

What is your “Presence Sensor Timeout” set to? Often, increasing this timeout a little can greatly reduce false alarms.

Note: For 1st gen presense sensors, you set the timeout in the ST Web IDE on your hub’s page. For 2nd gen presence sensors, you set the timeout in the device configuration settings page in the ST App on your phone.

1 Like