SmartThings Community

Hub Firmware Beta 0.20.15


(Zach Varberg) #1

Version

  • 0.20.15

Hub Target

  • Samsung SmartThings Hub (Hub V2)

Release Notes

  • Fix potential corruption of some Zigbee messages
  • Fix crash caused by certain mDNS answers
  • Improve Z-Wave debugging options

Release Date

  • Tuesday January 23

(Gonzalo Parra) #2

I was hoping to be included in these Betas so I could get the new Z-Wave Beta firmware as I want to test if this fixes the problems with the Leviton Z-Wave plus switches and dimmers before my return window for these is over… My application at CenterCode has been awaiting for approval for some time now, anything else I need to do to be included?


(Zach Varberg) #3

Sorry but since we are hopefully reaching the end of the beta we aren’t accepting new people at this time. When we start looking to start the next hub firmware beta new applicants will be included.


Hub v2 Update to 19.20 (No advance notice)
Hub Firmware Beta 0.20.16
(Gonzalo Parra) #4

Do you have any idea how long will it take for this beta firmware to be pushed to everyone? I only want it so I can get the Z-Wave firmware pushed to me, not really interested on testing other betas beyond this one…

I only have a couple of weeks left to return all these switches, I really like them and want to keep them but not if they don’t work as they should, that Z-Wave firmware is the last hope…


(Joel W) #5

Is there a problem, as my hub usually updates with an hour after release?


(Jimmy) #6

was just going to ask what time this would roll out


(Jeffrey) #7

No update here either.


(Joel W) #8

I am updated as of a few minutes ago.


#9

Got the update about 45m ago. Ended up pulling power and batteries from the hub to get the Zigbee and Z-Wave radios back online and device control working post-update. Not sure if a reboot via the IDE would have cleared it, skipped testing that step since I happened to be sitting right next to the hub when the trouble was reported and confirmed.

Prior to the restart we were unable to control any switches via Google Assistant, ActionTiles, or directly via the SmartThings app.


(Jeffrey) #10

here also - so far so good


(Working on a secret project, are we, sir?) #11

Working like a champ for me so far.


( Cosmo) #12

no issues so far


(John P. Hoke) #13

I received my update about 630p EST (2336 UTC to be precise.

I did notice that a few of my Zigbee lights (Cree Connected Bulbs) turned on unexpectedly, and that some of my automations would not work as expected until I went into the mobile app and turned the device on/off.

Specifically - IRIS Door Contacts would not control either my Philips LED Strips in closets (on/off) nor Cree Bulbs (on/off). Once I went into the mobile app and toggled the specific lights we appear ok now.

Otherwise all is well


#14

I got a notice this beta firmware was supposed to be done to my v2 hub on the 23rd but according to SmartThings ide still not done.


(andrewjames) #15

I also received a notice for 0.20.15 yesterday however still showing 0.19.0002


(AaronW) #16

I am stuck at 0.19.0002 also. Look forward to hopeful stability in my mesh networks. :slight_smile:


#17

Might be unrelated but my hub has went offline/online a few times an hour for the last two days. Never had this before and none of my other devices are having connectivity issues. I pulled the power and did a reboot but it is still persisting this morning. If it is still doing it this afternoon when I get home I’ll research more. Just posting in case anyone else has the same behavior. It could certainly be caused by a lot of different things though.


#18

It was just a faulty hub. Everything is back to normal.


(Zach Varberg) #19