Hub Firmware Beta 45.6

Once you’re in a beta cycle, you’re in it until the entire cycle is completed.

1 Like

@Kianoosh_Karami @cbaumler

Received the firmware update.

The Ikea 5-button remote is working again.

The Ikea motion sensor is also working again, after removing and adding it back.
The reported battery percentage doesn’t seem accurate (37% in ST, 100% in Home Assistant Zha). Batteries were replaced last week.

I put a fresh battery in the 5-button remote and it’s reporting 100%

Hey @Diegocampy , Sorry for the late reply. I believe I have fixed your centercode account, please feel free to attempt again. We do monitor both the community and centercode just as closely.

1 Like

Finally had some time to look into this a bit more.

You CAN see the firmware version of your devices via the CLI.

My On/Off Dimmer is device number 14 according to the “smartthings devices” CLI command

Entering the command “smartthings devices:status 14” gives me the following info in the data dump:

firmwareUpdate currentVersion “23079631”

Ikea firmware version 2.3.079, which is the most recent for that device.


It’s a known issue.
the battery is not related to the hub firmware it’s a driver or device firmware thing .

1 Like

9 posts were split to a new topic: Several events causing issues in the Hub

As of last night my Smartthings buttons have now stopped registering button pressed. They survived the 45.6 update but 45.9 seems to have killed them.

Try resetting it (not removing it) and see if that helps any.

I did get an incident e-mail this morning from SmartThings, could be related?

1 Like

My v3 hub zigbee module is “not detected” again. It worked for a day or two, now right back to no zigbee…

Today many have problems, ST has problems (see notification of disservice) and strangely to me everything works and I have not had new disconnections since I have this firmware. Hopefully :crossed_fingers:

Just to update you I have the 45.9hub v3 firmware. I removed my IKEA dimmer button and re-added. Button pressed are still not being registered but battery is. I do not have any way to update the IKEA dimmer firmware. Ikea motion sensor still not registering motion after removal and readding.

Edit added additional details

There is also a fix to the Edge driver that doesn’t seem to have been pushed out to the channels yet. I don’t understand Zigbee well enough to know whether you might need that.

Thanks for the update? Do you know where can I find info on this?

I think Graham is referring to this PR:

1 Like

@Automated_House reading the link it looks like it was merged 6 days ago. Does that mean they should be working again? If so, the IKEA devices are not but I’m not sure who to report it to.

No, that just means the code has been accepted into the main repository. It next needs to be pulled across to the beta repository and deployed into the beta channel from there, and there is a similar process for production. When I was waiting for fixes for the Sonoff button a couple of times it was taking up to two weeks from initial acceptance to hitting the beta channel.


I hoped to have solved the disconnection problems, instead I see from IDE a disconnected switch while from App still not, but I’m sure it will happen soon in fact it does not work from App.

I looked at the hub messages and noticed these multiple Trani error messages. Can anyone help me understand what they are?

I do not know if the problem is related to this firmware

Ps after 2 hours: The lamp came back online without ever going offline from the App (only to the ide) , so it was only a temporary problem, but I still have doubts about what the hub was doing.

The IKEA dimmer buttons are registering button pressed again after removing and re-adding. Now if the IKEA motion sensors would register motion I’d be all set. Thanks for the guidance!

This pull request may resolve the issue of IKEA motion sensors not reporting motion.

1 Like

Thank you for the update and sorry, I’m not a developer so I’m just guessing here but github says Review required, 2 of 8 tests failed, Merging is blocked which means this hasn’t been implemented yet?
If correct, will you let us know when the fix is pushed out so I don’t have to keep deleting and re-adding the device please?