SmartThings Community

Hub Firmware Beta 25.26

While I had a Custom DTH installed I haven’t been using it.

Having said that I removed the DTH from my IDE re-installed it and everything it working great.

Thanks for the help.

2 Likes

After many attempts, resetting, excluding, including and trying other devices handlers, still are my fibaro motions sensor and my Schlage door lock offline. If I include these using Homeseer or Levition, the before mentioned devices works fine. Is there a possibility that factory reset of the Smartthings Hub leave traces of previous devices causing connectivity issues? Is so strange that all devices included after I had to reset my hub all received node id’s greater than 40 while I had about 40 devices before. Ho has the same issues after resetting the hub just after the beta 25.26 firmware update?

Have you removed any custom device handlers in the web ide?

I’m investigating your issues.

2 Likes

I managed to get your lock back online. Somehow a parameter in your Z-Wave module’s persistent memory got set to an invalid value. I’m still trying to track down the root cause, but I’ve created an internal ticket to help us track this and resolve it so that nobody will have to deal with it in the future. Did you by any chance put your hub in Z-Wave learn mode at some point?

I couldn’t really tell much from the logs regarding your motion sensor, because they did’t go back far enough. I might be able to find out more if you exclude the device and add it again and then let me know so that I can pull the logs.

3 Likes

Hi @cbaumler, this may or may not be related to the beta, or now the public release of this version, but I opened a support ticket regarding my hub going through disconnect/active events repeatedly. It started a couple days ago with 2 hour intervals between these soft restarts, then it increased to every 1.5 hours, and now it’s every hour. For your reference, it’s ticket #719090.

2 Likes

Thanks for bringing this to my attention. I’ll make sure someone is looking into it.

2 Likes

Thanks a million Chris, very much appreciated! The lock is now working. I have excluded and included both sensors. They are now online but motions are not properly detected in Smartthings.

Thanks Chris!

did someone figure out how to fix this? my z-wave devices are also not working. i have firmware version 025.00026. i must somehow be in the beta? yikes!

That’s now the public release. Have you tried rebooting your hub?

As Jimmy said, you have the public release and are not part of the beta.

It looks like your Hub is having difficulty updating the Z-Wave firmware. I’ll flag it internally and see what we can do.

Hey ST Staff Members,
I think I found my zwave problem. I seem to have a haunted hub.
Will one of you fine folks go in there and kill some ghosts for me, Please?

You’ll find them hanging around nodes:
04
08
0B
1A
1B
22
37
6F
92
B2

None of the devices are actually in my system.
Thanks.

Are they working now? If not, can you be more specific about what you tried and when and what the expected and actual results were? That would go a long way in helping troubleshoot. Thanks.

1 Like

I’ve force deleted the nodes you listed.

1 Like

Thank you very much

1 Like

I’ve never had ‘hub disconnected’ messages previous to very, very recently … now I’m getting multiple notifications daily. Many times I click the instant the message pops up on my phone and the hub is fine, completely available.

Yes I have power cycled it.

Hub firmware 0.25.26 has been released to the public. Please refer to: