SmartThings Community

Hub Firmware Beta 25.26

(Chris Baumler) #1

For those who are part of the 0.25.x beta test, we are releasing new firmware:

Version

  • 0.25.26

Hub Targets

  • Samsung SmartThings Hub (Hub v2)
  • Samsung SmartThings Hub (Hub v3) (2018)

Release Date

  • 3/25/2019

Release Notes

  • Fix bug that could cause the Hub to reboot if no IP address was received within 20 minutes of boot.
2 Likes
Hub Firmware Beta 0.25.25
(Jason "The Enabler" as deemed so by @Smart) #2

I still have a multitude of zwave devices that are showing as offline. They are not responsive in the app or via Alexa, but they do tend to respond in automations.

Can I get some help with this?

2 Likes
(Chris Baumler) #3

I see that most of the devices are switches. Would they happen to be older Jasco models? Those have a hardware defect and may require either a hub reset or pulling the air gap.

(Alex) #4

I am not aware of blocking anything and have not changed anything recently that might result in blocking but I am not very experienced with Unifi’s firewall settings (which is also why I have not taken steps to block things). When I load the link above in my browser I get an empty HTML page - literally:

<html>
<head>
</head>
<body>
</body>
</html>

Last night I connected the ST hub to the ATT Uverse Gateway and the disconnections have not happened so when I get back home I will try to connect it back to the Unifi equipment to see if it starts again. If it does, it would suggest some incompatibility with the Unifi system however what eludes me is why this seems to be the only device to have issues.

I have not detected any other device grabbing 192.168.1.40 (my chosen IP for ST hub) and there are no known active DHCP servers on the network. To be sure, I turned on “DHCP Guarding” to ensure my router is the only allowed DHCP server.

UPNP is always off for security.

What are all the ports used by the hub? I wonder whether I may have assigned one to something else I am doing. I have not changed any of my port forwarding but it is worth checking.

The only blocking that I partially implemented is GeoIP. Blocking incoming traffic from certain countries. I believe when I turned it on I went with the countries listed on an article as the most likely sources for random hacking attempts to private networks:

I believe the list also included Italy but since I am from Italy I did not want to risk blocking something I’d be interested in accessing.

I can certainly turn this off but it has been on for a long time with no issues to the ST hub.

I am not sure what else to look at. I can’t seem to find a place in the Unifi Controller where I can see all connections (IP/port) of a certain client.

The only other thing that may be relevant, even though it has not changed in years in my setup, is that the Uverse router is not doing a real bridge mode but rather double NATing. It passes the public IP to my Unifi router but it can still handle it’s own network. The only thing connected to that network is the cable box I haven’t used in years and currently the ST hub for testing purposes.

As mentioned in my other posts, the ST hub occasionally stops responding to pings while the switch and the DNS I use never dropped packets in the same timeframe.

The current firmware on the Unifi equipment has been running for 5 days. The issue, I believe, started later. If connecting back to the Unifi equipment makes the issue come back, I can downgrade all the switches to the prior version.

Last time this happened I was told that additional features were being added to be able to troubleshoot this kind of issues. I am hoping they are live so we can figure out what is happening.

(Jason "The Enabler" as deemed so by @Smart) #5

Most of them are switches and yes, they are the older Jasco models with neutral. I’ve had them installed for over two years without these issues.

I’ve tried pulling the air gap and several other things to get them to work.

What do you mean by, “hub reset”?

(jkp) #6

Support page list the following ports for initial setup:

network settings and make sure the following ports are open during initial setup: 11111, 9443, 443, 39500, and 37

(jkp) #7

I find it funny that you blocked South Korea :slight_smile: :sunglasses:

(Alex) #8

Now that I think of it… Samsung! I have no idea why it is blocked as I think it was right off a list. Whether the list was accurate or not, I have no idea. With more integration between ST and Samsung maybe that is now relevant. I’ll delete the rule to see if it helps. Thank you for pointing it out.

I am not messing with those ports in any way I know of.

This may have been the source of my list, not sure:

1 Like
(jkp) #9

I just added South Korea to the block list so I will test for you :slight_smile:

1 Like
(Chris Baumler) #10

Sorry. I meant device reset.

The logs show that we are polling the devices, and they aren’t responding. The older GE/Jasco switches have an issue where they overheat and exhibit this behavior. Other users have had similar issues, and pulling the air gap or resetting the device has worked for them. You might also try removing the troublesome devices and re-adding them.

1 Like
(Jason "The Enabler" as deemed so by @Smart) #11

Yeah, I’ve somewhere around 50 of these switches installed and have been installed for over two years… maybe even close to three years now.

They are working. When my automations are triggered, they respond. They just do not respond to the app for polling or action. They are also reporting information to the app.

This started a couple of updates ago.

It’s not the device, I can definitely assure you of that. It is most definitely your update.

(Bob Wise) #12

All my jasco switches and dimmers still show disconnected in new app. Was told by support known problem working on

Been like this for months

Any ideas? Still can control but they all show greyed and disconnected

Bob

(Kianoosh Karami) #13

What makes you so sure it is the hub firmware? I am not against that it is, but if we are polling devices and the devices are not responding to those messages, what are we supposed to do?

GE/Jasco switches have known to exhibit this problem and maybe if your switches are off the older models that are documented to have this problem, what can we possibly do to fix the issue where they do not respond?

Again, we are more than happy to make the changes to fix the issues you are reporting, but in this eco system, if the devices do not perform as expected, we cannot really do a whole lot for it.

1 Like
(Bob Wise) #14

My switches and dimmers are less than 6 months old

(Jason "The Enabler" as deemed so by @Smart) #15

When a device is working fine for years and the software changes, it’s not the device. That’s coming from almost 30 years as an Electronics Tech. I do not expect you to do anything with fixing my problem, you can’t. I am letting you know all of this so that you know something in your firmware is causing a problem with the devices. But, as it is randomly affecting devices, there is anything you’ll be able to do to accurately reproduce the problem.

I know that the Jasco switches have been reported to have issues. But again, mine have been running fine for years. And again, I do not believe there is anything you can do on your end to fix my problem.

Also, when the hub reboots some of the devices actually came back, but others were lost. This is yet another thing that shows it is the hub and not my devices.

If I believed for a second that it was my hardware, I would fix my hardware. My mesh is strong. Over 150 physical devices pretty evenly spread between zigbee and zwave. I fully understand how the system works, how RF systems work, and how electronics work.

In summary, this report was to be informational to you. Again, I understand that nothing you can do on your end can fix my current problem. If you can’t talk to the device, you are crippled. I will fix it on my end and let you know if I have any more problems.

BTW, you haven’t heard a lot from me in the beta threads because I have not been having any trouble with my system, until now.

Thanks,
Jason

(Kianoosh Karami) #16

Jason,

I understand where you are coming from, but let’s assume that the firmware on your hub had not changed, and the same issues started occurring, would you then still think it was a firmware issue?

Also, the same reasoning should technically be applicable to the release of the new firmware. Has the new firmware been causing this issue to occur from the moment it was released? I guess what I am asking is what prompted the new firmware to all of sudden causing this bug in the past days? The new firmware has been out for months.

I do not want to question your experience and troubleshooting skills, but I think you have to build some trust and confidence in our skillset as well, and trust us when we point the issue to the device. It really is not matter of pride or anything like that, if anything we would be the first people to admit an issue on our end. My objective is to help you, and you can ask lots of other users here that we have taken responsibilities for issues or have tried our best to make sure we can help you resolve the issue.

Again, If you really do not believe us, which is fine by the way, you can prove us wrong by showing us an over the air trace that can help both of us to resolve any bugs.

(Jason "The Enabler" as deemed so by @Smart) #17

In this case, no, I would not start with the firmware as the problem. I would look for any other changes in the system that may have occurred and I would focus on the device. But, since firmware was updated in past days, I start with that. While the part of the firmware for the switches may not have changed, something in the update could have caused an issue.

Now, I do not believe it is the code itself, but the fact that it was an online update. We all know how packets are damaged and lost in the internet. That is most likely the culprit in all of this.

I’m not questioning your experience or troubleshooting skills either. I’ve been with SmartThings since Sept 2015 and I have been extremely active on this forum since, as in a daily user since signing up.

I do believe you and I know it is not anyone trying to brag or anything like that. But like I said, I know you can’t fix it on your end. All you can do is look at the low level logs that I am unable to access for any possible causes that may stand out, or contribute to any data trend in your records. I only see the big picture for my network.

So, no worry and no hard feelings here. I know you guys are great at your jobs, which is why I’m in the beta program to begin with. Trust me, I’m not a gluten for punishment, I like to help.

I’ll get my devices back online today and I’ll report any other issues in the future.

And, on that note, one last thing. Normally, in the past, when a zwave device decided to act up I could cut power to it and start the zwave device replace function in the app. When it was ready to replace I would replace power and activate the device, this would bring it back into the mesh in the exact same location.

That is no longer working. I am having to reset my switches using a minimote and add them back in. As you know, that’s a real pain in the butt… lol.

Thanks for taking the time to look into this and take note of the issues.

1 Like
(Kianoosh Karami) #18

Thanks for your response. Well, keep us in the loop with anything that you find, there may be things that we can do, at the very least we can try.

1 Like
(Jason "The Enabler" as deemed so by @Smart) #19

Something else of possible importance. The devices are not responding to polls or actions from the app, but they do respond to automations.

If you look at my switch, Kitchen Cabinet Lights, it does not respond to the (classic) app at all, but automations work just fine with it. The automation in question is also a locally running automation in Smart Lighting.

(Jimmy) #20

@bamarayne What status does it show in the IDE?