SmartThings Community

Hub Firmware Beta 25.26

Have you tried changing the DTH and then changing it back in ide? What DTH are these using?

I saw the same thing happen with some of the old GE switches here. Albeit it is with the 24.x firmware (current release). The funny thing was like you said it very extremely slow or didn’t respond to manual control from the ST app or polling. The only solution each time was to reset the device (switch it on and off 10 times quickly) or power cycle the mains or exclude and re-pair them and then it works for a while and then it would start giving trouble again. With automations it was a hit or a miss, it worked sometimes, others not and sometimes it would be delayed by upto a minute and then quickly run through the backed up commands.
Finally gave up and replaced them with the newer Z-Wave Plus devices and it’s been fine since. Could be me but I think the devices just got old and with age they got more troublesome like the Kwikset lock modules.

1 Like

They are showing the last status reported before the “incident”

Yes, I’ve tried this.
They are using the stock zwave switch dth that sounds lovely.

Troubleshooting my disconnects I noticed something interesting…

When the hub was connected to my regular networking equipment, the Event List was packed with

index:86, mac:xxxxxxxxxx, ip:xxxxxxxxx, port:xxxx, requestId:xxxxxxxxxxxxxxxxxxxxxxxxx

Once I connected it to the ATT router directly, it went dead silent in a sea of ping rows. The rows described above showed back up in the same volume once I hooked my hub back to the Unifi equipment.

Is this normal? Keep in mind that the sea of pings was mostly at night but I do not see any activity when we got up either.

The only 2 exceptions were (no editing):

zw device: E1, command: 8407, payload:

zw device: 57, command: 3202, payload: 21 32 00 4B 00 00 20 45

And there are no devices with those HEX IDs. Ghosts?

All in fun :slight_smile: :

So ONLINE?

oh, No they are showing offline. Not all of my devices, just some of them.

What was the distinction between ACTIVE and ONLINE? I thought was was supposed to replace the other.

In case anyone is wondering, these are one type of switch I’m having the problem with.

This is an in wall paddle switch.

I am also having the same issue with the GE outdoor module switches. The black one with the short cord on it.

Oh, I forgot to mention these are doing it as well now.

These are offline as well…

This thermostat is offline as well:

image

To much of a coincidence that all of these devices broke at the exact same time.

For some reason this slipped my mind earlier. This is the #1 reason that I know it’s not my devices. This all occurred at the exact same time.

GE/Jasco in-wall paddle switches
GE/Jasco in-wall duplex outlets
GE outdoor switch modules
Honeywell 8320 zwave thermostat
Monoprice motion sensors

All are zwave.

Do those devices have a checkInterval entry under current states?

yes, they do.

1 Like

Just for a data point. I’m not on the beta and I have these devices. I’m not having an issue with them currently.

I’ve had the paddle switches be unresponsive in the past.

I’ve had these for over two years. Every once in a blue moon I would have trouble with one. But with this many device types, it’s not the devices.

I’ve had the same problem with 25.x firmware. Random switches went down after receiving it. Also experienced significant lag on some switches. All ge/jasco. Only had problems with older ones so was told I need to replace as it’s a known problem. Had them all installed over 2 years and never had a problem. Zwave Mesh is strong I believe, reboots would fix some temporarily. Mine would always work at the switch, automations we’re hit and miss. I agree that something in the firmware changed and altered the interaction between the hub and these older ge switches.

@jamesonrw

I just took a look at your hub and your Z-Wave network, and all your switches minus one is online, I checked the hub logs and they are all communicating as expected.

If something unexpected occurs, please PM me with the info

  1. Which devices (Name or device ID)
  2. Timestamp
  3. What was the issue observed

Obviously, everyone else is more than welcome to do that as well.

1 Like

Have you had any disconnects? Since I plugged the hub back in to the Unifi equipment and removed South Korea from the blocked countries (incoming traffic only), the hub has worked fine without any disconnects.

I have not seen any disconnects since adding SK.

I was able to bring them all back, except the one, last night by switching the dth to a cloud based one and then switching back to the correct dth. It seems that you guys have a duplicate driver in there for the z-wave switch with the same name (z-wave switch) and one of them is AFU.

Do you think you can get it removed?

1 Like

Are you referring to

vs

Nope. The two you posted have different names, one is generic and one is not.

I’m referring to this. In the device settings when you select a “Type” for the dth you are given two. See the picture below. One of them doesn’t work right. I can’t tell you which one because I can’t see the code.

image

2 Likes