Hub does not support edge drivers?

I think Ikea motion sensors are FUBAR’d on SmartThings until this pull request is moved in

Thank you for sharing your experience, does the “BadRequestError” you get also say “Edge drivers are not supported”?

I already shared your comment with the team.

The new iOS app release ( solves the issue.

Thanks for getting back to us Nayelyz,

Confirmed it also says that “Edge drivers are not supported”.

We have the latest release of the app installed ( and still experience this issue.

Mmm is it happening only for that specific device?
Have you verified if you see the Hub’s LED blinking or get any logs in the logcat?

It’s a series of devices we have issues with.
The LED on the hub does not blink to indicate that it goes into “discovery mode”. It stays solid green.

:scream: this is weird, I made a test in the morning and it worked…
I shared a workaround when this was an issue, please check if it helps:

Unfortunately, this workaround does not work. We’ve reset the hub again and re-configure it, but still nothing.
The LED stays solid green, so the discovery mode does not trigger on the hub.


Can the team just acknowledge that something is messed up here with Wi-Fi hubs not being able to load edge drivers and confirm with the community that a fix is in progress. It has been two weeks now that I am without edge functionality on my hub when prior to 10/10/22 I was able to load edge drivers. I can pin it down to almost an exact time when things broke.

In addition, I still have not been contacted by ST engineers.

This would be greatly appreciated to update the community.


I’m sorry if I wasn’t clear before, this is considered a bug, and the team is working on a solution. As there are more people reporting it, we already escalated it.
We understand this is something you have struggled with since a long time ago, we’ll keep pushing.

1 Like

@ecobiax, have you verified which drivers are installed in your Hub? If you’re getting the BadResponseError, it can cause an issue because by default devices are expected to connect to a Driver. If there’s not one compatible with the device, then one from the default channel should be installed but it could be facing the same “BadResponseError” but I believe this won’t be shown in the logcat.
The command to check the installed drivers is:

smartthings edge:drivers:installed

To check if this is both issues are related, could you send me the following information, please?

Note: It can be over DM or an email to

  1. The email used in your SmartThings Account
  2. Access to your data:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

thanks for acknowledging. I’ll look forward to the fix.

Is this firmware update going to fix this problem?

This is for v2, v3, and Aeotec Smart Home Hubs, yours is SmartThings Wi-Fi and you’re still in the version 43, this is a fix for the v45

Thanks. Yeah. I see that but was hoping the fix for Wifi Hubs would be coming soon as well.

The team keeps investigating but I already mentioned to them there’s another case about this, so they are aware of the impact. Sorry for the confusion.

Any update on this? I have not heard anything from Engineering or support. Thanks. I would really like to get my devices working.

Same here. None of our automations work anymore. It is getting frustrating now, knowing that we have a device plugged in that does not do anything anymore.
I do understand the team is working on a fix, but how did we lose functionality of the device in the first place? It worked OK after the update, and then it suddenly stopped. It’s basically semi-bricked.

Seriously unacceptable. Just roll back the devices to the previous state when everything worked fine while you figure this out.

Are we the only two people using the WiFi hubs as SmartThings hubs? That can’t be the case.


Any update on this? My hub is still not working and I have no answers from ST.

Still getting this error.

? Select a driver to install. 2
Error: Request failed with status code 400:
r”:{“code”:“BadRequestError”,“message”:“Hub (SmartThings Hub) does not
support edge drivers”,“details”:}}
mikegreenberg@Mike-Greenberg-MacBook-Pro ~ %

Hi, @Its2loud
Sorry for the delay. I already pinged the team again to get more info. I’ll let you know as soon as I hear something.