How to remove a rule created with Glitch?

I wanted to play with the rules API using this app Sample-RulesAPI/Sample Rules Apps/ at master · SmartThingsDevelopers/Sample-RulesAPI ( There is a link on that page going to SmartThings Automation Builder (

I went there, logged in, created a rule and … submitted it. Apparently I had to pay more attention to the name of the app :). Anyway, the rule was submitted and now and it executed periodically. That was “At a certain time” rule and I cannot find a way to remove it via that app interface.

If I run method using my personal access token it does not list the rules created by that app, that is not surprising. Here I would like to confirm my guess that rules are isolated on the access token level. Is it true or the isolation is implemented on other parameter(s)?

Now, the main question, how do I delete the rule that I submitted with the Glitch app?

Tagging @jody.albritton

Yes, that is correct. You could try manually calling the Rules API wit the same token to delete

G’day Alex,
I’m wondering the same thing for the same reasons as you. Did you figure out how to delete the rule created with the Glitch app? My experience mirrors yours, in that the rule doesn’t show up in the SmartThings app or in the developer area.
Your level of knowledge is way, way above mine and I didn’t really follow your theory regarding access tokens.

I am so frustrated. I have spent hours and hours trying to figure out the best way to make/edit/delete rules using the API now that Webcore is gone. I also used the to create a practice automation. It worked and I have an automation that runs every night at midnight.

I need it to stop.

I cannot find a way to delete these rules as they do not show up using{{location-id}}. The only rules that show up there are those created with that bearer token. The ones created with the glitch page do not show up.

Is there a way that I can delete ANY/ALL rules and just start over?

If I had hair I would pull it out.

You can easily delete API Rules using the API Browser+

Thanks for that link! I have already tried API Browser+ without luck. It shows rules I created with postman but not the rules created with the app. If I can just delete all rules regardless of how they were created, then I would be happy to reload my non-test rules.

1 Like

Doesn’t the Glitch app allow you to manage the rules it created?

1 Like

$%^#*^#$^$#$%^ if only it did!!
It doesn’t even have a way to view the rules you created. I don’t think that was it’s purpose. I was looking to learn more about creating rules and I did not even expect it to actually submit them.

Not only can you not delete rules you make, you cannot even list them. To be fair it the app is for demonstration purposes, I didn’t think it was actually submitting them and left me no way (i can find) to delete what was created.

Certainly there should be a way to purge all the rules on the Aeotec SmartThings hub.

1 Like

Have you ever used the ‘Log Out’ option?

Yup, If you log out you have to reauthorize the hub when you log back in. Unfortunately, It does not appear that the rules created go away. When you log back in, I have no way of knowing if that creates a new token or uses a prior one. It does not show you what token is being used. If It did I imagine I could use that token to delete the rules with CLI or postman or Browser+.

I am wondering if the companion Rules Manager app on Glitch can manage the Rules. I’m not sure exactly how it is all glued together.

That app actually does NOT manage rules built with Rules Builder Demo App… I wish it did. I tried it… no joy.

Clearly I am not the first person to have had this issue. For the life of me I have been unable to find anyone who has a solution except to break the automations by deleting the triggered devices and re-adding them and recreating all other automations that used the devices.

That doesn’t mean you’ve actually removed the rules or attempts to run them, Smarttings will just not be able to find the devices… not very smart.

1 Like

Tagging @jody.albritton

1 Like

They made a change last week to the way the cli works. It used to be that it would show rules created with a PAT, but it was changed to now show rules created with oauth. You may want to try again, as (if I recall from my brief look at glitch it uses oauth) it may work for you now.


I briefly had a go at it again, but was unable to see the rules created using glitch… I will try again in a few days.