Deleted Rule Still Running

Recently I noticed that a rule I had created and deleted, but was still running. Even if you delete all the routines, it still runs. Lights turn off at dawn, when they should stay on. The only way to check that it’s active is that it appears in the app’s history and that the commands to turn off light bulbs are executed. How do I solve this problem? The strange thing is that when you run the CLI, no rules appear, but when you query the devices through the CLI they are all there. How do I delete this rule?
@Brad_ST can you help me?

Have you used the API Browser+ to look for the rule?

You could try deleting and reinstalling the devices. That should break the rule.

FYI: Brad no longer works for ST.

Hi Paul,
I tried using my.smartthings and the CLI. She doesn’t appear anywhere. I can only see that she activated it in the history through the app.
This routine starts at dawn and more than 40 devices. You would have to delete everyone and then pair again.
I don’t know what “API Browser+” is and how to use it.

This site:


I checked the API Browser and the routine doesn’t appear either.

As you refer to both a ‘rule’ and a ‘routine’ here have you looked under both Routines and also Rules under the Automation heading on the API Browser. Maybe an unnecessary question but just to sure.


Both. The problem is in the routine. But I looked at both.

I ran into a similar problem in the past, and had to have the SmartThings team delete the rule manually.


Make sure you don’t have a rule set up under Smart things Labs. I had a similar one under Gentle wake-up and took a while to remember/find it again.


Hello everyone,
Yesterday I deleted several devices and I noticed. SmartThings support got back to me asking about a device that appeared to be unverified and linked to a routine that no longer existed and was active. I decided to delete the device and repaired it. I noticed that the device id changed. Apparently it has been resolved. At dawn today there was no power off of the devices that were power on. Today I started recreating my routines and reintegrated with Alexa. Let’s see how it goes this next night.

@TAustin , that’s what I asked support from the beginning, which was for them to manually delete the routine. But they informed that they do not have access to delete users’ routines and devices. Strange, but that’s what they answered me.

1 Like

Not solved. After deleting and recreating all my routines, device shutdowns in the early hours of the morning continue to occur. And now worse, no associated routine appears in the history. It only appears in the history that it was turned off. Previously, all connected devices were turned off at 4:48 am. Today they are turning off at 04:32. I do not know what else to do. I’m having a bad experience with Smartthings.
Could there be a problem with the Hub?

What is this device up to now? If it turns on/off automatically without you having specifically added it to an automation since the device ID changed then you have to look beyond SmartThings itself to things like voice assistants that address devices by their labels or the home/room they are in.

So were you experiencing problems without Alexa being integrated? As you may be aware Alexa integration is a red flag when things get turned off at unexpected times so it is always worth removing it from the equation when diagnosing problems.

So is 04:32 a meaningful time to you? Does it relate to your local sunrise (e.g. minutes the same but hours different) or an offset from your local sunrise that you have previously used in routines?

For over two years now, sunrise/sunset times have been failing to update daily when rules based automations run in the cloud (for me anyway), so the jump from 4:48 to 4:32 is the sort of thing you can see when you force an update in an automation after about a week or so.

1 Like

@orangebucket The devices that turn off are not in any routine. Due to this problem, I disabled Alexa integration for 1 week, but the disconnections continued. I have one routine to device power on of sunset. But i dont have to sunrise to power off. The time of 04:32 is not related to sunrise.
How can I check which command triggered the device to turn on and off in smartthings? If it was manual activation, due to routine, if routine, what was its name?
Thanks for all

To update,
Today, turning off by itself at 01:02