Can't remove Rule Machine app or factory reset hub


I hope I’m at the right place but I’m getting crazy after a few days of trying to remove a smart app called rule by Bruce Ravenel.

When creating a rule, I got an error one day and now I can’t do anything on this rule, neither edit it or remove it.

I tried removing all of my things and rooms and secondary user accounts but can’t remove the smart app either.

So basically here’s the situation : I have a broken rule based on a ‘‘thing’’ (door sensor). I can’t remove the thing because it says it’s used in a rule, and I can’t remove the rule because it says it’s used by the thing. And I can’t remove my location because it says something is using it.

I’m getting crazy :frowning: Can someone help me?

Thanks a lot for your time and help.

Tagging @bravenel

Did you try to remove the rule from within the IDE?

Login to the IDE (If you’re in N America)
Click My Locations
Click List SmartApps (At the bottom of the page)
Click the Edit link at the top of the page (Under your home image)
Scroll down until you see Rule Machine
Under that you will see a list of all your rules
Click Uninstall next to the rule you want to delete

1 Like

Did you try updating Rule Machine and Rule to the latest version?


Thanks for answering.

I tried via the IDE but I get this error everytime :
There was an error uninstalling your SmartApp.

In the ‘‘My smartapps’’ menu in IDE, when I try to remove it I get another error : This SmartApp can’t be deleted at this time because it is installed by one or more users

I thought it was an error when I copied the code so I went to github to get the last version and replaced the code but it didn’t help. Also, maybe that would help, when I go into the smartapp itself then use the ‘‘set location’’ button to set it, then try to install a rule, I get the following error in IDE ‘‘java.lang.NullPointerException: Cannot invoke method getAt() on null object @ line 1025’’.

When I look at lines around 1025, this is what I have :
def evalTerm() {
def result = true
def thisTok = state.eval[state.token]
if (thisTok == “(”) {
state.token = state.token + 1
result = eval()
} else result = getOperand(thisTok)
state.token = state.token + 1
return result

Maybe there’s a problem in the code?

Thanks again

You are trying to delete the smartapp without uninstalling the smartapp. Go into the IDE, locations and scroll down to installed smartapps. Click that and then click the edit button. Scroll down and find the installed smartapp you want to remove, click delete and then you can remove the code in the SmartApps section.

1 Like

Hi. That’s what jnschemm suggested and I answered that when I go to my locations, my smartapps, edit then ‘Uninstall’’, I get the ‘‘There was an error uninstalling your SmartApp’’ message :frowning:

Any other idea?

Do they show up in rule builder? Did you remove them there or try? Maybe a problem with removing in ide?

Of course, you can always open a support ticket. The ice has been really slow lately, might just be timing out.